CSD Games/Tumbleweed

It has been a long time since the Waking Titan ARG but, we keep returning to the memories. Good times! Some have been asking about our venture into the experience and what resulted from it. I knew sooner or later, @DevilinPixy would pop in and say, “What have they been doing? Posting all of this in the incorrect thread…” :sweat_smile: So, here is a fresh thread for everything CSD/Tumbleweed/Waking Titan related.


sheralmyst-(So this all started with me being struck repeatedly by lightning, to which @Polyphemus replied)

Thinking back, it was about this point that Prof. Popocatapetl disappeared. Maybe you’re about to jump time lines.

sheralmyst-(After which I posted the video about Pop)


Where is all that stuff from, then? The only thing I find when googling “Professor Popocatepetl” is a volcano. Feels like I’m missing a piece of pop-culture in my library…


It is, of course, part of the historically consequential and scientifically revolutionary research conducted by a team of lunatics brilliant game developers known as CSD Games!


Ah… some offshoot from waking titan, then :+1:


Not so much from Waking Titan as “associated with” Waking Titan.

There was a bunch of stuff that we produced ourselves, collaboratively, as CSD Games. The Popocatapetl movie was part of our fictional back story.

As @sheralmyst says, it was fun. Good memories.


OMG! That was truly… INSANE! Loved it! lol

(EDIT: @Polyphemus, fantastic creative work! Thanks to @sheralmyst for pointing out that you made this!)


That was all @Polyphemus . He did an excellent job!


Thank you. But the Popocatapetl stuff was really just background. The ARG asked us to set up a games studio - so we did -we called it CSD Games. Several of us worked on an imagined background history to CSD Games. I made a couple of little movies, but the real effort went into making a game. We called it “Tumbleweed”.

Trouble was, only one of us - @DevilinPixy , was actually a programmer. The rest of us tried to contribute ideas and suggestions to the game, but all the actual work fell to @DevilinPixy. It took a long, long time, the ARG was long finished, and the game was still in development.

Tumbleweed eventually reached quite a sophisticated stage of development, and @DevilinPixy shared a number of playable alpha versions with the CSD team, but so much time had passed since the ARG that many of the CSD members were no longer in contact. Eventually, the project just fizzled out. As far as I know, the alpha version of the game still exists. Perhaps @DevilinPixy could comment?


I have the last released copy stored away. But @DevilinPixy moved the bolt cutters and I was stumped… :sweat_smile: The Cleaning Lady could not get the power on.


Thanks for the info! I do remember the ARG around that time, but didn’t realise any actual games had come from it. I had thought it was only part of the ARG storyline.

Strangely, Tumbleweed looks like a game I would love to play. @DevilinPixy : Is it possible to grab an alpha copy?


Hey @TravelEcho, of course I can get you the last release. I am however currently not able to easily grab a copy, as I am away from home. I should be back in just over a week though, so bare with me. Remind me if need be :wink:

As said, the whole project eventually fizzled out, although understandable, I am still a bit sad about it. After some technical issues on my end, life has taken over with other priorities, or I would have at least given the game a proper finish. I do however think it’s probably best to move on, as it no longer receives the attention it initially got. But who knows, I may even be crazy enough to get back into it if wished for. The website is actually still live as well, as you may have seen. Not sure how much longer though, feel free to take a peek while you still can:

I guess I will have to make some decisions about the future of the site/game some time soon. Either way, for continued discussion of CSD Games, I think it would be best to start a new topic.


Some editing and some moving and some deleting and now we are all on the same page…literally… :sweat_smile:


Maybe this round you wouldn’t have to go through programming it alone as you don’t need to hide to protect the ARG. You might find help/support in the community. For example: I am a recently retired programmer with decades of experience with real time visualization tech (not games, but similar mechanics) and I might have a skill that would be useful to you and time to apply it. And it is likely that I’m not the only candidate.

In this comment I am trying not to promise or instigate anything, in particular I may not fit in (I don’t know the technical issues you spoke of), but your resources pool could be greater now if you choose to revisit this mission.

Just a thought


I enjoyed playing it! I could not beat it, because I am a horrible game player.

I am up to help tinker. I have been learning blender and unity as you suggested @DevilinPixy. I still think a Tumbleweed configurator based on the physic/personality test would be cool.


I’ve been checking out the website and am impressed with the depth of coverage you guys implemented. I hadn’t realised there was so much!
It will take some time to catch up with it all. Looking forward to trying out the alpha.


It’s an alpha version. The difficulty was one of the things we were looking at in our testing - so don’t worry about it. I played various versions for months, and I never managed to finish within the time limit. In one version, @sheralmyst couldn’t even open the shed to start the main part of the game.

As far as I know, even @DevilinPixy couldn’t finish all of it in the time allowed - and she wrote the thing :grinning:


@TravelEcho: As promised, the latest download (July 21st, 2019) for Tumbleweed.

Anyone else who comes across this post/topic, feel free to download and give it a try as well of course!

Tumbleweed -Winds of Change v0.13

This is the latest Unity build version I had made. It has been on hold for a long time now and I am wondering if it is still worth to pick up development on this again. Keep in mind this is an unfinished game, there is no ending and there may be some bugs issues. Feel free to give it a try and I would certainly appreciate some feedback to decide what to do next.

You can get the download from my Stack below:

Tumbleweed downloads

Download for your platform, unzip in a folder and run the appropriate executable!


  • To change, use configuration at launch. Preferred 16:9.


Can be adjusted at launch under the input tab.

  • General: (Intro, Desert, Facility, and Tumbleweed)
    • Menu: <ESC>
  • Intro, Desert, and Facility
    • Look: mouse
    • Movement: WASD or :arrow_up: :arrow_left: :arrow_down: :arrow_right:
    • Jump: <space>
    • Run: <left-SHIFT> or <right-SHIFT>
    • Interaction: E + left-mouse
    • Flashlight: right-mouse
    • Phone (toggle): <TAB>
    • Scroll: mouse wheel
  • Tumbleweed
    • Look: mouse or WASD or :arrow_up: :arrow_left: :arrow_down: :arrow_right:
    • Free-Look (toggle): <TAB>
    • Wind: left-mouse or <space>
    • Boost: Wind + right-mouse or <left-SHIFT> or <right-SHIFT>
    • Scanner: E
    • Unstuck: Q


  • I advise to start fresh, as I have not tested if previous saves will load without issue.

Using an old save, will result in quite a bit of logic being a mess. This is due to the amount of newly added content and dependence on certain ‘reached’ goals (stored values that were not present before)

Any questions, suggestions, issues, let me know!

Enjoy! :smiley:


There have been changes over time, but it is possible to get to any of the goals within the time limit in the later updates. It may still require some additional adjusting/changes, as it is not easy unless you know what to do, where to aim for.

As for cutting the lock, which is required to progress, I recall having made a change to have the bolt cutter appear at a random location (10 options), to change it up a bit.

I have fully tested each update and while this turned out troublesome at first, with this last update (v0.13), I have been able to finish everything available. This requires at least 8 Tumbleweed sessions, during and after which more will happen in the facility.


Small technical difficulty with the keyboard. When I type my name (Scott) I get sSccootttt. And the email becomes …2@ddmm.ccoomm (or something like that). Shifted keys get the lower version first and then the upper. Backspace hits twice as well. I can cut the text from a terminal and it pastes twice. Select the duplicate (minus the first character so one backspace for the selection and the second for that extra character). Luckily the power password must have filled the input box because I didn’t have to play with that one beyond the cut/paste dance. The is on Linux, Fedora 32.

And what is with the pinkish orbs? Screen went psychedelic and it seems like I was floating. Could have been planned :upside_down_face: IDK.

Having fun with it, thanks for sharing.