Base Building Parts - Scaling, Rotation, and any new glitches

In the NMS Beyond release patch notes they mention “Scaling” and “Rotation on more than one axis” for “Some” building parts.

I believe that with the latest 8/30 experimental build, some of this is finally working as far as the rotation part goes. Scaling, so far, seems to be limited to only the decals, as far as I can tell.

If anyone has found any new building mechanics, capabilities, or glitch building, please share it here.

Also, if anyone hears or sees anything regarding the old Infrastructure parts that came with the Foundation Update (the Walls, Curved Walls, Linking Posts, etc) that now seem to be gone for good, please post here. I can see those old parts in the Save Editor, but they don’t show up in the game, even after “adding” everything with the Save editor and playing in Creative.


Well, when NMS was working for me in Windows, I found scaling on many items. BEYOND 3xperimental
BEYOND 3xperimental
Then another experimental update hit and NMS no longer runs while using my controller.


Thanks! That is exactly the kind of info I’m looking to gather for this thread. Also, thank you for the link and the example pictures.

That “Experimental” thread is rather large and covers everything, (I didn’t go through the whole thread) where I’d like to narrow it down to just new building mechanics, glitch building, and just general base building features for this thread.

Edit: Regarding your issue with the game not running; have you tried deleting the settings files in /No Man’s Sky/Binaries/settings and letting the game generate new ones?


Hey Intrepolicious, I believe the discussion and experimentation with snapping starts quite recently on the experimental thread so if you start from the bottom and work your way up until you start hitting pictures you should find some examples.

Also I think there has been some recent photos posted to

that showcase new rotation and scaling.

As for the old base peices, they’re still present in games files for those with legacy bases that still have the parts, but completely absent from the in-game menus. I still have a base I’d built from before atlas rises and used right up to NEXT that I can never ever change because I love my precious wooden posts :heart_eyes: If I even accidentally delete one I’m never getting it back :laughing:

I hope some day theyll make a return


Will try that as soon as I hook my Windows drive back up.


Thanks Todd. I keep peeking in the modding discord to see if there’s any talk of WinderTP’s Eucli-EA mod being worked on or updated.

Until then, I AM happy about the newly repaired “scaling and rotating” features in the latest experimental build.


New ‘glitches’ are unreliable at best. There are wire glitching and collision to try and take advantage of. Both are fraught with danger. So easy to delete the wrong thing and lose a ton of work. Wire glitching seems to have different timings on each object and is very difficult to pull off.
Here is something I spent forever on. My first attempt at trying these new glitches. Not sure I could do it large scale.


It’s an impressive machine but eh, what does it do?

… What does it do?

It blows bubbles.

You know, FOR KIDS!


Yeah, I’ve mostly been playing in VR since Beyond released, (which is not the ideal mode for building IMO… I mean, it’s kinda neat to build in VR, but you don’t get the new build mode camera, and the new blue ghost snap hint things (which are useless and annoying to me!) make things impossible to see.) … but now that the “scaling and rotation on the extra axis’s” are working, I’ve been doing some building experiments in pancake mode.

The rotation of building materials being only available to the first piece on the ground severely limits things for now I’ll say. I think a few more updates forward, and maybe a some new building mods might make this really interesting!


Playing in VR too and right now, at least on psvr, base building is a no go. But it seems we are stuck with that version from a few experimental updates ago where bases went all wonky right now. Two weeks with no patch, can’t wait to get building properly though :smiley:

Yeah the snap ghost suggestions are not helpful on VR, I find standing back a good distance helps, if you can. Would be perfect if we just got the circular anchor point, but more times than not it blinds your vision and hard to tell if Yr snapped to the right one.


It pops them. These planets are like a giant roll of bubble wrap. :sparkle: :smiley:


The old infrastructure parts are still not buildable, only available on old restored bases. In fact they initially caused Beyond to crash when selecting them (reported that, and it fortunately was fixed in the next patch).

I made a small mod for myself in Next to successfully re-enable the parts. Next changed the way snapping works a bit though, so they didn’t fully connect right. I eventually got them working well, but never released it because Beyond was imminent. I’ve got it partly updated for Beyond now, but the frequent patches make it difficult to keep up, so I’m gonna wait until the game is a bit more stable. Unfortunately that’s still no help for PS4/XBox.


That’s awesome! I’ll be reminding you :smiley:
Definitely a mod I’d be happy to use as I’ve been a major proponent of those old parts making it back into the game. Please see my thread I hope they plan on fixing these

Edit: never mind! I see you’ve already posted in that thread!


I was trying to find something to use as an outside staircase/ladder on a stacked round building, but all of then appeared to be interior use only.

I pulled out the skinny wooden ladder and noticed the instructions said I could scale it. Joy! I got it to lean the right way but could not find any way to scale it.


Yeah, I’m hoping the scaling and rotation functions get some improvements. I mean, it’s a step in the right direction, but it could be so much more.

So far I’ve noticed that rotating a basic structure piece is limited to the first piece on the ground level.


Lots of helpful info and tips in that video! Thanks for sharing that. Being an hour long video, I had to take it in chunks lol.


Tier 2 Wire Glitching

Ooh that might come in handy!

1 Like

Had an interesting problem with wiring and piping today. (Interesting=maddening!).

I got the final batch of the 60 Supply depots made, as well as five more gas harvesters, but when I went ot hook them up to the existing array the connectors refused to show up on the old ones.


Since the connector were showing up on the newly planted ones, I wired/piped those together, hoping for a miracle.

I also checked on my power source in case it was the problem, but it was fine.

I also double checked my base complexity, and it was still on Ultra. After an hour of frustrating myself over it, I gave up and flew to my freighter to debrief my frigate crews.

When I flew back to my base after that (no log out), the wiring/piping connectors were all working again and I was able to connect everything. :shrug: :roll_eyes:

Any one else have this happen when building a farm by adding to existing working machines?