Wierd Glitches

Happened to me too, twice!

Hotfix Patch 1.31 Hyyyyype!! :slight_smile:
Something tells me this guys juuust might be able to pull it off.

Glitches I’ve had so far

  1. My specialists are gone and when I rehire them, it’s as if I haven’t done any missions
  2. I’ve lost some very important technology blueprints so I can’t build certain things
  3. My base turned into a hanger(I fixed it though)
  4. I have to get my status with the 3 races improved even though I already have maxed out my status bars with all races
  5. Low frame rates(although this could be my computer, if so ignore this one)

Anyone run into these bugs and have a fix for it?

The status thing is becouse of all the new activity you can do with each one and the different guilds go under guide and they explain all of it

I thought there was a bug with upgrading exosuits, and inventory being flagged as “full”, but it turns out that the way exosuit inventories work has been completely re-worked. Your exosuit now has three inventories. And one can be full, but not the others.

1 Like

I’m trying to do the new story and I’m on the part where I am supposed to learn 3 new words, but I learned all the words before the update and even though I click knowledge stones and stuff, it still won’t give me the quest completion.

I’ve noticed some aliens still have words I haven’t learned, but I can’t find a way to learn them, none of the old ways work. How can I do the main story if I cannot learn anymore words?

I just started the pirarte mini quest for the armorer where you have to leave your base and fly your ship into space to attack and destroy a pirate and as soon as I started shooting at him, my camera view locked onto the front of the pirate’s ship on the outside. Initially I was like, “Cool! New camera modes!” And then I slowly realized I couldn’t switch back and I was screwed.

It also seems like my ship went into another dimension because the pirate was unable to kill me. If you skip to 1:58 in the video you can see my lasers shooting the ground coming from thin air. I tried to reload my save and then the game crashed :frowning:

I think I see what your saying, but it was the status thing where you go to a manufacturing facility and correctly enter the right choice to start the facility back up again and then whatever system you are in it says, enter species here status improved, I did that 4 times to complete the mission even though I already had maxed out the status.

1 Like

@MrBacon hi, yes I’ve experienced the first two here you mention. My specialists were gone, also had to relocate since my planet had become something really extreme. Re-hired them after finding a new planet I was happy with but glitchy responses from them, as in: Overseer wanted platinum as if beginning again but then couldn’t give it to him, as he then said the same as my Farmer and Scientitst, simply to leave them alone! My vehicle Tech guy want’s me to build a Roamer base as if for the first time, but I can’t since I no longer have the blueprint for voltaic cells and not enough in the cache to retrieve all in my containers…so, about to head over to the link posted by @MacForADay in the V1.3 Bug reporting thread did you see? This link here:


So fingers crossed :slight_smile:

1 Like

Thanks for the link!

I’ve got over 500 hours invested into my PS4 save with close to 500 million credits and 7 ships, and a Freighter. My base and home planet were both destroyed by the 1.3 update. Just like so many others on here.

If I am going to have to start over, I am going to do it on my PC version where I can actually get a locked 60fps out of this game! (It only takes an overclocked 1080ti and i7 6700k to do it, but I guess that is what a game like NMS demands in hardware. ??? )

Lord knows, my PS4 PRO can’t get remotely close to a locked 60fps, which is pretty annoying. And now that all my time and effort put into my base and my save has been basically tossed in the bin, I think this is actually so long PS4 version! :confused:

I forgot to mention that I HATE having to hold down the RT to power my ship forward now! If I let go, the thing stops dead in mid-air!

I miss my Cruise Control that has been part of this game since day one! Who the hell thought this change would be an improvement?

This is a SPACE GAME! Not GTA5, Forza or Grand Tourismo!

Not sure if it’s a glitch or “working as intended”, but I just finished trying to find a decent first world in Creative Mode. After about 40 toxic, irradiated, freezing, miasmatic, blighted, torrid, incandescent, and on and on in that vein, planets, I decided to see just how many it would take to give me a mild weather planet. After 60 worlds I decided to stop at 100 if I didn’t find one. I have now gone in hoping, and exited disappointed, to try again 100 times and not a single decent planet.

Anyone anywhere find a planet that had decent weather effects? :confused:

My survival mode base changed to lush. You can have it, since all lush planets are extreme sentinel in survival mode.

We have to agree. Our earlier ability to skim in mid-speed across a planets surface seems to have been nerfed. We now only have an almost stand-still or a speed that is almost too fast to take in the details. The things we scan in the mean time are so far removed from our focus that they confound our attention in searches between planets in the same system.

Agreed. Over terain I would like the slow drift back but have the reverse thruster allow pause and hover. Can’t appreciate the detail.
Still loving it but there are a few tweaks I’d rather have adjustable to preference

I disagree. I like having to manually use the thruster. Often times, on survival, before I want to risk landing and using plutonium, I want to do a visual sweeps and things don’t load in fast enough if you are moving. I also like that I can sit near a resource rock and laser mine it from my ship. No need to keep circling around. Could you mine from the ship on a planets surface before? I don’t remember being able to but I’ll admit that I hadn’t tried in a long time because you originally couldn’t.


New and updated mods are starting to roll out. But if on pc and need/want to start a new game and kind of feel like you sort of want to get back at were you were, the Trainer still works for infinite jet pack and credits on demand…

1 Like

Actually my 4th planet was a really nice and peaceful planet with an average temperature of 0 degrees Celsius(on another note, anyone know how to change it to Farenhite?)I set up a base there.I was surprised how fast I found it.

1 Like