Atlas Rises Patch 1.31


#1

Hello!

Thanks so much for all of your feedback following the launch of Atlas Rises, it’s great to see so many of you enjoying the update.

Today we’re releasing Patch 1.31 on PS4, and it will follow soon on Steam. This fixes a number of issues including:

  • Fixed an issue causing some players to crash when accessing the galactic map while having too many waypoints active
  • Fixed a crash some players experience when pinning certain tech
  • Fixed a crash which occurs when players with particularly long play-throughs attempt to save the game
  • Fixed an issue that sometimes resulted in guild missions not crediting correctly

If you experience any issues, let us know by submitting a bug report here: https://hellogames.zendesk.com/hc/en-us/requests/new?ticket_form_id=167605

Thanks!


#2

The issue preventing progress in the Artemis story due to already knowing all words isn’t mentioned. I hope they fixed that too. That was my main problem.


#3

This looks like a focus on crash fixes. I’m stuck on Artemis story too, but luckily there’s a lot of other stuff to do.


#4

Impressive patch speed.

That being said, though, I would suggest perhaps (ab)using some of the ETARC players for a closed beta for a hypothetical 1.4 @oldgods that might make the release a little smoother. (Though I realize doing such a thing would at the same time seriously increase the possibility information leaking early, which is probably exactly what you were trying to prevent… I suppose there is never truly an “easy” way. :slight_smile: )


#5

Hey - we’re aware of this one, I don’t have an ETA right now but it’s something we know about.


#6

#7

(bug) cannot craft glass or circuit boards to proceed in the story even though I had unlocked them before the update. I have tried deleting my base and rebuilding it but had no luck. All the terminals say I should let “” “” get on with its business. I also moved much base to another planet but still had no luck. The story mode is unplayable at the moment.
A reply or suggestion would be great
Thanks


#8

I recommend removing all terminals, and only built the construction terminal and hire that guy. That should start the quest line, you then only add new terminals if the construction line requires it. This seems to works for most people. While I do believe there is a bug at work here, this seems to be a decent workaround.


#9

I tried this Shota but it hasn’t worked for me I’m afraid, though a good logical suggestion I’m very glad to hear is working for many others. I’m still learning myself the various ins & outs of the old/new resources and craftable items Simran but can say this much: that in having the same issue with staff at my home base, a fellow CS I was chatting with over PSN while playing last night suggested I after deleting all terminals to delete the entire new structure as well, leaving only the first pod and go from there with only the first construction terminal, getting as far as him asking me to obtain platinum but then unable to give it, a slight step further than them wanting to be left alone but still stuck. I can confirm though that these things have been officially reported.

Able in the meantime to fly out to play the other new story mode, I can say that I have received a new suspension fluid blueprint in the process so…now I wonder, if I have been demonstrating disappointingly human levels of impatience due to over-excitement at all that is new, haha! Maybe all is supposed to be revealed in time through greater pursuit of problem-solving, who knows…have no doubt though that like WT, be it through the abundant help of the fantastic minds of others, or of self discovery or by way of a new patch, all will be revealed and resolved in the end… :slight_smile:


#10

Well, if it doesn’t work, it doesn’t. Though I wouldn’t really know why you’d be unable to hand in platinum, if it doesn’t work, that’s just it. Probably best to wait for a patch before continuing that line. In the mean time you can do the other story parts, or just fly around, gathering new recipes, planets, ships, etc. A universe still has plenty to do for a looooong time. :stuck_out_tongue:


#11

Yes, tried that a couple of times but I still can’t talk to the contractor … Even though it’s in my missions menu I can’t seem to activate anything, it’s getting frustrating now. It keeps saying that I should hire one while I already have onde, and I can’t hire anyone from the spacestation as well.

What I think might be the problem is that as soon as I got 1.3 and missed my terminal guys I went out and hired them all without doing the questline first … Hope they can patch this somehow.


#12

Indeed yes, you are so right! Surprises on my travels have been abounding, just really loving it and can wait on fixes no problem :smiley:


#13

Are any of you able to increase your standing with the guilds? Because that’s not working for me.


#14

Nope, probably won’t work until the Artemis quests tells you to, and that doesn’t work because all words are already learned so you can’t learn new ones. (Or something along those lines.) :slight_smile:


#15

I had a similar problem and found that they were waiting for something else. Check your mission log, each specialist will have their own log, in there it should tell you the next step for that specialist. I never used the log before (ps4) so I found it by accident but it’s been a huge help progressing the line. Only problem I have right now is the weapons one, it asked me to kill 3 sentinel starships, I got one before they killed me, and now I can’t seem to pick the rest of the mission up. Got plenty of other things to do in the meantime, but it would be nice to finish that so I can pack up my base and move it closer to where I am now.

The space combat has gotten drastically harder. I used to be able to take out almost anything on my C-Class Shuttle with max phasers, but now I can barely kill anything on my S-Class fighter with max torpedos and max shields. I was never very good before, but the phaser lock was very forgivable before the update and now it barely locks on at all. Guess I’ll just have to start spending money on bribes for the pirates instead of destroying them.


#16

There might be a bug with old ship tech. I have a c-class hauler, basic photon cannon (no missles), and the first (+1) shield. I took on 3 enemy ships and won. Only had to charge shields once in battle. AND I’m playing on survival.

I know people are hesitant to start new, but the vast majority of bugs seem to occur with old saves. Just consider it.


#17

I may. First I think I’ll try to find a new A (or higher) class fighter and trade in one of my old ships. In the middle of the Artemis line right now so once I finish that I’ll see what happens. I’ll post an update when I get that far.


#18

Yep. My old faithful ship just doesn’t seem to have what it takes now. I recently found a crashed A class and plan on just setting it up with weapons and shields. Ill save my old one for warps and exploring and I now have a big hauler to cart lots of stuff, which I won’t modify at all.


#19

I believe haulers are actually quite kick-ass, especially the higher classes with their shield bonus. They have huge amounts of hitpoints and shields. If you just stack an odd 3k iron for shields, you almost can’t go down against a few random pirates/etc. Currently flying around in a B class with some shield and 3 (the cheapest) photon upgrades, and I have not been shot down even once. (Though I didn’t compete against sentinels yet either.)


#20

Ok thanks. It would seem my old C class explorer will have to be superseded by a new vessel. It must not register as equipped with good tech in 1.3 or else maybe it is just dated tech that 1.3 level enemies can walk all over.
I used to flatten everyone and gave the sentinel mother ships a good flogging too. Now I’m like a little puppy taking on dragons. Splat!
Time for some work in the garage.
Gotta pimp out my A class. :smirk: