Summoning Exocraft bug?

PS4, Normal mode, using a file I started when NEXT dropped.

I have all my exocraft geobays built on one planet by a base, and an exocraft summoning station built on other planets at other bases. Prior to Beyond, I could summon my exocraft with no problem but now, whenever I try to summon an exocraft I get an error message.

Did HG change the way exocraft are summoned or is this a bug?

2 Likes

If you have an Exo Summoning radar thingy on the planet you are on, you can summon any exocraft you have bays for.
Since BEYOND I’ve had to rebuild my exocraft summoner AT GROUND HEIGHT. Tricky building mounted ones aren’t recognised anymore…& maybe all pre-existing arent recognised.
Also my Nautilin required a new geobay be built before it would come.

Have not yet tested if a summoner by itself on a remote world still works as it did during NEXT.
But I will be…

6 Likes

Ok.
I returned to an old base location with no exocraft structures and tried to summon.
Obviously nothing.
I then went outside the base area and built a summoner and called an exocraft successfully.
I left it and went to a nearby planet & attempted to summon an exocraft but couldn’t (as expected)
I then built another summoner and it worked fine.

Seems that so long as you have exocraft geobay built at a base somewhere, simply building a summoner works as it should on the planet you are on.

7 Likes

If I understand the problem correctly, you are still using the the exocraft platforms you built in NEXT?

If so, rebuilding them again at or near your base “should” work.

Good Luck!

4 Likes

Ok I recently started up an older save and I’ve found that at my base locations the game doesn’t recognise that I have a summoner unless I put down an exocraft geobay of the type I want as well.
I haven’t got the time right now but I’d like to find out if this occurs OUT OF BASE AREAs like when I tested it the other day.
I’m thinking it has something to do with whether you are in a base area or not as to how the summoner works…

3 Likes

Thanks for looking into this @Mad-Hatter and @TravelEcho!

So far I can only summon exocraft on the planet I’ve built the geobays on. I tried deleting and rebuilding the geobays but I still can’t summon exocraft on other planets, even when I have the summoner built.

I’ll try building the summoner away from my base; right now all my summoners are built within the base area. I’ll update you later when I’ve tested this. Hopefully this will work; I miss going for a cruise on some of my planets, and I do not want to build a geobay on every planet I want to drive on!

3 Likes

Good news @Wickerson!
On a planet with NO exobays but one long term base, I tested things, with these results.

You must build the summoner OUTSIDE your base area and then you can call your exocraft anywhere on that planet, even if your geobays are on another planet.

Note:
I do think however that your geobays must be in a base area somewhere as I found my Nautilon (which I built in some long forgotten random non base location) does not come.

I saved this game and my summoner is still there even though its outside my base area.
I teleported out of the system and then came back and it is still there.
If you can confirm my findings to be acurate, we may have just solved this one :+1:

4 Likes

Good sleuthing so far guys. :applaud:

I have not yet got that far in my new game to be able to help out on a practical basis, but am looking forward to seeing if you can figure it out and resolve the issue.

4 Likes

Did a test and can confirm: the summoner needs to be built outside of the base area, otherwise it doesn’t work.

Thanks for the info @Mad-Hatter, I can ride again! :grinning:

5 Likes

Nice spot you two. I probably would never have noticed because I always build the bays outside my base radius so they don’t take away from precious build capacity :slight_smile:

3 Likes

I only build one set of exobays per save but I liked rigging the summoner radar thingy up on my roof at various bases, (using trickery), mostly because it looks cool :sunglasses:
It no longer affects Terrain Edits when placed on the ground near a base but it also doesn’t actually work :roll_eyes: so it really is just eye candy if around your base.

2 Likes

Thanks for the info! I will have to try that. I started a new base and built an exocraft summoner . When I tried to summon an exocraft I got “No exocraft summoning station on planet.” Maybe it was too close to my base. I could craft the geobay for an exocraft and use that exocraft.

2 Likes

I built the summoner dish outside of my base building bubble, with all exocraft hubs on a different planet, in a different system . Was unable to spawn until I directly placed another exocraft hub for which ever vehicle I wanted to spawn.

3 Likes

Welcome to the forum @DarcZaFire

3 Likes

I have ahd that problem myself. Are you using Win 7? or 10? I should check and see if it will work for me now that I have Win 10.

Also I see in the upcoming patch (currently on the “3xperimental” branch on Steam) that there is some kind of fix for Exocraft not spawning if the dish is built within the base limits.

3xperimental Click on summary.

Good luck!
oh, and welcome to the forums! :heart:

3 Likes