Base Armorer? And Exocraft help

Hello everyone!

I am stuck on the mission where your base overseer wants you to hire a base armorer. I make sure the mission is clicked on. The galaxy map tells me i’m in the right system. The teleporter shows the mission icon to be in the same system. The icon shows me to the space station. But I enter the space station and the icon stays on the outside of the station. I talk to NPCs inside and don’t get anywhere. I’ve tried leaving and coming back, and the same thing happens - the mission icon pops up on the space station, but stays on the outside once I enter.

I was advised to talk to all the Vykeen in the station, and that didn’t work. I’ve also tried warping and speaking to others in other space stations, and have had no luck. In particular, the people ‘for hire’ are usually in the room to the right of the Multitool. I keep running into Vykeen who want me to hire them to be EXOCRAFT specialists for my base, in multiple stations. But I am not even allowed to do that - the option is grayed out. I tried to just build an Exocraft command station at my base to hire one to see if that would advance the following Vykeen to Base Armorer, but I do not have the option to build an Exocraft terminal at my base.

Any help would be much appreciated. Thank you!

4 Likes

Welcome to the forum @caphe.
It seems I recall others having this issue. Hopefully someone can help you out. We are a bit distracted with egg poaching. :smile:
Perhaps @DevilinPixy recalls where we stashed a thread on this subject

3 Likes

Just one query… I assume you logged completely out of the game and back in again, then affirmed that the mission you require in still checked?

Also, Welcome to the Atlas CSD forums, formerly known as ETARC. :heart:

3 Likes

Thank you! Yes, logged out, made sure the mission is checked… same deal, the mission icon stays on the outside of the station, and the only NPC I can hire is an exocraft tech.

4 Likes

p.s. thanks for the kindness and the welcomes!

4 Likes

Maybe you could warp far away and then reset the mission?

4 Likes

If it were me, I would delete the quest and go back to the npc who gave it to you to start it again… That is all I can think of.

Those base building quests have always been crazy buggy in non-specific ways.

Perhaps others here have different suggestions though.

Also, if I recall correctly, you could try a completely different System as long as it has a Vy’keen Station. (that is disregard the icon)

Another question: Did you try going there you base portal or station portal? Just another idea to try.

Good luck!

4 Likes

Some other topics with a similar issue, with the last one being from NEXT.



Make sure you have progressed enough with the Overseer and Scientist to be able to build the Weapons Terminal. Make sure to build this terminal inside a prefab construction like a powered Cuboid/Square/Round Room. Not always does it get correctly recognised inside a different custom structure.

If the Vykeen to hire can not be found in the current system’s space station, ignore the mission icon and try to visit neighbouring Vykeen systems and talk to every Vykeen in the space stations. Not always is the person to hire found inside the separated room.

Building the Exocraft Terminal will likely not work, as this is a mission that comes later with its own requirements. Bypassing steps required may mess it up even more.

This mission has been buggy ever since NEXT, make sure to report it to https://hellogames.zendesk.com/

Note:
If all fails, try warp to systems away from the base, until the option to reset the mission in the Quest Log becomes available; middle mouse button on PC

3 Likes

I found the below post on Steam out of many others with similar issue. This person solved it by setting the active quest to ‘Expanding the Base’. Then go into space to open the Universe Map to set the filter to ‘Active Quest’. Warp to the marked system and visit the Space Station there to search for the Armourer.

Often players get side-tracked, causing the quest system to fail. Something HG should look into, especially considering the amount of players with the same issue.

Keep us informed @caphe

3 Likes

Thanks everyone!

Well, this is odd. I had warped to several Vykeen systems and not had any luck hiring any of them for the weapons terminal. I had tried a lot of what you all suggested, with no luck. I decided to just play the game for a bit before trying anything else with this particular mission.

Just now, I randomly warped to a new system, went to the Space Station, and the first Vykeen I ran into and spoke to, offered to be my base armorer.

So, all’s well that ends well. Thank you all very kindly!

7 Likes

Happy to hear your issue solved. There is usually one out there somewhere, but annoying to not be pointed to the correct location, resulting in a search that should not be needed.

3 Likes

There seems to be an ‘automatic’ reset now for base missions that go buggy. After a while they just start working again.
I did notice that the standard Atlas/Artemis/Null/Apollo type missions can sometimes intrude, (such as waiting for an in-space scan) & this can block the flow of a couple of Base Missions.

Just keep on playing seems to be the key.

Hint.
Always fill your pockets with local plants ie Solarvine, Frostwort etc. while exploring. These are really handy later on when Mr Gardner Gek wants you to plant things & produce some harvest. Having some already speeds things up heaps.

Also grab every single Buried Technology Module you see…you need hundreds.
There is always one buried just next to a Damaged Technology so be sure to look around.

Oh… and welcome to you @caphe.

6 Likes

Thanks everyone! And thanks Mad Hatter for the additional tips, much appreciated.

6 Likes