PS4 Crash Issues. Request for Assistance


#1

Greetings fellow travellers.
I have a PS4 fault which I’m trying to diagnose, which I’m hoping someone very clued on to PS4s running systems can help me with.
I’ll need to give a fair bit of information so bear with me.

I have 2 NMS saves I’m using as I go through my problem.
One is a fresh new NEXT save in the early stages of base building and the other is a very established carry over 1.3 save in the early stages of base building in NEXT but with all the previous carry over from 1.3.
To keep it simple I’ll just call them OLD SAVE or NEW SAVE.

So, My OLD save sometimes starts up and is hugely laggy and eventually becomes a crash displaying an error code of CE34878-0.
My NEW save fires up normal but sometimes it repeatedly crashes like clockwork 2 minutes in.
It also displays an error code CE34878-0.
This is a somewhat generic code stating that an app on the PS4 has crashed and thus provides little diagnosis information other than it is it is related to corrupted memory.

At other times and not necessarily related to a warm or a cold running system, the 2 games fire up beautifully, although the OLD save does show a hint of lagginess around my fairly small base.
So it is not a repeat failure in that it happens every time. It’s quite random but it is regular.

I’m trying to determine if the fault is in the NMS game, in my save files or if I have some sort of deteriorating hardware failure.

I recently did a complete FULL INITIALISATION and a complete reinstall and update of NMS to try and rectify the fault. It seemed to work for a short period but then the issue resurfaced.
Then it goes away.
Then it comes back again.

I’ve tried testing it with cold start ups and warp start ups with no obvious pattern.
I’ve tried testing it while connected and disconnected to the internet, again with no obvious pattern.

I can’t help think that this is some sort of processor error but my understanding of computer tech is limited so I’m struggling to grasp the likely causes. I thought that corrupt data would cause a repeat failure every time, yet this isn’t always happening (although the NEW save has demonstrated a sudden but predictable crash as if it suddenly ‘trips up’ at a certain point.) I also experienced this same repeated ‘2 minute’ crash when trying to start a brand new game with no save file at all…

So… I ask you mighty PS4 gurus of the CSD forum:

  • Can a program run in different ways due to a bad save fault? (ie Can the save file affect the entire program’s ability to run?) If so, why would it not happen every time?
  • Can a memory failure in the hardware cause this kind of sporadic crash yet at other times just run as it should? How?
  • Would a failing processor or drive cause this kind of fault?

With most of the game now 99% housed in system storage due to the code changes since day 1, is it likely any issue with the NMS CD would cause a problem?

My instincts are telling me the PS4 is dying and that it is struggling sometimes to process the demanding environment of NMS but I still would like to know the likely cause.

  • Why would it be struggling?
  • What is the reason behind it sometimes running great yet other times being utterly awful.

As a bit of testing, I tried installing and playing the MAD MAX game, which has a history of crashing for no apparent reason and could not trigger a crash. Admittedly it does not have the demanding requirements of NMS NEXT.
I also tested my partners NMS game on a separate profile and it is equivalent to my OLD save and it has behaved exactly the same as mine. This indicates to me that it isn’t something in the save files (I hope) but rather something in the running of the game itself. I would note that it seems the more complex the game save is the worse it lags before it crashes. My basic creative save and my newer save simply crash without going laggy first.
Again this points to something screwy going on with the ability to process and render the game environment.

I hope someone out there has some information for me as I’m a bit lost as to what to do at the moment …

Thanks in advance
MH :rocket:


#2

I’m sorry your having probs, and I’m. Even more sorry caus I don’t think I can help :slightly_frowning_face: all I can really offer is some moral support, I was going to suggest hat you tried defragging the hard drive but you did a complete wipe, if other games work fine I wouldn’t have thought it was a hardware fault and I take it it’s only started doing it since 1.5? If so, IMO, it has to be a software issue


#3

Are you on the normal ps4 or the PS4 pro? . Try deleting NMS and any other games, Apps that you do not use anymore off the ps4. Then reinstall NMS and the updates then after that is done de-frag the hard drive. I had this issue when 1.3 came out. I done the above and had no problems since. But this is on the PS4 pro.
Hope this helps and klet me know if it helps.


#4

He’s already done a full system reset and reinstall, so I’m not sure a defrag would be nessasery but hey I’d say it’s worth a try :wink::+1:


#5

Thanks, but it’s a total clean slate, should just run. And it does…sometimes.
I’m hoping someone can point the finger at something in particular if it is a random come and go problem.
I mean I just completed the first part of the survival mode start without a hitch while trying to cause a crash.
But next time I power up, it may just keep crashing… or if it’s one of my old saves it may do the lag & crash…or it may just fire up lovely.
It’s so random!?

Any other ideas?


#6

You are certainly not the only one crashing a lot on PS4 after playing for a couple of minutes. I am certainly not an expert when it comes to PS4, I don’t own one and can only base it on information found on the internet.

The error message received is very generic and doesn’t tell you anything. From all the additional info you provided, it is most likely an issue with the game, not your hardware. Even more so with the amount of PS4 players describing similar issues.

Found this Reddit post from a couple of days ago. Might be worth a shot trying to change your system timezone to Eastern Standard Time (EST US), or just completely disconnect from the internet and see how it behaves. I can imagine how network connection can cause issues, knowing this has been an issue on all platforms. Pretty much every bug, results in a crash like yours and we know there are many …
https://www.reddit.com/r/NoMansSkyTheGame/comments/91k5z3/crash_after_an_error_occurred_ps4pro/

May also want to give it a try with ‘Boost Mode’ turned off.

In any case, make sure to report your issues to Sony as well as Hello Games. You will likely have to be patient until these issues have been ironed out. I am pretty sure it is the game to blame. Mean time, have some moral support from me, while keeping an eye out on updates to try again.


#7

Its so random I’m a bit unsure what to do.

I managed to play a good 2 hours of my old save beautifully. (Won’t retain that progress but I was having fun) Smooth as silk altbough I’m scared to try any new missions yet.

A survival moded new start played perfect and I finished up in space (where I’ll never play that grind heavy mode ever again)

I have a NEW game which is in its infancy but is so smooth. Problem with it, is it is on a separate USB to my good OLD game and I dont know how to combine my back ups onto the one USB without wiping the other.
This means, depending on which one I want to try I must delete and instal different saves.
There must be a way to comcombine backups but I’m too dumb to work it out :roll_eyes:


#8

Wait…you are saving them on a USB? Could the USB have corrupted your save file? I would not try to combine them…
If you had a pc you could test it… On a smart phone (android) you could test it with a micro to usb adapter. To test open file manager and copy a big file like a movie to the USB and then watch it from the usb…see if it plays correctly…there may be an app that would test it as well. Big audio file would work as well


#9

It originally was an on system file saved also on PC via a USB.
I’m juggling 3 USBs each with unconnected saves.
Its either a console or game code issue…of thst Im now sure.
Firing the new game up and walking in any given direction creates a crash at just over 2 minutes.
If I just stand still and do absoultely nothing and just sit, sure enough 2 and a bit minutes later it crashes.
There must be so sort of automatic thing at about 2 minutes going on which glitches and crashes the game regardless of player input.
There seems to be no variation between internet connection being on or off.

Testing continues…


#10

I draw your attention to this:


At least you are not alone.


#11

Well my saves again stopped loading…for the 2nd time…except this time I lost about five or six hours of gameplay because I had backed them up recently instead of losing 20 to 30 hours…but frankly I am getting sick and tired of this crap. Submitted another bug report with my newly corrupted saves attached…again…but I feel like I’m nearing my last straw…lost 15 to 20 hours of gameplay when Atlas Rises messed up and made the main quest impossible to continue…now lost another 20 to 30 hours plus another 5-6 on top. If it reaches a point where I have to lose this save…over 800 hours of gameplay…then I’m done with the game…permanently. I am NOT starting over from zero, not flipping happening.


#12

Still testing with total inconsistencies.
Have ruled out internet.

Most certainly identified a crash point just after the 2 minute mark on regular new starts or existing early stage saves.
Definately a sporadic lag and crash issue on my complex carry over continuation save, yet on screen in front of me as I type this is that very same save running crystal clear.

Had my first load up crash while still in the star sequence while loading just before.

Am yet to have creative mode crash or in anyway fail at all so there is something to do with the stats of the player character that is not part of creative mode…most likely the requirements for materials and tech that isn’t applicable in creative.

Bugs aside, I’m suspecting that the processing requirements for NMS NEXT are at the limits a PS4 can handle. I also think older consoles may simply struggle and can’t do it sometimes.
Once my machine is warmed up it seems to be able to run NMS in all its most complex save details.
I’m going to run a few more cold start and warm start trials but I think my issues may stem from an old system pushed to its limits.
There is something about the 2 minute crash that has me thinking the memory in the PS4 has an issue and at 2 minutes in it hits a critical hiccup and the game fails. Get past that and its great.

My partner is convinced we should follow advice for the error code ‘if all else fails’ …and go buy a new PS4.
I can’t say I fully dissagree either. I may let my wallet take a hit for the good of all the CSD and share my findings.
Does anyone know if transfering data across to a new PS4 will include updates? My internet is maxed thanks to going through the repeated process of installing/updating NMS.


#13

I had read at least one of the frequent crashing bugs was related to timezones which seemed to be the case with me as it was morning crashes and evening success (AEST -Australia) but I picked up another comment about changing motion blur down to 99. In my case it was already below this so I just dropped it to zero. No crashes since. Who knows, maybe it will work for you. Generally speaking I’m not a fan of motion blur anyway.


#14

Thanks for the response. That is a really weird reason for a game to crash…
I wonder how that works. Any more info would be great. And I’ll check the motion blur settings too.


#15

No problem, PS4 pro btw, uncapped framerate 1080p output.


#16

You could take your hard drive out of the buggy PS4 and put it in the new one to save reinstalling, just one other thing, does your PS4 ssound like it’s going to take off I.e. the fan doing overtime? If so it can be cleaned out but this involves taking it apart, I did it to mine and you wouldn’t think it was on its so quite now, I’m just thinking that if this is the case the chip overheating may be affecting it…it’s just a thought


#17

No. My PS4 lives in an alcove to reduce dust issues. I stripped it a while back, just to inspect and it is very clean and the fan isn’t screaming.
The unit does get fairly warm but nothing scary.
It actually seems to be running NMS better once it is warmed up but that is just strange…
I’m going to test the time-zone thing that jas been reported and see if it crashes in relation to the time of day.
Apparently that is a known issue. It’s a strange one too but I’ll look into it.


#18

Ok guys. Made some weird but awesome progress in testing.
Following a hint from @ashamam I’ve been testing my PS4 timezones with excellent results.

By altering my PS4 time zone to an evening time zone somewhere else I can get both versions of game to fire up and run sweet.
My old 1.3 carry over save is smooth as silk (motion blur is turned down below 100).
Starting a new game will just keep on playing no matter what (dying excluded).

If I leave my PS4 setting on a morning time-zone it trips up and may crash.
My old 1.3 carry over save will start laggy and will progressively worsen until eventually it crashes.
Starting a new game will result in smooth play for about 2 minutes from end of intro but by 2 min 40 there will be a crash.

I have been repeatedly cycling back and forth between evening time zones and morning timezones in the PS4 settings and closing NMS each time and the exact same behaviour results.

If either of these faults are affecting you give this a go. I don’t know the contact details for the Zendesk but this issues is definately a proven circumstance so should be reported.


#19

Have submitted the issue.
https://hellogames.zendesk.com/hc/en-us/requests/new


#20

After many times starting over, testing the PS4 time-zone bug, I got pretty quick at getting myself repaired and airborn. Certainly enough time for a selfie.

Even did one in survival mode so I figured it was worth a completion pose photo once I made it to the space station.