Over Maximum Game Wrecker Bug


#1

Just a warning as none of this is properly verified.

If you have a very high complexity base and then build a monument or a race track, this can possibly bug your game into destruction.

I’m aware now of 2 games reduced to repeat crash in relation to a monument built near a complex base and in close proximity to a comm.
The only solution in this circumstance is for the player to relocate bases while offline and restart the console. If lagging continues, a backup and then reinstal may be needed.
Both known cases have had the game survive the crisis.

Also its possible to build a race track that allows a max complexity base to go beyond maximum and then crash badly. Do not save this game in this state as this may corrupt save data effectively killing your game. This will require a reinstal and pre-bug game save point.

Stay safe travellers.


Off Base Farming
#2

I wonder if maybe that’s what corrupted my save…

I should note that the game counts every “waypoint” of the race as additional complexity for the base. So if you make the initiator and then set up a bunch of race points, now, your base can go up to 112% complexity or such.

I’m not sure if this is what caused my save to become corrupted, but around that time I did start experiencing the issue where my atmosphere harvesters would no longer work right, portals would not let me charge them sometimes and would usually forget they were previously charged, etc.

Eventually it got to the point where I could not even open NMS anymore without it directly crashing before the save selection screen even comes up, making that entire save file totally unusable. I had to roll back to my last cloud backup a week prior.

I sent all my save files in to HG, but they never responded, even after several weeks. I know of another guy who has had his game get corrupted to the point where it cannot be opened, also.

I really hope they figure out how to fix this. I started a new save game, but I really am not jazzed about having to redo literally everything.

However I do note that on my restarted game, I no longer have crashes when using framerate unlocked mode on PS4 Pro, and the game over-all runs a lot smoother. Why would having a new save affect FPS of the game? That is really bad programming.


#3

I found an old backup of my PS4 save file, from pre-1.35 in late August, before I did the “same-grave” trick to learn all the glyphs, before I did many portal visits, before I made any monuments with other players, and before I moved my Pathfinder-era base. It has 760 hours.

I loaded it into 1.38 yesterday, and amazingly, there is NO freeze when saving and everything runs smooth as butter just like a new save.

However I found emails I sent to HG just a week after that backup, where I was complaining about the long 5-second delay incurred when trying to save my game.

So that means, some kind of bug or issue between 1.33 and 1.37 is responsible for messing up my save. It’s not related to how many hours of play-time are on the save, because if it was, then my old backup with 760 hours should still have the lag when I loaded it from pre-1.34.

I did find this in the 1.34 update notes:

“Fixed an issue where large numbers of portal visits would be added to save files, greatly increasing the save size and impeding the ability to save the game. We’re aware there are still some players experiencing this issue, and we’re currently investigating any remaining reports.”

I think that making discoveries on the other side of portals by making an exocraft station, then getting in and out of the exocraft to discover the planet, may not have been handled properly (and this still might be an issue).

Could some issues also be related to claiming a base thru a portal? HG seems to have walled off all the various tricks to use portals as a way to “skip to the center,” but they left in the base-claiming trick. Why leave in the base-claiming exploit but take away the ability to call down your ship, etc.?

Anyway, I am really frustrated right now, because my main save got messed up, and now it’s basically unusable. I have sent the corrupt files to HG but they never responded and it’s been over a month with no fix.

Two of my friends, who are both dedicated hardcore players with long save times, have also gotten to this point where their save has become “full.”

I am really down, because I expected HG to resolve this problem by now. They need to issue a hotfix that repairs our saves and lets us keep playing.

We don’t want to have to re-grind all our class S freighters, ships, and multitools that took SO FREAKING LONG to get. We don’t want to lose our accumulated stats like how many planets we have 100%’d, how many sentinels we have killed, etc.

More than any other game I have played, I really value my original playthrough save from NMS. I do not want to start over and I want to keep playing, but the game is literally broken.

HG support has not responded at all regarding our corrupt saves or when we can expect a fix for them. They do not seem to care that even when our saves were working, we have a 5-second freeze when trying to save, and experience lots of extra lag and crashes.

They have just left us in the dark.

I would really like some reassurance from HG that these issues will be addressed soon. I am someone who streams this game on Twitch almost daily and I get a lot of people asking if they should buy the game or start playing again. When they see my stream and see the crashes and problems, and hear me talk about these issues, that’s not good for the game.

I want to help NMS and it’s why I give so many bug reports to HG. But why did they stop issuing bugfixes after 1.38? It was going so well.

Anyway, I feel the community getting really anxious lately, but I would be fine with waiting in the dark if the game worked right and my save was not messed up. However I am really not cool with this current situation.


#4

I’m not anxious. I’m somewhat intrigued to know what’s going on, but I’m sure we’ll find out in good time.

After 1.3 launched, HG put a lot of time and effort into fixing bugs. More than they intended to, I suspect. But they had a schedule, a new release to build, and a very small team to do it with. Any more bug fixes would have taken away resource from development.

So now I expect further bug fixes to be implemented after the new update. I can live with that.


#5

My current base is st 104% complexity. PS4 normal. It’s the race track that puts you over base complexity maximum, it was the last part of my base that I built. I do know for definite that you only get 50 waypoints for your track edit. Not sure if the amount of waypoints is a potential problem. Possibly.


#6

Be very careful @MasaqDJ with an over complexity base.
If it crash/saves you will have a dead game.


#7

Backed up I’m fine, thank you :smiley:


#8

I think lol.


#9

I didn’t see a racetrack or a monument but I had an issue like that when I visited another player’s base…I walked around for a bit and I crashed, reloaded the game and then crashed again…after that I just tried to leave the atmosphere and crashed another four or five times trying to leave the planet. When I finally escaped and I was in space I thought I was good but crashed trying to enter the atmosphere of another planet. In the end I managed to resolve the issue by running to the space station, saving, and then manually rebooting the game. Outside of that I don’t think 1.3 ever crashed on me…but that one instance was nasty.


#10

My solution to ongoing crashing in a system was to reload offline and get the h*** out of there.
Attempts at returning later get the same results so I stay away. Pretty scary on high hour games given some bugs are game wreckers.
Also found the PS4 sometimes crashes after long multi-hour sessions. I periodically do a power-down reboot and don’t get issues if I follow that routine.


#11

You guys don’t get it. THE GAME CRASHES BEFORE I EVEN GET TO THE FREAKING MAIN MENU TO PICK A SAVE!

My friend QHELIMonkey this weekend lost his save too. He was streaming his journey to the 256th galaxy. He made it to 255, and then, BAM, blue-screen crash on PS4 and he cannot even launch to the main menu anymore. AFTER HE WENT THROUGH 255 GALAXIES!!! Denied the last one by this ridiculous “save gets full” crap.

They need to fix this bug! It is not acceptable that we are now unable to play at all until some untold date, unless we start completely over from scratch. THAT SHOULD NEVER BE ABLE TO HAPPEN.

I don’t care how small their team is. There is NO EXCUSE for this.


#12

@VitaminArrr Did you ever debug an elusive problem? Knowing how hard it can be in a “simple” financial system, I can only guess it’s a gazillion times more difficult to 1 reproduce, 2 find the reason, 3 fix.
And having a save game that crashes on your pc or ps4 might not even help them to reproduce if system specific variables come into play.
I understand that this is not what you want to hear, but if it could be fixed in minutes, it would have been.

@SeanMurray It would be nice if they “recognised” the bug by giving a shoutout though.
In that sense I agree with your outrage.


#13

It seems like there is way too much data held in a save file and once you get any section to a certain size, it becomes unstable. NMS would be better off with a database like orientDB or sqlLite maybe.


#14

The original post and some of the responses discussed base complexity and if one scrolls down billions and billions of threads there was an updated Base Building Table posted that might help with avoiding those problems. There also are instructions elsewhere about editing the base building limit but some have reported problems not only with errors when editing of the file but also occasionally with the impact of having raised the limit.

NOTE: Popular misbelief incorrectly credits the phrase “billions and billions” to Carl Sagan but the term is credited to Johnny “Carl Sagan” Carson in this skit albeit one with poor quality video: Billions and Billions. I particularly like the visual aid showing the actual location of Australia about 4 minutes in not to mention the effective use of the telescope at the end.