Community event returns you in Euclid when coming from another Universe!


#1

So I decided to do the new weekly community event. Polo located a portal for me and off I went. Found said portal, warped to a new planet and started digging for treasure. All fine so far, no issues at all. Handed in my first 25 Hex Cores and bought some items in the Anomaly Store. Now able to dig up even more treasure for additional Quicksilver, yay! Dug some more, handed in 50 got a couple more items. Fully discovered the planet while at it as well. Did some exploring, checked out all the Comm Stations, had loads of fun for hours.

Now comes the problem! I decided to go back through the portal, only to notice this was not the way I came in the first place. New system, new planet, hmmm. List of things shown in Galaxy map, which seemed familiar, but why with a system unknown to me?

Well … I warped to the next system to be able to check what Universe I am actually in. Lo and behold, I was now back in Euclid. So those wondering how to get back to Euclid fast … this is how you do it! However, I came from Eissentam! So unless I can find a quick way back there, I am screwed!

For now I will just reload my backup, but please be aware: Weekly Community Event sends you back to Euclid whether you came from there or not!


Weekly Community Event Season One - General Discussion, tips and Feedback
NEXT Patch notes - Steam Experimental [POTENTIAL SPOILERS!]
#2

For those able to edit the save file, you do not have to reload your backup and lose all the work done.

Under PlayerStateData, change the RealityIndex to the number matching your Galaxy/Universe. In my case this was Eissentam which uses 9. Then basically copy the first few entries under SpawnStateData from your backup before the teleport to the event location to prevent spawning in space to die. For me these were the following few entries:

	"PlayerPositionInSystem":[
		-104048.1953125,
		-91765.34375,
		-5118.927734375,
		1.0
	],
	"PlayerTransformAt":[
		0.11479192227125168,
		0.8197977542877197,
		-0.5610297918319702,
		1.0
	],
	"ShipPositionInSystem":[
		-104031.0859375,
		-91795.53125,
		-5095.2705078125,
		1.0
	],
	"ShipTransformAt":[
		0.2016257792711258,
		-0.7999299764633179,
		0.5652071833610535,
		1.0
	],
	"LastKnownPlayerState":"OnFoot",
	"FreighterPositionInSystem":[
		-2384.25244140625,
		3050.419921875,
		-35.22694396972656,
		1.0
	],

This fixed it for me, but feel free to ask if your situation is somewhat different.

I had fun doing the event and re-visiting Euclid. Even uploaded the discovery when shortly back in Euclid. It was a quick fix for me and I can continue digging for more treasure, back at home in Eissentam. I do however hope HG comes with a hotfix, because I am sure some will not be so lucky to easily fix this.


#3

Additional info:

Some players may not experience this issue at all. It appears, according to some of the Steam discussion, that reloading your save while at the event location, causes the issue. It seems that some data is not actually stored when saving. So when reloading, all it knows is the event location’s universe/galaxy, but no longer knows where you actually came from. Those who did not reload and returned through the portal, appear to have ended up back in the correct universe/galaxy.

I can confirm a reload after having quit to take a break while at the event location.


#4

That’s odd…on PS4 the portal returned me to the same system in Eissentam I left from without incident…multiple times…I went back and forth through that portal quite a lot as it seemed to sort of reset the mission for a while and that was the only was for me to keep getting more Hex cores because the game would stop generating more every time I had 25.


#5

Maybe the issue is only on PC, I am not sure. You are playing on PS4, correct?

As for getting Hex Cores, I had no trouble getting them, even after the initial 25. You may however want to try storing them elsewhere and not in exosuit. Some seem to think it may help to continue getting them at a steady rate. Makes some sense I guess, as the RNG could be linked to the amount in inventory? Can’t really confirm myself, although I did store them elsewhere every few stacks.


#6

I also replied before I noticed what you said about reloading in the mission system…I didn’t do that as far as I am aware so that may also be why I got away clean.


#7

Ah yes, That could very well be, as I have been reading up on some others with similar issues. It seemed to be a linking factor for getting the issue. I know I did reload and ran into it …


#8

I heard reports about being stuck in Euclid from experimental so I backed up my saves and I was actually very keen to not end the game with any saves on the other side of the portal…I didn’t specifically know that reloading there would cause the problem but I knew I didn’t really want to be there as things could go wrong.


#9

I also made constant manual saves every time I successfully returned from the mission system through the portal.


#10

Oh yes, I can imagine your train of thought. Always best to have a backup and not tempt any issues.

Several issues involving the portal though. Not just ending up in the wrong system, but being stuck there as well as the portal deactivated. Others not even being able to get through the portal, either crashing or being sent right back. Appears this may have been caused by trolls who build in front of the portal exit. Going offline helps, as the structure blocking you then won’t load. Plenty of things gone wrong with this event release …


#11

Oh and not to mention being forced to do the event if you are still doing the story lines … All portals appear to be linked with the event, not just the one pointed to, so no other way to do Artemis for example if you still need to do those portals :slight_smile:


#12

In creative mode I got back okay without any problems.

I also made a manual save point on another planet in the community event system. Eventually I flew back to the Planet with the portal as I realised I couldn’t get back from the space station due to ‘Portal Interference.’ Portal travel worked okay for me on PC.

If anyone is stuck maybe attempt to make a base, build a teleport and use that to return to your home base? Does that work on the other side of a portal? That may be a work around if it helps? I never did this so do not know if this is even possible.


#13

If you create a base in the mission system(Euclid galaxy), then go back to another galaxy via the portal, and try to teleport to your new base from that galaxy, you will die in space. The reason is because the game will try to teleport you to the location of your base but in your actual galaxy…which likely means that there is no planet or anything in that exact same location.


#14

Ah okay, am I correct in understanding your wording, you mean Teleports are linked only with the current Galaxy you are in? Another device is needed to travel between Galaxies?


#15

I don’t think you are actually able to build a base in the system after getting there through the Portal. Used to be possible though before this update after going through a Portal. Not sure if this is specific to the event location or if they changed it ‘globally’ now.

For those stuck at the event location because the portal has closed, this can be edited with a save editor. Look for the ‘PlayerStateData’ and then find ‘OnOtherSideOfPortal’ to change the value to false.

Edit: As a side effect that change may actually allow you to build as well, hmmm …


#16

Right now it’s not really possible to travel between galaxies…this community event seems to do it a bit but it’s buggy as hell and not really something reliable.


#17

I do see loads of player bases there on PS4 in that system so people have done it on PS4. Maybe it only restricts you if you’re not from that galaxy or something? Not sure.


#18

I have posted about that in another topic related to the event, but I did indeed notice several bases. However, they all appeared to contain just the base computer for the ones I actually visited. I had not checked them all though, but after checking 4, they all appeared the same, just base computer, with the pre-Next flat area. Seems to indicate to me that those bases used to be there pre-NEXT. So those who actually have those locations, can likely ‘re-claim’ it. I could be wrong though, but that was my thought after seeing them.

Of course on PC this doesn’t matter. If you wish to build a base there, you easily can by modding. The portal having been blocked for example, is proof enough for me.

Also the address has been posted, so visiting the system normally, would likely allow you to as per usual.

Edited


#19

I went through the portal on my Xbox , from Eissentam, was able to complete the 25 and return with no issues. I took @DevilinPixy’s advice and didn’t reload or do anything other than collect the cores.

Edit: I checked a few buried tech places when I returned and found some cores as well, so all looks good for me


#20

Happy to hear you returned safely as well :slight_smile: If my issue happens on console, you’d be in trouble for sure, unless you have a backup to reload