Cant progress base building missions


#21

Yea ikr, i have completed all the farmer quests and its idk what could be the problem.


#22

Have you been on the fetch-quest for the Korvax to reset his convergence link or whatever it is?

Has the Vykeen sent you off to fight a pirate/sentinels yet?

I’m just trying to work out exactly where you are in the base missions…


#23

My current mission is collect Vykeen daggers, i have been sent to fight pirates before by him.


#24

Some missions require other missions to complete before they re-activate. I’m not sure how long you’ve been at NMS but it can be a tad buggy sometimes.
Its important to do EVERYTHING exactly as requested and to make sure you have the appropriate mission sellected in your LOG before you complete the steps…even if that means swapping back and forth as you wander.

Vykeen daggers are regularly sold at Trading Posts on Vykeen world by Vykeen traders.

I’d finish that mission and then see what happens with your technitions.


#25

Im gonna complete all other base quests and then get back if it worked or not.


#26

Now i have completed all other base missions but still cant talk to the scientist. please help


#27

Im partway through a new save…once I get to the same stage I’ll try to workout the steps…


#28

I’m only up as far as scanning critters for the scientist and I need to go do real life stuff.
I’ll get back to it when I can…


#29

I read somewhere this can happen if you move your base and make a new one. Which i have and forgot to mention.


#30

Yeah…that used to be an issue early on in Atlas Rises. A lot of old bugs have popped up again so you may need to remain patient.
Next session I should be up to the farmer and the blueprints for circuit boards. I’ll go through it step by step and see what happens.

Edit:
I’m at the point where I’m growing some Coprite , Construction guy is waiting on a Circuit Board(s).
Play-through has changed slightly since last update. I took some time to set up my storage vaults since my inventory and ship is still undersized. Almost there…


#31

Well get back to me if you find anything interesting


#32

so I don’t know if any of us who have continued our save have tried to build the specialist terminals, but I have and they are still acting like I’ve done all the missions. I can’t even talk to the farmer, the construction person wants me to do photography, exocraft guy is doing that thing where you drive out somewhere and get units, and the scientist acts like he’s finished.


#33

Yea i just gave up completely on my save and started a new one.


#34

Ok @Mikro.
Update:

I’ve finished the farmer quests.
I’ve given the Overseer a Circuit Board made from home grown materials.
I then gave him a Gravatino (home grown)
One of these prompted the Exocraft Tecnition Terminal.
He wanted me to build a Roamer exocraft geobay.
He then wanted a scanner installed.
He now wants me to blow up a depot
(This bugged the first time so make sure you periodically save).

This is where I’m at now…
Does any of this sound familiar?

Edit…
It wouldn’t accept my destruction of the depot…but returning to the exo tech with 100 gold worked…


#35

ugh, now the Armorer “blow up 3 depots” quest has stopped working for me after I blew up the first one. I’ve since blown up 4 more, but they won’t count towards the quest. On the upside, the fungal mold I grew a few days ago and harvested, finally registered with the farmer so at least that is progressing, albeit a few days behind schedule. I just want to get all my base staff in a room together for one of those come to Jesus meetings.


#36

Ok. I finished my base missions.
Bit of a grind but sorted.
I’ve mined out all the copper from here the horizon so I guess it’s time to do base number 2.
Korvax guy just went silent after the CB blueprint. At least the others let you know…he just clams up.
Anyway…time to start hunting the $ and get out if Povertyville.


#37

This may not be relevant to the original poster’s problem, but I found a pretty major bug that is preventing many players from even starting the base building missions. I show the work-around for getting them in this video:


#38

FYI: The Armorer Blow Up the Depot 0/3 quest wasn’t working. To get around it, I went to a space station, accepted a standard mission from the mission guy, to blow up a depot. Went to the depot it marked on the map and had my way with it, on foot mind you. The depots usually have 5 or so buildings/tanks, and they each counted as 1, so I only needed to destroy 3 tanks, not all of them.

The Armorer Destroy Sentinels 0/8 quest was terrible as well. I killed about 40 sentinels in the process. Added, removed the terminal about 6 times. Sometimes 1 kill would register, sometimes 2, then it would reset. On PC, entering a ship, a building, a cave… all if it reset the quest counter. I finally went out in the open and maintained the sentinel alert level the whole time. I killed 4 small ones, then a walker and dog showed up and I ran away. Oddly enough, the wanted level reset to 2, the kill count didn’t reset, so I killed 4 more little ones and was done. Seems like keeping the wanted level up was the key.


#39

Agreed. The final armourer quest is very badly explained. It took me a while to work it out.

Once the task starts, you need to kill 8 sentinels (it doesn’t matter which kind) in a single session. If you hide in a ship, building or cave, the session ends, and the count starts again at zero when you come out.

Players can encounter this quest fairly early in their game, when they are not particularly well armed or armoured. In those circumstances, the trick is to keep running.

Shoot down a few drones, then run away. Keep moving, and allow the search counter to drop. Then come back, and shoot a few more drones. If you’re feeling particularly brave, you might take on a dog sentinel, but do NOT try to take out one of the new walkers with a mining laser or boltcaster.

Keep moving, keep reloading, stay away from the big dangerous guys, keep knocking off drones. Don’t hide in buildings or ships, or you’ll lose your progress, and have to start again. Allowing the sentinel’s search counter to drop to zero will not cancel your progress, and will give you breathing space to reload, allow your shield to recharge, and check the log to see how many more you need to kill;.

Once you’ve killed 8, that’s it. Return to the armourer - quest over.


#40

I got stuck with the ‘Depot’ mission as well, as I was stupid enough to destroy the ones required with my ship instead of on foot. Had no save to return to and no other way would make it count. This was one of the 3 times so far I had to manually fix the issue in the save file to be able to progress. Mind you, I am on a fresh NEXT save, so at least I do not have the pre-next save issues.