Bases - Terrain Edit limit / Render Count issues


#1

Some of the changes I noticed with the latest update 1.59 are a terrain edit limit and render count. Sounds good and supposed to improve performance, although for me not noticeable with no obvious fps gain. The silly thing with both the terrain edit limit as well as the render count, is that this appears to be global!

  • Terrain Edit limit:
    This means that no matter where you build your base, any terrain edits already made, continue to count towards this limit for ANY base you have or create. It makes no difference where you have a base(s), new planet or different system, all the same. The terrain edit limit is actually easily reached as well …
  • Render count:
    Why on earth does this appear to be a global count? Although I could not view my large bases from a distance without the game hanging on me, at least I used to still be able to walk around enjoying my creative work. With this new change, pretty much anything non-structural stops rendering unless you pretty much touch the object/item. Lights and decorative items are most obvious, but it doesn’t stop there. Being in a well decorated room, shows pretty much none of it when taking two steps away from it.
    When it comes to rendering and performance, all that should matter is what is actually visible. When I am inside my base, in a room, where all I can see is two walls and the interior design added, I should easily be able to see ALL OF IT! However, this latest update shows pretty much nothing but these walls. Horrible implementation where location of the ‘camera’ and checking for what should be visible (in view), is thrown out the window for what appears to be a global count, preventing anything from rendering. My other bases should not matter, as I can not see them …

Here’s hoping for further improvements …


#2

Noticed this on console too, it may just be a temporary quick fix while they spend time working on a better and more permanent fix. Sadly I think developing for console and aiming for parity is really hurting the PC folk. I hope it’s not a sacrifice they made to get tessellation on consoles,.


#3

I am now also experiencing screen freezes when approaching my base from the air. As you described, the game doesn’t actually crash - it just locks up and hangs.

The only solution appears to be CRTL ALT DEL and Close Program.

Very annoying.


#4

I have had that problem with one of my bases. Originally it was a large base with a lot of glass, a farm of frostwort outdoors, 10 bio-domes, and what was to be 10 landing pads if the game would allow it. It also had a nearby dioxite mine. The game started locking up as I approached the base or even turned from not facing the base to facing it, even from as far away as the mine (about 500u) even though the base was not visible from the mine. This happened after I only had four landing pads built. The mine also started producing copper, even though the dioxite remained intact under it. I’m not sure if the mine issue is related, or if it is just an intended game mechanic to represent exhausting the vein.

I started dismantling the base very cautiously, teleporting to the base, then deleting what I could reach without turning, beginning with the bio-domes. Since nearly everything had glass, I wondered if the transparencies made rendering too difficult. The more I deleted, the easier it was to delete without crashing. I have now deleted all of the bio-domes, all but two landing pads, and about 1/3 of the base. I’m building bases elsewhere, so I’m scavenging the materials as I need them. The goal is to leave about half of the original base footprint if it stops the crashing. So far, it hasn’t stopped completely, but it has become infrequent enough that I can move around to get the deletions done.

Overall, I’ve gone to using several smaller bases on several planets instead of one huge one. I’m also using less glass. The crashing base was made almost entirely from elements that were mostly transparent. I don’t know if any of the speculation is accurate, but by comparing details we may be able to avoid the situation that leads to the crashes. The building game has been so enjoyable with this patch that I’d hate to see a solution that involves returning to former base size limits.


#5

On PS4.
Past experience & reading other’s accounts here, I find big bases get messy.
Lots of glass quickly messes up the complexity but anything big will go bad.
I believe HG gave us multiple bases with open complexity limits so we could build lots of customised colonies without hitting the barriers…not as to push the limits of complexity and cause ourselves problems.
I’m still building small modest bases similar to pre-NEXT and am having zero problems.
I recomend building bases the same size as we did before and it is smooth sailing.
Incidentally, if you want super complex, try using creative mode. I have one massive construction in creative and it has no issues. Something about the mode makes it glitch free.


#6

Figured I’d post here, although it has been a while now with 1.7, The Abyss update.

I just noticed how my Terrain Edit limit for base building has now been reached due to the update. I have always kept an eye on it ever since they introduced this limit, visible through a tiny indicator when placing parts that can alter terrain when placed. I had not built anything in a while and was well within the limit, with the circle indicating just over halfway. Now I decided to build some more with all the new parts available and noticed my limit already reached. So clearly this update has lowered the limit quite a bit.

This limit apparently counts for all bases together, not for each base separately. So even if you try to avoid it as much as possible, you’ll soon reach this limit, if base building is your thing. I checked my creative save just to see if it was completely bugged or not. My creative save does however have plenty edits left, although unclear how this is calculated. This creative save only has the motorcycle base build though, so no wonder it is fine.

It saddens me, as building where terrain actually needs to be removed, will now keep the terrain in place. I have always tried to keep such terrain edits to a minimum, now this has been limited even further. The amount of terrain edits due to building is in my case not even all that much. I can’t even do anything about it either. It’s not like I can try remove a few parts to get the terrain back and allow new edits again. It would require to completely remove a base and rebuild to get these edits returned. I have a total of 5 bases, not including my freighter. Kept them smaller than I would like at times, to prevent crashes I used to have.

Please Hello Games, give us a reasonable limit. Since Next released, limits have been decreasing further and further. In most cases not even hard limits, but limited by the risk of crashing or user experience. I understand performance issues, but I am honestly getting more and more annoyed. Draw distance and load times for objects around the player has already gotten worse. At times it takes about a minute or more to even load everything. Further ahead, still well within what we should be able to see, objects or parts are either not even loaded, or have their lowest LOD level shown. Turn around and see this loading, popping and LOD level changing, happen all over again. Now we are even further restricted with terrain edit limits being reduced, without a way to properly address this as a player. Well, unless you know how to work a save editor that is. Makes me sad, although this update is otherwise great, still a way to go …


#7

Question. Does this include terrain that is removed automatically when placing a structure?


#8

Reading this makes lots of sense, I thought maybe they’d changed the way floors interact with terrain when nothing was been flattened by floor tiles on the first new base I’ve started in a while. Thanks for the heads up :slight_smile:


#9

Yes, I am talking about terrain edits caused by placing building parts/objects, not edits made with the Terrain Manipulator.

I am however trying to figure out how this is stored and if calculation for this limit is based on both, which wouldn’t actually make sense.


#10

Just did a test in Creative mode.

I made a whole lot of terrain edits with the Terrain Manipulator (TM), outside of the base region, to see if the indicator had changed upon return at a base. The indicator was still showing the same, so I went back out of the base radius again, to make a whole lot more edits with the TM. This time I did not only delete a lot of terrain, but also added a whole lot. Upon return to the base, the indicator still did not show a change.

Now I tried the same within the confines of my base, using the TM. No changes to the indicator at all, as suspected. I always figured that TM changes would eventually be undone, either over time, or overwriting the oldest change made once reaching a set amount of edits possible. Considering the fact that back in Atlas Rises, I could see terrain edits slowly be undone over time (erosion), I believe the former is the case, or possibly a combination of both.

So considering edits made by the TM do not affect the limit indicator, I tried something else. I started placing floors somewhat underground, connecting the next to the previous placed. You can pretty much see a change with every single floor tile you place. This change is tiny, but place a couple and you certainly see a change. I can only imagine how fast you now reach this limit. Not willing to test and count though, see for yourself.

Either way, this proves that the Terrain Manipulator edits are not calculated towards the terrain edit limit in place for bases.


#11

Due to terrain edits returning early on, most of my bases are suspended up on stilts. I didn’t like the returning geography so I changed my tactic and have since gotten used to it.
I intend to return to my couple of bases that are not truly required, to delete them or to rebuild more terrain efficiently.

To build cuboid rooms, I place a timber wall and a floor panel as a roof. I then place my first cuboid resting on this. I then delete this scaffolding and use this cuboid room as my base to build the rest off the ground. I then instal various non-terrain-editing stilts (or archways) to give it realism.


#12

Yes, many parts do not edit the terrain at all, which I had been aware of since NEXT released. I hardly ever build directly on the ground, or at least try to avoid it as much as possible. I thought I was doing quite well so far, with the indicator only just passed halfway around the circle. This update changed all that.

Not sure where I can even gain a bit by removing, besides the fact we do not have any tools available in-game to get this limit back a bit. Being on PC, I can clear all terrain edits with the save editor, which would then require replacing many parts where needed for all my bases. Finding the single edits is complicated and would take a lot of work figuring out. I am hopeful though, as Hello Games had announced working on a feature that would help us out some time ago.


#13

Same here. I learned early on what a pain returning land features were. Now all my bases (and I have dozens) avoid terrain edits altogether. I build around the landscape, rather than altering it.

Funny though, I have some very large bases. My farm, in particular, is huge, and mostly glass - but I haven’t had any problems. Everything seems to run and render fine (fatal thing to say, I know - cue major crash).


#14

You do not experience any delay on base parts/objects rendering, nor having any issue with render distance/low LOD?


#15

The only thing I’ve noticed is when I’m inside the base corridors (long, long corridors, with biodomes either side), sometimes I can’t see the ones at the very end. They only pop in when I get closer. But if I go outside (say, walk along the roof), it doesn’t happen. I can see everything.


#16

The issue is mostly with the new building parts and decorations. For some reason the old base building parts have a lot better performance.

Let me show some images:

My River base with a bridge across, from a distance. I have given it time to fully load. You can clearly see the low LOD for some parts. They appear as normal walls, instead of the part it should be.

Same with my house. No decoration or lights are visible. Even the bridge on the left is not showing like it should, although even closer.

Getting closer to the bridge, with most parts now loaded correctly. Almost all the lighting still missing.

This is what it should actually look like. I had to stand right in the middle on top, to have everything loaded in, before moving away in photo mode to make the shot.

This is what the house should look like. Once again, standing really close to get all loaded, to then take some distance in photo mode.

Even when reasonably close to the bridge, you can see how lighting is not loaded at all, including low LOD for several parts. Some parts actually flicker in and out of LOD at this distance.

Here I have teleported to another base of mine. Walked down the stairs, to make this screenshot. Notice low LOD for the wall as well.

It took about 20 seconds to finally show the door, followed by the save point and beacon.

Here I just entered my Freighter. Was just too late to not have the first parts shown. A desk made of several parts.

Took several seconds to load it like this. You recognise the bridge behind, which opens up last.

Here is a long hallway on my freighter, after giving it time to fully load, as it otherwise misses the back end. Once loaded it actually looks ok, no complaints besides taking its time.

Crops in Hydrophonic Trays give a good idea of the draw distance we … I mean, I have.

A bit further up ahead in this same farm area. Just out of reach to have the back end trays load their crops. Oh and yes, those are the back sides of Standing Planters, which did not show in the previous image, because they did not load.

Oh hey, there is my Gek Farmer, just close enough to see now :slight_smile:

Turned around to show the trays again, after they had already loaded previously. Once again, that is the render distance I get for crops, but also for many parts and decorations.

So yeah, performance is pretty decent. Almost always close to or at 60fps (capped at max 60), with occasionally a dip. My settings are at high or ultra, so should expect it to be good.


#17

My farm from outside. As you can see. all the necessary detail appears to be present - and I don’t have to wait for anything to load.

However, if I go inside, and look down the left hand corridor -

If you look right in the centre of the picture, there’s a greenish square. That’s where the final few corridor sections have failed to render, and you can see the trees beyond.

If I move just a little further along the corridor, it resolves itself:


#18

Good grief! If I made a base that big I wouldn’t be able to move…I am doing good to get 30fps with medium settings. Difference is, my base is completely loaded at all times and I have several separate buildings, all built on the ground. If only I had your problems…:laughing:


#19

Where can you see the edit limit when building?


#20

You can see the Base Terrain Edits limit indicated by a white outlined progress filling up a circle which is grey itself. It shows when in the building menu, but only for parts that actually have the ability to edit terrain. When the limit is reached, it will show red, with a cross in the circle. It is unclear to me how this is exactly being calculated.

All edits to the terrain are stored in the save file under ‘TerrainEdits’. These are edits made to the terrain by building, as well as edits made by the Terrain Manipulator. However, only edits from building parts actually count towards this limit. Terrain Manipulator edits are somehow treated differently. I have some understanding of how these are being saved, but it is quite complicated. I might post some additional details on what I figured out so far, if anyone wishes to know.

Example with plenty Base Terrain Edits left.

Example when Base Terrain Edits can no longer be saved.