Uploading a base to steam workshop


#1

Today I was trying to resolve the issue with not being able to upload my base to steam workshop.
For some reason it stoped working at some point last year, with an error message “not enough space”.
Back then I just put this aside for the future, when I would have mood/time or maybe it is just going to be fixed in some other way itself.

So I’ve tried it once again and got the same message of “no free cloud space”.
Then I went to steam forums and found out, that I have gigabytes of free space on steam workshop available, as I have not uploaded anything there yet (I deleted my old base upload after 1.3 update).
I noticed that my base’s entry appeared in the workshop, but with no name, description, screenshot and etc.
So I was trying to upload some screenshots, reduce base complexity, delete everything and re-upload - nothing helped.

Then I went to game settings and got a terrible surprise, that I have only 20 megabytes of space for NMS save data and it is already fully used.
I decided to check out if this could be the reason and is there a workaround to that limitation and did the following steps:

  1. backup game data (twice :slight_smile: )
  2. launch nms and load from save
  3. while nms is still running, switch over to explorer and delete save data from AppData/HelloGames folder
  4. exit nms and wait until steam will delete game save data from the cloud
  5. disable cloud sync in nms settings
  6. restore game save data, launch nms, load save and upload base to steam workshop
  7. SUCCESS!
  8. quit nms and enable steam cloud sync (here I noted, that my base data was stored in the cloud game save storage)
  9. launch nms, check everything is working fine and wait until steam will sync game save data
  10. save, exit nms, wait for cloud sync to complete (here I noted, that steam deleted my base data from cloud and put game save data instead)
  11. launch nms again and check everything is fine
  12. then go to steam workshop and try to load my base
  13. FAILURE!

I was thrown to a completely different base location on the same planet and with the completely empty base. And not only that - after reloading to normal save, I have found that all comms on my base are gone.

I sit for a while trying to calm down and tried to restart the game. Thankfully my save loaded successfully and all comms were there again. That was close one…

Thus:

Issue number one: nms uses game save cloud space to transfer information to steam workshop storage area and thus can’t do this successfully, if one have save data sync enabled and space is used up.

Probable issue number two: nms is putting to steam workshop a reference to the actual data, stored in game save cloud area. And thus, when I reenabled save cloud sync - I deleted base data and nms failed to load it, when I tried to visit own base by loading it from workshop.

I need someones help to check this probable second issue. I have the same nickname on steam and the base name is Oakian Outpost.
If someone will have time to try to load my base from the workshop and visit it - it will help to understand if it’s me, who can’t visit own’s base or files were damaged indeed.


#2

After more experiments I have ended with this:

  • other people’s bases are susceptible to this issue - loading to a different position on a planet with no constructions present.
  • HG path finder base have loaded successfully, even though it is quite complex one.

Next thing to try - load a base, while disable cloud game save sync and have base present in the cloud game save area.


#3

Another related issue I came across was this weird glitch when visiting a base my friend had long abandoned. He had since moved and upon my return I still saw his base there on the planet. Luckily I had saved the game to a back up folder because when I tried to return to my base through the space station I ended up at his bases Terminus. No Ship, No way to return to my part of the Galaxy.

I submitted a bug report to Hello Games on it but I don’t know if they figured out what was wrong. Issues with using Steam or Playstation Networks are that you don’t control them as easily as you would your own. But then it is a lot cheaper too and a small company like Hello Games wouldn’t have been able to afford something more robust that NMS needed.

Maybe HG will fix the problem and be more transparent on the issue of just how the data is handled in NMS.
But Till Then We Just Have To Enjoy The Game As is :slight_smile:


#4

I had similar issue - terminus was throwing me to my old base with no ship access, instead of space station in the same system - this was fixed, I can confirm that.


#5

I have said this before, the size of Steam Cloud storage for NMS is ridiculously low with only 21MB. When checking other games on Steam, you will notice how most have at least 100MB or more available. This size (quota) is enforced on a per-user-per-game basis and is set by the developer(s) and should be set to a ‘reasonable’ amount. It consists of the following 2 values:

  • Byte quota per user
  • Number of files allowed per user

The size set/enforced for the Steam Cloud for NMS is far from reasonable and should be set quite a bit higher. I have reported this a couple of times and mentioned it here in the forum as well, after running into issues:

  • Unable to upload base to Steam Workshop
  • Discoveries disappearing
  • (New) save games resulting in unexpected behaviour
  • Various other issues …

Reason for those issues is clearly the way too low size set for the Cloud Storage and the way Discoveries are being stored. Save games themselves are actually not all that big in size, although they grow in size over time. From what I have seen, they will likely not get any bigger than 7MB. This does however mean, that the limit can be reached with just 3 game saves.

Now add the, in my opinion ‘stupid’ way of storing Discovery thumbnails on the cloud as well, and you will way sooner start running into issues. Those Discovery thumbnails are small images of each location you discover, which can then be shown in-game. They are stored inside the ‘cache’ folder and uploaded to the cloud as well. They accumulate rather rapidly over time, each taking up 21,4KB, soon resulting in taking up, by far the biggest part of your Steam Cloud storage.

From experience I have noticed, that I am already running into issues with just a single game save. Now add to this the ‘wonderful’ save system update we received in 1.3, where we are now allowed to have even more save slots, you can imagine the result …

I reported the issue and strongly recommended to UP this limit to a ‘reasonable’ size instead to prevent the issues many are experiencing (PC/Steam). I did this even before the new save system was announced and repeated the request when the new save system was being ‘tested’. Mind you, this issue does not have to exist at all and can be easily fixed through the Steam settings the developers have available.

For now, the only (possible) solution is as follows:

  • Empty the cache folder on a regular basis!
    C:\Users\<username>\AppData\Roaming\HelloGames\NMS\st_xxxxxxxxxxxxxxxxx\cache\
    This will result in preview images of location discoveries no longer being visible in-game. It does however not appear to break the game. This usually frees up quite a bit of storage space, often enough to be able to upload a base to the Steam Workshop again.
    Note: The following 2 files will always return (sync) and are required by default. You could leave them in the cache folder instead of deleting:
    INTRO_FEED_CACHE.JSON
    INTRO_FEED_CACHE.MFT
  • If the above fails, due to still not having enough storage space on the Steam Cloud, make a backup of your saves.
    C:\Users\<username>\AppData\Roaming\HelloGames\NMS\st_xxxxxxxxxxxxxxxxx\
    Now you should be able to remove 1 or more save games you are not using, as you can restore them from the backup when planning to use them again.

NOTE:
The above suggestions are at your own risk!
There should be no need to turn on/off your Steam Cloud syncing.

I honestly hope this will be fixed in a future update … :face_with_raised_eyebrow:

Edit: For all I care, remove the feature to show this tiny image (thumbnail) for each location discovery in-game, while upping the storage limit for the cloud, if that is required for us to rely on this system again.