Unable to access/switch to ship inventory at any trade terminal

Old save (PS4, Creative)… since the update, I can no longer access or switch to my ship inventory for selling at any trade terminal. Including terminals found in the wild, depots, space stations, and my own base. Above the sell list, it shows Exosuit inventory and “Switch [square]”, but pressing square does nothing. I do have the matter transporter installed.

Anyone else having this problem?

EDIT: It started working again just now (only in one space station) after being broke all day yesterday, but I’ll keep my eye on it when I save/reload.

BTW, I was only having this issue in bases/world, I don’t have a freighter in this save.

EDIT: I’m in a minor settlement right now, and can access/switch inventories.


Might be a PS4 problem.

I’m on PC, Steam, Normal. Just tried it and have no problem.


Is your Freighter in-system?

I’m on PC/Steam but with PS5 controller. On land terminals this button only shows backpack/freighter, but not ship, no matter how close it is.

1 Like

Ok. So here is an interesting fact. I am on PC/Steam with an Xbox controller and all is fine. However, I switched to a PS4 controller and no, Freighter inventory does not show at the Trade Terminal. In fact, I am seeing a yellow exclamation mark where it says Switch. Perhaps you need to check your controller configuration. I have seen updates mess the config up. For a time, I could not highlight waypoints from my Xbox controller. I reported it and it was later fixed. In the meantime, I assigned another button for the task.

Side note: I cannot access my ship inventory from my base Trade Termianl even though my ship is nearby.
Also, I could access Freighter inventory regardless of whether it was in-system or not.


So I was visited in my game today by a player on PS5 (maybe PS4, can’t remember) Anyway, he said there was no way to recolor things on the PS in build mode. So there must be an issue with the PS controller config. He was only seeing the yellow ! that I saw when trying to access my freighter at the trade terminal.
Hopefully, HG gets that worked out soon.


Hm. I’m on PS4, and haven’t seen the yellow ! anywhere yet. For the missing ship inventory, it shows the square for me. But when you said you had different results when you tried a PS controller, that might be some sort of clue about something.
I’m able to recolor in build mode without problem, (I’ve only tested a few parts though).
Sounds like multiple things going on.


(PS4) Same here.
However…some parts are one colour as default but the option to recolour comes up anyway…making it confusing as to whether they are colour changeable or not.
The same for the textures.

Building components (walls, floors etc.) are for the most part changeable while most ‘equipment’ (besides furniture) is not.
Annoyingly each one of these walls, roofs floors needs to be colour selected or it will be the default colour.

The derilict frigate sourced decorations are one colour as are most of the completely new decorations.