Terrain manipulator


#1

I was trying to carve into a large cliff face next to my base with the terrain manipulator, it would not have it. No, hole would be made. The cliff terrain is different then the other terrain, more rocky skin. I also tried to build into it, which worked, but didn’t carve out the terrain like other surfaces around the base. Is this a glitch, do I need to upgrade my multi-tool?


#2

I have noticed some areas more difficult to dig up…I have not experimented with it.


#3

I think this is the NMS version of bedrock.
Usually deep down and found in caves but sometimes it comes to the surface. Although it sculpts slightly with building, the Terrain Manipulator has no impact on ‘bedrock’.


#4

Makes sense. I wonder if anyone has tried to drill completely through a planet? I thought about it…:grin:


#5

I dug super deep hole trying to get to one of T0dd’s old comms on my old world but it was burried deep below the bedrock & was thus unreachable.
This indicates to me that the ‘soft’ terrain that can be manipulated is only about 80U deep at the most & that below this is the impermeable bedrock.
This would suggest digging right through would be impossible. Cool idea though :grin:


#6

No. What you’re seeing is “the end of voxel space”. Also called “Bedrock” or “Rock Bottom”.

What you have to understand about NMS’ procgen is that it builds a rough terrain map, and then builds the microterrain on top of that using voxels. Those need an unholy amount of RAM (well, not individually, but there are millions of them in memory whenever you are on a planet), so they have to be pretty careful about how they use them.
Voxels are stateful and therefore editable, the underpinning heightmap, however, is not.

I think that one of the changes they made to enable NEXT’s better terrain is to improve the interplay between voxel space and the heightmap. In earlier versions pretty much all of the heightmap, except for its lowest points, were covered by voxels. Now they allow the heightmap to pull more weight, like forming cliffs. This enables them to scale terrain features up, because they need less voxels (that, and probably that memory compression they were talking about in a few talks. However they managed to coerce the necessary cycles out of the PS4s already strained CPU).
As a side effect, we now have to contend with a few terrain features that are not editable. It’s a good bargain, I think.


#7

So, the real glitch is that I can build into the Bedrock?


#8

You can build into the bedrock? And there’s no rock afterwards in the room that goes through it?
In that case, it’s actually possible that all my above assumptions are completely wrong, because if they were right, that wouldn’t be physically possible…


#9

In a cave base I have, the structures deform the ‘bedrock’ surface allowing you to place your building part, but I haven’t tried to extend into the ground beyond one part. The ‘bedrock’ cannot be dug into using the terrain manipulator though.

My amateur’s understanding thinks that the bedrock area we can build into is somewhat ‘flexible’ but is the ‘edge’ of the interactable graphics. All the area above the bedrock must be a manipulatable mass that follows quite different rules. It can have caves, plants, rocks & be interacted with, whereas the ‘bedrock’ is simply the boundary which apparently has some tollerance to allow structures to be placed.


#10

Interesting. That suggest a flexibility way higher than I would have expected. It’s probably not carrying a state itself, as that would defeat the entire purpose of it needing a lot less memory than voxels, but now that I think it through it would actually be possible to implement the behavior to manipulate the bedrock mesh into the building parts themselves. So there’s a possibility that I wasn’t wrong completely…


#11

The bedrock stays in place, the building units just pass through it. I was attempting to create a underground base . I think what I did would have worked if it wasn’t bedrock. I put a wall with a door flush with the cliff, then a straight corridor, then a cylinder room. It should of all carved out around them. I open the door and bedrock. Okay, I’ll shoot it with the terrain manipulator, wrong. So, there is a cylinder room under the bedrock. If I could teleport in and out some how, that would be cool. Try to to grieve me in my under-bedrock base, noobs! :sunglasses: Thanks folks, I have learned!


#12

Yes, that is exactly the behavior I would have expected from it.