Anyone had success with underground bases?


#1

Mine keeps messing the terrain creating out of world glitches and when I move away, some structural parts will just fill back up with dirt. Worked so hard on it too and now I might have to dismantle it all.


#2

I stuck with old beacon being placed beneath the planed surface (not reachable by any means) and now scientist does not recognize my progress, because beacon already existed, before I started the quest. Same would happen with geobays. I tried to move my base to clean system, but this did not help. Quests were not reset and all NPCs are now asking to leave them alone and pointing me out to my old planet. so be careful with dismantling and moving out before completing new base building quests. bug reports were submitted.


#3

I have set up a new bas after finding my original post v3.1 base floating. I have made a warehouse that’s quite big with a Level below ground, this was done without the manipulator as I haven’t discovered yet, I accidentally threw a granade down on the floor and to my suprise it destroyed the tarain! So thought ok I’ll make a bridge going over the hole to the warehouse, I then discovered that I could place cuboid rooms below and when I did the tarain automatically deleted around it, so far have not noticed any land filing back in altho when I go down to the lower level there is tarain coming through the floor slightly in patches which I can live with if it stays like it is.


#4

I was wondering if he meant intentionally placed underground (not bugged). Let me know how your’s turns out.


#5

I see what you mean, could be @TWISM original base.


#6

That basically what I did, used cuboidal rooms to make my way to the bedrock where I started creating a complex, but the cuboïdal rooms are always filli g up fully for me.


#7

Nah, it is a base on a game I restarted.


#8

I have been testing an underground base, and have a few suggestions.

When you start, dig a hole just big enough for a square room. Filling in at the surface is difficult, as you can see, so aim carefully!

Dig straight down, and hollow out an area underground. Fill it in with rooms. Do not fill in the space outside the rooms, as it can fill in space inside as well (you can see this in the images).
.


Just fill in the gaps at the surface and boom! underground base. I’ve had this for a few days and it has not filled in. I was posting this in the screenshot thread, but I thought it would be more helpful here. Good luck if you try!


#9

The method I used, and it was sheer luck that I found this is, started with a square room, then I accidentally blew a hole up near said room, at the time I didn’t have the manipulator so thought I would make a bridge with small flat square prices, but whilst doing this I found I could snap another square room to the surface one and it auto deleted the tarrain around the room, made a couple of floors below ground this way, the tarrain did come through the floor a little but nothing major, I’ve since scrapped this though as in trying to make a farm.


#10

It did? Underground? Huh, I guess that makes thing easier. Plus they fixed the loophole with the terrain manipulator, so digging is now terribly expensive. Thanks for the info.


#11

No probs, now I don’t know if this is a bug, if so they may have fixed it/may fix it in the furure, also some people have done this and have had tarrain glitch img in alot worse than I did, like I say mine only had a bit coming through on the floor which I could live with, let me know how ya get on :+1:


#12

Does anyone know if biodomes need fueling now?


#13

No fuel required at all for Biodomes and crop growth appears to be at same speed.


#14

I have had the same issue as @TWISM prior to 1.32 update. Had been using cuboid rooms to make a huge underground room and after some time, the ground just reset and all rooms were filled back in with ground again. I then decided to not build underground at all to not risk running into issues.

I did however use cuboid rooms (square and curved) to get a curved wall in place as rotation and orientation made it impossible to get it right, as you can see in the image below. Did this in 4 spots total at my base.


Considering my experience with the surface resetting, I expected this to at some point get filled back in automatically again. This did not happen however, not prior to 1.32, not when 1.32 arrived and still not with the latest update 1.33. This has left me to wonder as to why these holes would not reset. Only difference I can think of is the fact that I had these cuboid blocks removed again, where with my attempt for a room underground, all the cuboid rooms were still there when they got filled back in (reset).

So did leaving the cuboid rooms make a difference prior to 1.32/1.33? Has this been fixed regardless with both these updates we had? Or have I just been unlucky for some reason? I have by now seen others building in/underground without issues, so I assume it has been fixed. I will however wait until I come to a point where I plan on building a new base, before I will consider building underground again.


#15

Update: Warning!

Currently doing some testing in creative mode, where I built a room underground to the limit, with some cuboid rooms removed to leave a hole. Flew away from the base till about a 1 minute distance at high speed. Upon return to the base, lo and behold … the cuboid rooms all had the terrain reset, while the hole where I removed the cuboids after placing did not reset.

Hole created by placing, then removing cuboid room - No Reset

Cuboid Rooms placed underground - Reset

Same Cuboid Rooms (some terrain removed with Terrain Manipulator from outside)

Will do some further testing with a variety of different structure parts/rooms as well as limit or no limit reached and update my findings. For now be aware that this may happen, it does for me at least on PC.

Edit #1:
Additional Info:
Initially I tested with only a few blocks underground, to then fly away and wait for 10 mins, 30 mins, 1hr, 1.5hrs to no avail. Reloading a save or restarting the game had no results either, the terrain just never reset with only a few Cuboid Rooms underground.

I decided to stay at the base with only reloads, while staying at the build limit with a huge amount of Cuboid Rooms above ground, I started to slowly increase the amount of Cuboid Rooms underground, taking them away from above ground, until a reset happened. Apparently the amount of blocks used underground causes the terrain to partially reset. I had always thought the terrain would fully reset, but this is actually not the case. At some point I ended up having 69 Cuboid Rooms underground, when I noticed a reset to have happened. Using my Terrain Manipulator, I did some investigating and found a big part of the underground room, not having terrain inside.

I then decided to not stay at the build limit, no longer using Cuboid Rooms above ground, apart from the entrance. I then started increasing the amount of underground Cuboid Rooms, until I once again noticed the terrain to only partially reset. This happens at over 60 Cuboid Rooms used underground. This also means that being at the build limit is no requirement. A reload/restart or moving far enough away from the area to unload the region is however required for this to be triggered. The result of this last test can be seen in the video below:

I still plan on some further testing with other building parts and will keep you informed on those results.

Edit #2:
Additional info:
The same appears to happen when using other building parts. Only the Bio Dome seems to remain unaffected. As soon as you reach a high amount of building parts used underground, the partial terrain reset will happen after a reload/restart or unloading/reloading the area.

Terrain which is then removed using the Terrain Manipulator will remain removed it seems. It can just be very hard to do so especially if this is required to be done from the inside where the tool does not work. Sometimes however, you can find a sweet spot inside where the tool does work (atmosphere affects player). Terrain likely starts to partially reset at the location where you started building underground.

This concludes my testing for now. All should be fine up to 60 building parts used underground. More may be possible, but becomes risky and may require the Terrain Manipulator to fix up unwanted terrain inside your underground base. So once at the tricky stage, reload often, to check. Happy building :stuck_out_tongue_winking_eye:


#16

I wonder how underground tunnels between above ground structures would be affected?


#17

Based on what I have tried to test so far, just tunnels, if created by placing and then removing building parts, should be fine and not reset. Any reset that happened during my testing was apparently caused by the amount of actual placed parts underground. there appears to be a limit where this resetting of terrain starts to happen.

I am not sure about tunnels being created by using the Terrain Manipulator. This would probably deserve some extensive testing on its own. I did however notice that trying to fill in holes where I had previously placed parts underground or affecting the terrain, not always fully remain filled. Parts of the holes continue to re-appear on a reload for some reason.


#18

I’ve made a nice “winery” with underground tunnel access to a cube-room, which space got mainly hollowed by erasing a cylinder-room and some multi-tooling around the edges, on the first day. Green ambient lights on the tunnels and all…
So far it has remained, unchanged, as far as I can tell.
Since then, I’m moving into more extreme landscaping, by creating a “mountain” over my base, including “small-brush” texturing to make it look almost fully natural (or rather proceduraly-noisy-looking) If that tunnel I first created disappears, I will know I’ve hit the limit…


#19

Sounds pretty cool. Keeping fingers crossed for it to work out. Would love to see some images once you are done with your project.


#20

It’s begun to bug out… I think I might have reached the limit, but will try pushing it a bit more.
So, this would be my base as it would appear to any player…


And this is how I actually see it myself, using a combination of SpaceDream, BigThings, Shaiak’sGenration and DiverseEnvironments

My “winery”… true underground part.