Synthesis Update PC Normal-new ship tech issues

  1. Purchased and used over two stacks of “distress signal” planetary maps, used them all and found not one single purchasable crashed ship. Sent me to many abandoned buildings, observation buildings, and only six actual crashed ships, two of which were empty (no ship) and four which were missions to repair the ships, which the pilot then flew away.

  2. Abandoning that approach, I purchased a shuttle at a trade platform and flew it to the station where I scrapped it. The problem was that the ship that showed up was not the ship I left behind on the planet (my fighter), but a hauler from my freighter that was in a different system.
    –A time consuming workaround was to portal from the station to a base on a planet and call my fighter from there, then return to the station.

  3. I decided to next purchase a ship at the station, which I salvaged. Only to find that the game still insisted on replacing the salvaged ship with one of my haulers even though my fighter was already at the station. (at least this saved some time --I only had to jump in my fighter at the station after salvaging this time).

  4. The next issue was when I tried to use the augment on my fighter, This time I received a warning panel popup (see below) that had nothing to do with augmenting a new slot on my fighter:

I said no and tried again. Same popup. I had to log out of the game completely in order to not get the popup (that was after I tried relogging and also logging to the mode select screen but the popup returned both times).

After logging all the way out and back in the augment worked finally and gave me the slot upgrade, thank you.


Still happening. Is this happening to anyone else?


Yes, it happens.

I ignore it. I just carry on and add the slot. Nothing bad has happened (so far).