Quicksilver Missions Still Not Visible

I have yet to see a single Quicksilver Mission.

I am legacy since pre-1.38 & have only done the original Farmer/Armourer etc missions. I have billions in units, I have all construction / starship/exocraft/multitool etc etc etc upgrades/modules/blueprints etc etc etc and still have lots of noughts in my nanites box. I have seen at least 1 variation of every fauna. It appears that not even monstrosities can kill me. I do not want to start again.

So if someone could please tell me what HG wants to force me to do to start seeing these Quicksilver Missions so I can replace my fleet with Living Ships except my Squid Planet Killer (okay that is an exaggeration).

Even though I have network on & multiplayer I have never seen anyone. Ever. The price of always playing solo I guess.

I am adding a link to a later post. This may help those on XBox.


So, you have called in the Anomaly, entered, but do not see a QS icon at the Nexus terminal? The icon looks like a yellow quill point, :smile:
The missions should show up at the Nexus regardless of MP being enabled or disabled.
Are you PC or console and what mode?


Along with @sheralmyst questions I would ask you if you are on PC, what OS you are using. I

I had the same problem (and many others) before I finally gave in and installed the Win 10 free update.

Suddenly the Quicksilver quests showed up for me!

I play NMS solo, but I had tried to get the QS quests by turning on MP but like for you, they still didn’t show up for me until the very first time I went to the Anomaly after installing Win 10.

Please let us know if you find a way to get it fixed.

HG really needs to update its spec sheet.


I am PS4 & play solo/network off. As a last resort I logged in to Playstation Network, still with network off and lo and behold up popped a QS mission.

It should be noted that apart from setting that up on Day 1 of PS4 I have never logged in to it for anything else including a few Nexus missions I tried to try to trigger QS.

If someone can explain that for me I would appreciate it.

Anyway, I’m off to get a couple of Eggs and blow some more nanites.


Glad you found something that worked for you!


The Nexus, with the missions and QS shop items, are aimed at Mulitplayer. It uses a separate connection to the servers than the Discovery Services. Because of it being part of the MP experience, it likely requires you to login for it to become available, even though network can remain turned off.


I’ve noted as a primarily offline PS4er, that the Quicksilver shop and various other features & missions to do with the Anomoly Nexus are not available offline (NETWOK off)
I’ve also had issues if signed out of the PSN that most of these features won’t work, regardless of having NETWORK (online) on.

It only affects us minority of usually offline players so they don’t seem to fix it.

There is also a persistent bug when online, with poor internet, that anything in the OPTIONS menu (Discoveries, Log etc.) gets interupted by a message about Network Features Unavailable. This pops up over & over interupting any use of the options menu and it is hard to get rid of.


For a while with the Network off it did play okay but later I had to restart Network. There is no requirement for MultiPlayer.

To be honest MultiPlayer can only be for real beginners as I even knocked off the Weekend Mission in 30 mins or so. Monstrosities mission would be the best for MP.

When I have maybe 2 living ships (maybe 10 days from now) I will turn on MultiPlayer and help people doing missions QS or Not.

150+250+250+250+1200 +250+250+250+250 (10 days regardless of where in the week you start).

Hope this helps someone.


Everytime I go to the Nexus, I only see a first mission that gives 250qs, that’s right?

I guess I’ll be doing a lot of these since the prices are almost always starting at 3.200! And there’s so many new wearable faces!!


The Weekend Events get you 1200qs if you are keen…


Only thing i can do is 250qs missions, I guess when this one is done, another will spawn and so on…

At east the missions are not hard to finish!


Yes. One Daily mission each day for 250 QS and on Friday a Weekend Mission for 1200 QS.
Some people have gone on strike and are sitting at the Nexus demanding more QS, lol. I wish them success.


I’m on PC Microsoft store version i have never seen any QS missions and the shop only has basic decals and some statues i have gotten to the new beginnings mission after resetting the simulation and still nothing

not sure if this changes anything but
running a
Windows 10
Radion RX 580 Series
AMD Ryzen 5 2600X Six-Core


Hey Sonetio, welcome! In the quiksilver merchant’s shop next to the Nexus, do you see any options to buy, say, colored jet pack trails? Also, just to get a handle on where you are in the game, are you new or just playing on a new paltform?


Thanks for the reply and no just decals and statues and I’m new to the game been playing few days just today got to the mission where you reset the simulation and finished the atlas missions not long before that


Does it show you are connected to Discovery Services on your Discovery tab?
If not, then try turning off Multiplayer in Network settings, restart the game and try the QS shop again. You may have to try uploading one or more discoveries as well. Sometimes a few restarts will get the connection going again.

If it still continues to fail, make sure to report it to Hello Games’ Zendesk. There have been a lot of networking issues since the last Crossplay update. I am sure Hello Games are working hard on getting these sorted.


Welcome to the forum @Sonetio. Sorry you are having problems. Like @DevilinPixy stated, make sure discovery services are active. It does sound like you have only the beginning QS items available. I don’t suppose HG has set it up so items open as you progress in the story? That would seem unlikely.


ok tried everything you said and a bit more have noticed that its in a constant state of connecting to online discovery services tried deactivating my firewall and anti-virus and still the same

Edit: sent a descriptive issue report to hello game
steam: no issue but laggy and no friends have it
microsoft store: issue no lag and all friends have it


Huh… that kinda makes sense. Before the cross-platform update, QS unlocks were handled on a per-platform basis. It looks like HG completely forgot to unlock all the old stuff for the new platform they’ve added… :tired_face:


I am also in a constant state of trying to connect to the online discovery services, I’ve tried restarted my game going in and out of multiplayer and all that but to no avail, if you have found a fix please let me know, i just want those missions and to be able to buy the egg