My game keeps crashing when finished loading


#1

When my game is finished loading i can see the first frame for like 5 sec then it just closes down with no error messages or nothing like that. ive tried verifying game cache and tried reinstalling redist package, but nothing works.


#2

Per a previous thread that is closed (before this Bugs & Issues section was created)…

Continuing the discussion from No Man’s Sky V1.5 NEXT Bug Reporting:

To help possibly answer both issues…In My Humble Opinion…

It depends on the Video Ram Size in your system. I am running an 8 year old computer system and recently upgraded to a video card with 4gb of DDR5 Vram on the Video Card. The prior card had only 2gb and the game would Use all that Plus 6.5gb of System Ram! which would often start over-heating my video card & system. I had to have an extra external fan blowing into the machine (with the computer door removed) to play the game.

To get the game running with the old card, I had to:

  • Close all background programs that I could…to save memory usage
  • Use the Windows 10 Services to disable Windows 10 Update
  • Use the “Game Mode” on my Virus Protection Software…so it wouldn’t check everything and slow the system down
  • Use a telemetry-blocking program…so Windows 10 wouldn’t use memory to start sending files home!

With the new card, I don’t have to do any of that to get the game running!
I still block the telemetry and close background programs that don’t need running. Now all 4gb of the Video Card’s Vram is filled and 2gb of my System Ram is used…leaving 6gb of System Ram to actually run the game & other applications!

The video card I got (for this Dell XPS 8300) is low powered (I upgraded the power supply to 600watts from 340watts…just in case) and is the same size as the original video card. I’ve monitored the heat generated whilst running NMS…and the video card’s fans rotate at the slow speed…that is how effective the video card is at removing heat. Average temperature: Video Card = 60°C, System CPU = 62°C. It is an older card (3 years old since the model was introduced) and I don’t want to start a graphic-card-war here. PM me if you need to know the make and model.

TQQdles™


#3

I tried closing all backround processes down but to no luck. the only things i had running was discord, steam and NMS. But i dont think my gfx card is the problem since i recently upgraded to an rx 580 8gb strix, i have a 750 watt PSU and 16gb ram. So the only thing that possibly could be the problem is my cpu, an fx6300.


#4

I have an i7-2600 3.4Ghz so maybe the multi-threading is helping in my case.

TQQdles™


#5

I would suggest to try a complete re-install (assuming Steam).

  • First make sure to create a backup of your save files, if you plan on using them.
    C:\Users\<username>\AppData\Roaming\HelloGames\NMS
  • Uninstall the game through your Steam Library
    Steam Library > No Man's Sky > Properties > Local Files > Uninstall game...
  • Restart Steam and re-install No Man’s Sky

If you still crash on launch, try verifying the integrity of game files
Steam Library > No Man's Sky > Local Files > Verify Integrity of Game Files

If you continue to crash I would recommend to contact Support:
https://hellogames.zendesk.com/
Make sure to include the ‘crash log’
C:\Users\<username>\AppData\Local\Temp\
The file would be called something like NMS_crash_XXXXXXX.dmp where Xs are numbers


#6

I captured a video of my game loading and me walking around in-game for a minute. I’ll provide the link to the video at the end of this message.

Note: The in-game footage is a little jerky because I am capturing the video AND playing the game using the same hard drives (in a RAID 0)…so they are really flogging the hardware. Without the video being captured, the in-game movement is really smooth.

Also, I have a slow DSL internet connections (0.6mb/sec) when compared to most cable modems (10mb/sec to 100mb/sec) systems…so I have to fly slow to allow the terrain to fill up with flora, fauna, and items.

My computer specs are: Dell XPS 8300, Intel i7=2600 3.4GHz, 8gb DDR3-10600 Ram, 2 x 1tb WD Black (7200rpm) Hard Drives in RAID 0, GTX 1050Ti w/4gb DDR5, DSL internet.

TQQdles™


#7

These issues also affect PS4.

They don’t do nearly enough QA and testing on their software before releases. They don’t seem to even check for memory leaks before pushing something out the door.

I have no idea what is causing the problems under the hood but console is also affected. They know the specs of your console in advance, so there is no excuse.


#8

Thanks for the help :slight_smile: , I resolved the problem when i upgraded my pc to a ryzen 1600x and upgrading to windows 10