Expeditions 5 - Exobiology (revisited)

A topic for the revisited Expedition 5 - Exobiology

Runs: 24th Nov – 8th Dec

Info

Previous/initial topic can be found here:

I have updated the countdown timer on JSFiddle

Enjoy!

5 Likes

Oh! HG isn’t starting them from the beginning?

Mal and I missed the first few and were really hoping to catch up on those.

I hope I am mistaken.

2 Likes

nope. 5-8 only

3 Likes

8 Likes

Beetles can be easily found near the 2nd RV.
Where are the striders for the eggs and does anyone remember which cake impresses Cronus? Working the expeditions on Switch. (I can see other player’s comm balls)
Starting planet

4 Likes

Tall Eggs from Striders here:
System: Hivaleyms III
Planet: Izonakr X
Next to RV 3 (Ogaets XII)

5 Likes

Found the recipe, assuming it is still the same

5 Likes

So this is a really good system to visit. Creature Eggs. Tall Eggs. Murky (swamp)moon for the
Sightseer and Eyes In the Reeds missions. The other ring planet moon has Ancient Bones for the Ancestors mission. I also joined the Explorers Guild here for the Famous Explorer mission.

6 Likes

6 Likes

Well Chronos had better be impressed. That’s a lot of busy work.

I have never liked playing Chef Emeril.

2 Likes

If only we could place the cakes out on a table… :cake: :birthday: :pie:

4 Likes

With only about 7 days left, I find I’m stuck trying to find the marker for R2. In space I see it. I mark it and speed toward it, but as soon as I break through the cloud layer, the icon disappears. I’m going to try leaving the system entirely, and warping back there again.

I have had some remarkable luck. I’ve fought some pirates off a freighter that was then handed over to me and it turns out to be an A-class, with three plant rooms already placed and planted, and one combat frigate. But no warp capability, no fuel blueprint (or fuel), and no portal blueprint, so it’s just stuck in the system just before the R2 System. Oh well, if I ever find a way to get the fuel bp, things will go well.
I’m thoroughly enjoying this almost stress-free vacation! :smiling_face_with_three_hearts:

3 Likes

Fuel BP. Don’t forget to talk to your frigate mission person and then check the fleet command room comms

2 Likes

I think that I had trouble finding the second get-together too. My locator refused to locate it. Moved the ship and tried again without any luck. Found a cave system and when I came out the other end then the locator started working.

You could rely on the fourth post of this discussion and chase down the lat/long coordinates.

3 Likes

I did talk to them and even tried to start a mission until I realised I had no fuel or fuel bps.

I have not yet tried checking the fleet command room. Good idea. I will try that tomorrow, thanks.

I’m happy to hear that you managed it. <3

I tried leaving the system and warping back in and that worked perfectly. Thanks for the advice. :heart:

3 Likes

Well how did anyone figure that out?! Well done!

I didn’t see any sense in interacting with the command room thingy if I didn’t have any frigates on a mission.

I think it would have been better designed to give that job to the entity who gives you the frigate missions. /grumble

I followed your instructions and now have all three blueprints for frigate fuel. And have successfully sent out my pilots on two frigate missions.

Thank you! :heart:

I also had trouble getting the game to register my three different egg types, but after re-logging with them in my inventory and then waiting five minutes it finally registered. The nasty man’s cake made and delivered. Now I’m off to finish the planet type checklist and find my way hopefully to R4…