CPU RAM Overload(aka my graphics card is too old)

Well at.least that is what we assume
My daughter is in Linux
I am Win10
We both use AMD
We both have the same issue. The game runs great. 40-60 fps
Then suddenly, white or black screen.
Then the game returns at a dismal 1-8 fps.
Once we manage to exit from.thw game and Steam, our entire PCs are locked up and CPU ram is maxed out.
Is the game tapping into thw cpu ram?
Any ideas?

Also, neither one of us can get the game to start about half the time.

But my son is also AMD amd the game runs perfectly…I give up

3 Likes

I’ve spent a lot of time writing monitoring tools for Linux, not much experience in Windows, and nearly none with Steam et.al. (Those programs like to suck resources even when you are not actively playing a game and I need(ed) my computer for work.) I might be able to help with understanding what is going on but my insights will be mostly generic.

I don’t know what you already know so I’ll start with some basics and we can go from there if there is interest. (I also haven’t found the thread where they started so I may be way out in left field :slight_smile: )

On Linux there are a couple of basic tools that you can use to monitor memory usage. top is good for getting an idea of what processes are using your resources. vmstat can be used to monitor the overall stats of the system. There are a a few others that are not normally installed on my systems. sar and iostat come to mind. And there is a free command to get a few more details on system memory usage. Beyond that there is the /proc file system which can be used to see into the kernel’s data structures. (I doubt we will go there.)

top is usually run interactively from the command line but we can run it in the background and save output for later examination. We could start a job before running the game and go back later to see what happened.

$ top -b -d 10 -o %MEM | grep -A 20 '^top' >/tmp/somefile.txt
^C
$ more /tmp/somefile.txt  # or use any editor of your choice
$ rm /tmp/somefile.txt #/tmp will eventually cleanup but why waste disk space?

I like using vmstat to get an idea if we are swapping (si and so columns). If your system is swapping then performance will be bad. It can also be run in the background.

$ vmstat --unit M 5 3  # use MB for units so the columns line up better.
procs -----------memory---------- ---swap-- -----io---- -system-- ------cpu-----
 r  b   swpd   free   buff  cache   si   so    bi    bo   in   cs us sy id wa st
 0  0      0  53449    699   7033    0    0    48    42   60  104  1  0 99  0  0
 0  0      0  53448    699   7034    0    0     0  1452  349  471  0  0 100  0  0
 0  0      0  53448    699   7034    0    0     0     0  280  401  0  0 100  0  0

Since your computers are suffering after the game is closed it must have some process lingering that is holding onto memory (if memory is the problem). It could also have left kruft in the GPUs memory causing it to be slow (Vulkan doesn’t cleanup anything automatically as far as I know). Memory issues are also a common problem with NMS releases that almost always gets a fix in first few updates.

I’m sure that I am already going off task so I’ll stop for now.

3 Likes

Thanks for all that! My daughter mentioned running one of the applications you mention. I will ask again. I am hoping my new PC which will be running a lot more RAM than required, will be a better experience but, like you stated, may be something else.
And yes, it usually does get fixed in a patch…eventually. But this has been the worst experience so far.
She is running Arch and whatever she ran in the back ground stated something about Mesa which are the drivers she is using.

1 Like

Mesa is the main graphics interface on Linux. It is a front end to most of the graphics drivers (all except the official Nvidia driver AFAIK). Brian Paul wrote the first version of Mesa in the early 1990s and it implements OpenGL and more recently Vulkan. The real drivers are modules used by Mesa. I was also writing an OpenGL driver in the 90s for Linux and Amiga but Brian was much faster, and most importantly he got through the legal hurdles. My code only got to the wire frame level before I decided to quit that one and to use his.

And more memory will often fix these kinks of problems. Graphics programs cache a lot of data in RAM to keep the speed up, and when it runs out it has to start evicting data to bring in more. This churn really tests a programmer’s diligence at handling memory. More memory reduces the problem and speeds the game in the process.

2 Likes

Thanks again! I really believe this is the issue for both of us and I really wish HG would up the rec specs for the game…I am not sure even they know what it requires :joy: they have it on so many systems now.

1 Like

Just saw someone mentioning on the steam forums that performance seems to drop the longer you play. That used to indicate memory leaks in the game. How long before it does this?

Oh, but you say once you close NMS the ram is still being used? It should return almost instantly. Use windows task manager to find out what is using it, if it’s not NMS. I’m sure you know this, but if you don’t know task manager that well, this website seems to give some good info. https://www.howtogeek.com/405806/windows-task-manager-the-complete-guide/

I’m on all amd (3600 cpu, 6600 gpu) and have noticed performance drops in quite a few places where there were none before but nothing as you describe. But then I’ve only played about 6 hours since echo launched.

2 Likes

About 30 to 40 min in. Memory leak has definitely been an issue for me in the past. It also eventually gets fixed.
My son also runs linux and he says the way he runs mesa and the way my daughter runs it, is different…I don’t remember the specifics. But his avoids the stacking and hers does not. He believes that is her issue.
But I am running Windows which is its own special monster…I will try harder to catch what is happening in Task Manager but it takes a few minutes to get it open. Usually Disk and CPU are in red. Steam is taking a lot of Disk and System is taking a lot of CPU…
However, I was just playing and had to pause the game for about an hour and it is still running but now we will see what happens when I move. This issue usually starts as I enter a planet’s atmosphere for the first time or the planet has lots of fauna or lots of flora and sometimes when scanning in the new autophage camps. Again, feels like ram overload. I pushed all my settings back a bit but no change.
Back to the game to see what happens.

1 Like

Leave task manager open in the background while you play? Is this the new one? The disk and cpu in red is not a good sign. The disc usage is probably because it’s swapping out lots of windows stuff to give NMS more memory, which may also use lots of cpu (compressing).

On amd if you press ctrl-shift-o it’ll bring up an overlay which shows various usage numbers for ram/cpu etc. It’s a bit of a pain to setup if it’s not already, but it’s part of the radeon thing which gets installed with drivers so yours should have it.

How much ram? I’ve got 16gb and haven’t noticed anything, but then the only stuff I have running is steam and any game I’m playing. Steam has a “small window mode” which takes up a lot less memory, but the only thing you can do in it is see your game as a list and play them.

2 Likes

So that did not take long. I was able to get task manager open fairly quickly. Again, it was steam and system pushing disk to 99%
This is my old pc which is why I don’t mind messing with it.
I also have 16 GB ram…will have 32GB in my new one and can use twice that.
And I am sitting here watching steam still pushing disk to 100% and there is no game running
System says gpu 0 copy…what is that?
As soon as I closed steam, it stopped…disk now a cool 0 to1%

2 Likes

Try the small window mode in steam, then go back to normal window mode. That should force steam to tidy up whatever it is doing. There are also some other settings in steam that force it to use less internet and memory. Under preferences-> library, “Low bandwidth mode” and “Low performance mode”. Also, don’t run any betas for steam.

(edit: well good luck, getting late here so sleep calling me)

3 Likes

Thanks! Will test all of the above

Edit: lol. I think it comes down to my graphics card. It is just not up to the task of NMS. :joy: I ran the util window. CPU stayed a cool 22% and below
But my poor GPU kept popping to 100%.
Edit: with the Steam changes, so far so good…
And as soon as I typed that, I landed on a planet and the game plunged to 1 fps and almost crashed but recovered
Played until I got too sleepy. Maybe the Steam changes made a difference? My PC is still very slow afterwards though. Even after closing Steam
Note: this only happens after playing NMS
Will test again tomorrow.

2 Likes

I’ve had a similar issue for years with the game suddenly freezing & blacking out for ~10+ seconds, only to often return at a diminished framerate. I tracked it down through Windows logs to the video card driver crashing & restarting. I have no full fix, but greatly reduced the frequency by using Texture Quality: Enhanced instead of High. I also switched to Window Mode: Borderless instead of Fullscreen which tended to lock my whole computer up when the problem occurred.

I’ve also encountered some Steam/PC freezes when exiting NMS (and only NMS). The worse was back in Atlas Rises, during the bloated-savegame bug. On quitting NMS, Steam would cloud-sync my overinflated save files, locking it up and dragging my whole system for about a minute. I also recall having to delete the savegame cache*.dds files (savepoint thumbnails) when that grew large enough to cause a similar issue, but these files no longer appear to be sync’d.

Very recently I had an issue where Steam always became unstable for several minutes on NMS exit. Trying to quit Steam during that time would inevitably cause it to crash. I eventually noticed my NMS shader cache (Steam\steamapps\shadercache\275850) had somehow gotten messed up and exploded to 120+ GB in size! I deleted everything in that folder to let it properly rebuild, and haven’t had the problem since (and with some precious SSD space restored).

So, dunno if any of this will help, but maybe it’s some stuff worth investigating.

3 Likes

Well that certainly describes my issue. Thanks for all of that. This definitely sounds like what is happening to me. Hopefully, my new PC will be together in the next couple of weeks. Just hope I have my save file backed up well. :grimacing:
The shader cache issue I had back before they brought in vulkan so I don’t think that folder is there now? But I have not looked in a while…
Speaking of graphic card drivers, I had to remove my card from Windows ‘let us update everything for you’ list. It kept installing the wrong interface for my graphics card. I manually update my drivers. But, still have this issue.

3 Likes

I’m not experiencing any problems during gameplay, but I have noticed that over the last few weeks the game will sometimes crash during startup, and have to be restarted.

It generally gets as far as the Hello Games logo, then drops me back to the desktop. So far, it’s always worked on the second try.

4 Likes

I have been having that issue as well. It is apparently a seperate issue? It was really bad when the update first launched. It was crashing multiple times for me. It seems to be better since the last couple of patches. If only I could play more than 30 minutes before all the rest of the troubles set in
In the meantime I.have switched to PS5 where I have to play catch up.
I just hope the next expedition is not too soon.

3 Likes

The shader folder location I posted is the new Vulkan shader cache location for NMS. I believe you are correct about the old GAMEDATA\SHADERCACHE folder, all I have there are old files from 2019.

2 Likes

OK. I will definitely look into that.

I’ve had NMS crashing once on startup so far. I thought it was just because it was a save from the Mac version, but it seems not.

If it is the video drivers crashing, you should notice a popup telling you so. At least on amd, but I’m think nvidia as well. A red cross or something should appear in the bottom right corner of windows, unless you’ve got it hidden. Usually a sign of overheating or overclocking.

Looks like your new pc can’t come soon enough.

1 Like

Hmmm, so I have a number of steam shader cache files. Most of them from 2021 and 2022
There are 3 from this month. 2 under AMDv1. Both in the MB size.
One under fozpipelinesv6. 43 GB
There are 2 under steam shader cache folder and both are from 2021 and 22 and in the MB size. The entire 275850 folder is 44GB

1 Like

I have never seen anything pop up but I do sometimes run core temp or the util window. My temp seems to be ok. I have several fans and one of them only kicks in when needed. I have not noticed it kicking in.
The whole thing is perplexing. I think maybe I will drop all settings on NMS to the lowest possible and see what happens. It will make me nauseous but it’s all for the cause. :grin: