CPU RAM Overload(aka my graphics card is too old)

So I reduced all graphics and it ran longer but still not smoothly. But for a while now, I have had a hard time getting Steam to start. Ready for my new PC.
But at least I can now play :upside_down_face:

3 Likes

My daughter did a clean install of arch linux and nms now running smoothly


5 Likes

She’s using Arch? Huh, that’s pretty hardcore…

1 Like

She and my son give new meaning to the term ‘PC Master Race’ :rofl:

2 Likes

So that’s why you feel like you finally found your clan with NMS Echoes. Your children are Autophages, they constructed their own carapace computer.

2 Likes

Thank you! That must be it. Empty-nester syndrome. Now I see why I am drawn to all the mechanical clicks and whirs. They sound so soothing and comforting. :robot: :notes:

1 Like

New PC almost ready. Windows install was presenting so many annoyances…like not being able to update the apparently useless ISO thumb drive I created because I could not get the drivers for my wireless card without windows already being installed…and I currently have no ethernet cable long enough to reach from the modem, anyway…I am now running Endeavor. We will see how this goes.

Auto settings…

4 Likes

Benchmark in medium settings. Will try high later

Linux Endeavour.

Edit: so far, the OS is working out for me. Have my son working some kinks out of running the EA app. It is…complicated
Slowly learning command codes
NMS running a solid 60fps on a mix of Ultra and High settings…simply because I do not like all Ultra settings

4 Likes

I have recently (within the last month) built a new PC for my grandson. When trying to install Windows 11, I encountered problems with the absence of network drivers on the new system, which stalled and froze the installation process. There seemed to be no way forward - but I eventually solved it.

If this is the problem you’re having, let me know. Microsoft have been up to some skullduggery (again). It seems this is not a bug as such - it appears it may stem from a deliberate attempt by Microsoft to force users down a particular path. In some cases (seems to depend on the age of the ISO file) there are workarounds.

It is, however, complicated, and I’d rather not write reams of explanation if it won’t help with your problem.

3 Likes

Wow! Thanks for that. I grabbed the latest ISO they had. However, I am feeling more comfortable in the Linux Endeavour os at least for now. If we can get the EA app running, I may stay here for a while. But keep that info handy, just in case.

2 Likes

In windows 10 you could just unplug the network (no wifi or cable) and it would let you install without having to make a ms account. Do MS not allow even that anymore?

1 Like

So, you know those days when.you put on the sunscreen and the hat and you have a free day and you are all ready to mow the yard then the battery is dead and a tire is flat and the charger is missing and the air compressor has a busted hose?
Well that is kinda how it went trying to run Starfield on linux last night. It would not recognize my graphics card because it sees the mesa drivers. I tried a few things from the proton database site but no good. Went to bed at 1 am with my head splitting from pain…woke to no internet. Going back to bed

5 Likes

Don’t worry, running it on windows 10 was almost as bad. It ran, from 60fps to 15fps in the intro, then crash to desktop. Over and over again. It takes approx 5 mins to get to the point where it crashes, and you can’t save. So, ok, my amd gpu drivers are a year old. So what? Fine, update them.

AMD makes the worst driver installation process imaginable. Couldn’t download, could download but then it stopped. Random “OOPS something went wrong, we screwed up, ha ha ha” messages. Complained about everything, about windows update is busy (it’s not) then finally after the 7th attempt it decided I’d run out of disc space. Delete random caches and old db’s and amd temp files. Finally, amazingly, randomly, it installed.

This is at 1am launch day. Finally working (terrible performance) at 3am and was able to play for an hour. The first few hours is…uninspiring…a bit dull… but it does get better.

3 Likes

Why does anybody try to run a Bethesda game at launch day anyways? :man_shrugging:

2 Likes

@GullyFourmyle
Any idea how to get the EA launcher running in Wine? The EA app says it can’t connect to the internet yet other apps have gone thru Wine with no issues.
It keeps timing out trying to send info

I just tried loading wine and the EA browser and failed for a different reason than yours seems to. Wine is missing the iconv.dll which Mono (C#) wants. That was with the 32bit wine, the 64bit wine doesn’t get nearly that far (EA runs but dies trying to load a different library).

When the EA installer was running, it did go to the network and I think it got something, at least it tried to un-encrypt some files after downloading. However there were a some errors about secure cookies. (Edit it looks like it connected to Akamai and Cloudflare so I don’t know if that was the EA installer getting its files, or Wine updating something.)

The version of wine that I have is 7.12 which EA describes it as a testing version with experimental patches. Which version do you have and which distribution are you running on. I can go buy another disk and try something closer to what you have. (I need the disk for another project anyway, I’ve just been putting it off).

1 Like

Let me check on that when I can…will be out all morning…Endeavour, Wine…I am new to all of this…
Here is what my son says :sweat_smile:

It is working for me, although not directly. :slightly_frowning_face: I tried various things (different versions of wine, drivers, etc) and could get a lot of failures but nothing network related.

  • I loaded Arch (I think that is what you are using. ??) The latest version from Sept 6.
  • I loaded wine and a lot of dependencies that I found from the Lutris install. I tried the stable, dev, and staged version. Ended with wine-8.15 (Staging). They all seem to work the same.

Running the EA installer directly would install the launcher but that launcher comes up with a blank window. I possibly don’t have the prefix stuff right but the problems that I saw were in shader compiling and not in network. It connected to at least 12 different sites.

I then loaded the Lutris app (because most of the sites offering help for this process pointed that way). Inside of that app I could install the EA App (again) and it came up working.

I got this far, I don’t have any games so I can’t test much further.


This is running Lutris which in turn runs the EA App as a game.

There seem to be other wine installations. Lutris, GE, Lutris-GE, Lutris-GE-proton … And special ones for particular games like LoL. For the dependencies I followed instructions on https://github.com/lutris/docs/blob/master/WineDependencies.md, I have not tried alternate wine installations.

I’m not sure where to go from here, I’ll continue to look for possible problems with wine and the network.

1 Like

Ok. Thanks a bunch! I will tinker with all of this and pass it to my son.

1 Like

I don’t know if you want to debug it this way or not but I can give you some hints of tools to try. To watch the network connections there is a command called netstat that shows connections. And one called watch that will run a command every few seconds. Netstat came from the net-tools package. To watch for connections to be made by the EA App/wineserver I used:

watch 'netstat -antp 2>/dev/null | grep -v firefox'

The output starts off empty until the app starts running then becomes:


It seems to be a mix of Amazon and Google cloud servers, at least one is in Germany. Some didn’t answer the reverse DNS queries with anything that I recognize, probably ad or traffic monitoring servers.

The State column is the most interesting, LISTEN will be internal communications for wine. Same with anything connecting to ::1 or 127.0.0.1. The rest is someone talking out to the network. ESTABLISHED means that the connection is up, SYN_SENT means that the connection is being attempted (and if it hangs around it probably means there is either too much traffic to that site or a firewall is in the way). TIME_WAIT means that the connection is closed. There are a few other states but I don’t think we want a class on TCP here. And I ignored the UDP connections, that mostly comes into play when a game starts. (And since they don’t have a true connection they are a lot harder to view.)

There are a couple of other tools that I use a lot for quick looks at the network. ping and traceroute can be used if you know the server that you are trying to connect to.

There is a whole other class of network problems that can occur once a game is trying to run. In particular one called NAT traversal comes into play if the remote server wants to connect back to your game. I think I read that you were once using a cell network but are now off that one. (I could be mis-remembering here.) Cell phone based networks are a real problem for NAT. The connection gets messed with in the central office and they use a different protocol to talk to your house, so NAT seldom works as expected. This usually means that only one device can be playing games at a time. My daughter-in-law is using T-Mobile’s network. They can be playing a game on the PS4/5 just fine but when the Switch is turned on, even just for YouTube etc, the game freezes. I really don’t think we are at the point of worrying about NAT yet.

1 Like