Graphic Settings

Since the Endurance update, my game lags and stutters, especially on planets, even on lowest quality (that’s suspicious). It’s kinda usable in empty space and on my newly-minimalist freighter. Time to adjust my graphic settings again… Has anyone discovered any hot new tips recently?

(The advice to delete some NMS shader cache is outdated, correct? I’m not using Nvidia Experience to auto change settings because I find it too intrusive, does it propose anything useful?)

Remember this community revelation 2(?) years ago where everyone changed their “high and low thread” graphic settings in a file? My performance is now back to how it was before that.

Current plan:

  1. Check whether my ”hi/lo Thread “ settings got reset
  2. Update drivers
  3. Blow dust off fans?
  4. Check temps
  5. Watch Streams only on tablet and not in browser

Task Manager tells me my GPU is bored to tears (it didn’t seem to be the bottleneck, hence I haven’t updated its driver yet). The CPU usage is all over the place, sometimes maxing out on medium settings. I did not have the impression my PC was overheating (it’s 20-30C here).

Specs: SSD, GTX 1060 6GB, 16GB RAM, i5 CPU 4 cores. I don’t even have 4k or dual monitors or anything graphic intensive going on on that PC, it should not be that stuttery.

I have not tried VR yet… At the current state I expect it to be headache inducing. Last time when I started VR for a multiplayer game (before Endurance), VR never even loaded (eternal starfield). :frowning: I just want to see new shinies in VR… :pleading_face:


I feel your pain. Shader cache folder is empty because Vulkan takes care of that. I did find a box to check in my Steam settings to allow Vulkan pre shader rendering or something like that.
My CPU story is the same. Only, once in each gaming session, it is like my game suddenly bottlenecks, CPU goes full tilt and my fps drops dramatically and I hear a terrible noise thru my speakers. I have found that if I just lay down my controller and wait, it will settle down and go back to running smoothly.
We are not alone.
Currently, the game will not even start for my daughter in Linux with Mesa drivers. And I see many others having stuttering and freezing.
I took off my cape and got smoother results but I have put it back on since the Endurance update.
There is something screwy somewhere in NMS. My untrained brain says it is because they have optimized it so much for every single platform out there…each time they add a platform, I get weird issues.
I do have an 8GB card…AMD RX 580. But I believe the problem is I need a new motherboard which means a new build…the game gives me a steady 40-60 fps…until it bootlenecks in my CPU
I keep my graphics card updated always. Game looks awesome for me right now with just a few minor issues.


@AdaRynin I have changed category, considering the issue being NMS related.

Do not bother adjusting thread settings, as changing it will not do anything. Besides, you’d be forced to set your settings file to read only too. This change was made by HG quite a ways back, due to changing thread settings causing more issues than it solved.

You may wish to update graphics drivers, and possibly force a reset of graphics settings by removing it so it gets regenerated upon launch.


I just want to see new shinies in VR…

All the new features look great in VR. Sorry.

How long does it take to get from starfield to playing the game?

On my old rx480 (similar spec to 1060) I could run at 30fps with pretty much max settings. In VR had to turn everything to min, and turn the scale down in steam to get the width resolution to be approx 1280 pixels. Locking frame rate to 45fps AWS made it much smoother. HG did keep “improving” the performance, which for AMD users usually means downgraded performance.

Have you tried restarting windows (via start menu)? For me, NMS is always super stuttery after an update and restarting windows pretty much sorts it. Something to do with vulcan shaders.

1 Like

I have shut down and restarted since then and afterwards it worked its way up from 12 fps to 30. :slight_smile:

I had tried changing the hi/lo thread settings but the game overwrites my changes at start (I left the file open in notepad++ and it said the file changed). So people who do that probably also set the file to read-only. I don’t even know if these two year old tips are still valid.

Yesterday I tried the tip to enable the Steam setting that caches Vulcan shaders. So yeah, it could be them causing stuttering, right after each update! Not the best user experience. Restarting is easy — but not everyone tries that.