Base Restoration

It looked like 1.58 might now have enough of the problems worked out that I migrated from Atlas Rises to Next and am using 1.58E with my Day 1 save.

Used the option to bring in my old base and it worked great, almost. The problem that I cannot get rid of is that the grass is growing inside rooms in the base. Tried a few tricks to get rid of this but since I am writing this they obviously didn’t work. I tried:

  1. Mowing the lawn with the terrain manipulator but had problems with the uneven ground below sometimes making me fall into a crack.
  2. Did an old trick of clearing shadercache which worked so long ago with grass clipping through the floors of bases in Foundation.
  3. Can fix this for individual cuboid rooms but that means deleting everything inside first and then rebuilding everything again. Takes too long with the flora and does not work for the round room around the base computer.

Tested option 3 with the cubicles that I made for the indentured servants. Each is squirreled away in their own windowless cubicle which is a cuboid room tacked onto the end of a hallway and therefore separated from each other.

Has anyone found a way around this type of thing other than to build bases from scratch?

PC Normal and Thanks.


It’s not just a problem with restored bases. It happens with newly built ones, too.

Clearing the terrain before building is not the answer either. Eventually it comes back - in some cases to the extent that you can’t get into your buildings any more.

Raising the whole structure above the ground on foundations will prevent terrain coming through, but there’s a problem with the foundations, too. Using them can stop you from placing some items in your rooms.

The most workable method I’ve found is to build on raised foundations, then delete the foundations. It looks weird, because your buildings are floating in the air, but the grass and terrain doesn’t come through.


Thanks but was hoping that someone had found a work around that did not require dismantling the base. Putting a base up on blocks would require removing everything first.

The secret or stealth patch notes for 1.58 indicates that the likelihood for this type of error had been reduced but in my experience the failure rate is 100%.

One thing that I tried but knew that it probably could not work was looking at putting in foundations in an already created room without destroying what was already created but that doesn’t work.

1 Like

Just an idea, but not sure if it will work. Ever noticed how building underground will remove vegetation above ground? Might be worth a shot to build for example a large cuboid room underneath your base to get the vegetation above removed. Can remove these cuboids after if wished for. Of course this will require you to get underground in the first place. You will also be left with either a large underground hole, or a new structure underground. Not sure if this will eventually be filled in again, including vegetation above. As @Polyphemus mentioned, this is likely going to be the case, although HG has been working on getting this fixed. I have recently noticed an additional icon showing for terrain edits saved with your base.

Too bad there is no easy fix for your issue. Would be nice to have our multitool equipped with a lawn mower option :wink:

1 Like

Thanks. For last hour and a half have been trying exactly that - build cuboid rooms below and then deleting does remove the grass growing above (not through) the floor but it also leaves the space underneath empty which cannot be evenly filled in with the terrain manipulator. These holes act as movement obstacles.

This process also renders the work stations for the indentured servants inoperable and deleting and rebuilding these does not work as the servant is in the hole beneath the workstation.


  1. You can add the rooms without being underground. You can also add the round room underneath.
  2. They also placed the immovable base computer at the same place as the ladder if you have a biodome above the the round room.
  3. They also pulled a “funny” with the quests. The exocraft indentured servant is located in another system but cannot even get close to the icon for that quest as it is in the middle of space and your ship is not allowed to access the point where the icon is located, you just either blow past it or ship comes to stop when heading in that direction.
1 Like