Wires and Logic failing (on reload)

PC (Steam) - version 2.09.1 (normal mode NEXT save)

I gave up trying to wire up my doors. Most of the times all the hard work getting my logic to work, goes down the drain again when I load into my game a next time. Doors as well as logic appears to lose connection, failing to function like it did before. Small electricity symbols appear to indicate an issue. Accessing the build menu, selecting wires, shows there are no longer any connections, besides the wires that remained. No longer can the logic itself, nor the doors, be hooked up again.

Another issue I noticed inside my bases, is the Proximity Switch itself. In many locations, as soon as it gets activated, it will no longer deactivate, as if now getting a continuous signal from something else. It appears as if any location on walls or floors where lights are connected cause the Proximity Switch to malfunction. A building part that is not directly connected to where I have my lights, often results in the Proximity Switch to work fine on it.

I have however not been able to easily reproduce the same issue with the Proximity Switch, in a simple creative mode setup. Just a Battery, 4 Solar Panels, a couple of connected walls with powered lights is not showing the issues I face in my base.

No clue what is causing the above issues. You’d expect everything to remain connected. I’d also assume that individual logic parts act on their own, only influenced by their connected wires. I hope this will be looked into and fixed in the near future. For now I see no point in trying, leaving my doors wide open.

Edit: Just restarted my game where I had removed all the logic and wiring with it. Had replaced the doors to show them having connections when in wiring mode. Checking the wire mode again after restart, shows no connections on the doors anymore. So the doors even fail on their own.

Edit: Changed version from 2.09 to 2.09.1


I’ve had to replace most doors with identical ‘new’ doors.
Use of a signal booster seems to glitch base parts.
I’ve had a base which thought a decorative monitor was a reason to stay open.
Decals have weird collision and locating issues.
Old lights on thin wall panels cause multiple issues including being not replaceable and getting ‘maximum base parts’ type warning.

I’m still a fan of the smaller, Atlas Rises size bases (give or take) as they seem much less glitchy than the very large bases do.


From what I have gathered from others that have delved into the door powering issue, it is best to connect your proximity switch with a power inverter to get the desired effect (meaning…if the null condition is to have the doors open, then you would need for the null condition to be in effect when you are in proximity.)

Forgive me in that I have not tested this myself before posting this possible solution. I have been drawn in to the issue of no longer being able to locate my primary S-class MT location…and door power was the one thing I left for further examination for my legacy bases.

As for connections no longer viable, I have noticed most of the new industrial base components will not allow a power connection if you don’t establish it immediately after you build the item…which has had me delete and rebuild several of those items.


@Mad-Hatter: I certainly prefer the Beyond version, but it has added a lot of new issues on top of already existing issues. Even though my bases appear to have merged, I can at least add to my base again. Back in Next, the limit was reduced to a point I was all of a sudden left having reached this limit. This meant I could no longer build anything, not even a new base. Terrain however no longer gets removed when expected; likely due to this same ‘old’ limit. Next had lots of rendering and popping/LOD issues, which I no longer experience. I certainly see improvement for that matter, although even more troubled at the moment.

@LordMarkov: Sorry for not having mentioned the ‘Power Inverter’. It was actually part of my logic to make a door work properly with a Proximity Switch.

When wiring up the required logic to the door, I can get it working fine in one go. If I then save and reload it completely breaks on me again. No matter how often I try to rebuild, it just won’t remain functional. Not in my experience anyway.


Don’t get me wrong. I like not having an imposed limit on how I choose to build. What I was more saying was my preffered size of base generally is that of the Atlas Rises era.
My current bases are probably slightly more complex than my old ones but I tend to keep them fairly reminiscent of the sizes I got used to build…I just have lots of them all over the galaxy :grin:


@DevilinPixy @Mad-Hatter, do these issues occur when you leave base as well? Or only when exiting and re-entering game? What happens if you enter game then leave base and return. I notice some bugginess when I load in sometimes and leaving and returning resets everything back to normal. This loading issue also occurs sometimes when I fly to quickly back to base from space. I wonder if the bug is due to the nature of the electricity. Perhaps the wires behave as if they are attached to a finite source. When not playing and then returning the wire believes it has no power. I’m going to be experimenting tonight as well and dive deeper into the power system.


I have not tried leaving the area to see if it works when I return again. I’d be interested to hear your findings.

1 Like

Seems to be constant regardless of loads.

Wires now appear to remain connected in update 2.09.1 (Steam default). So my logic now remains in-tact after a reload. I do however still have the weird issue where the Proximity Switch is getting a signal from elsewhere in some situations.

Never mind, I spoke too soon. Even though my logic still works, the door connectors still lose the ability to attach. This results in the wire going into the door connector, to no longer trigger the door. So logic works, door remains open again regardless.


I was able to replicate this with one of my bases last night. I had 2 doors powered with the proximity switch and power inverter. However upon reload, one of the door stopped working. It appears that the completed circuit to the door loses its connection.

I have noticed that most of my doors, especially from legacy bases, will not connect to power at all. You would think the fix is to rebuild the doors, but when I delete I cannot rebuild it (getting a Base Complexity Limit Reached message.)


I had this in my older p/d save.
Its horrible! The more you amputate the defective base peices, the more the ‘disease’ spreads, effectively ruining the base.


@LordMarkov and @Mad-Hatter:
I merged both your replies here, which describes the bug issue you were referring to.

I have tried replacing doors and even changed the wooden walls they used to be placed on. Back in NEXT, walls would turn into doors when a door was placed or a prefab connection was made . This appears to have changed somewhat as well, noticing issues because of it. So where I have doors, I now actually use the doorway, not a plain wall. Either way, it does not fix the issue, as these doors are bound to lose connection to logic/power.

You can bypass this restriction by changing the Base Complexity to Ultra in Graphics Settings, although you should likely change it back again after applying fixes.
Not sure if this setting is available on console though, but I am sure someone can verify.


I just went through all of the menus in the options tab. I could not find a base complexity adjustment.

Edit: I forgot to mention that I am on PS4 for that console double check.


If I recall correctly, you are on PS4 right? I already feared it would not have such a setting to temporarily be able to avoid the complexity limit reached issue.

Thank you for verifying :wink: