Why cant i take a photo its a mystery! NMS

Hi Guys

just arrived here.
Ive been having issue with taking a photo in NMS
when i went to OPTIONs and then photo the option to TAkE SREENSHOT is RED at present its the left hand mouse button but even if I change it it still wont take a photo in game. I have everything the option offers when I press X but when i try and take a photo it doesnt work . I am stumped with this one.

5 Likes

Hello, @Amber, and welcome to the forum.

As you mention your mouse, I’m assuming you’re playing on PC, through Steam.

(oops -edit)
You can take screenshots via Steam by having the Steam overlay active. This is something you need to set up in your Steam account settings.

During normal gameplay on PC, screenshots are taken by pressing the F12 key. The left mouse button only becomes your active shutter control when you’re in camera mode (although F12 will still work too).

:grinning:

5 Likes

Welcome to the forum @Amber. Yes, @Polyphemus is correct. Overlay must be on. Also, F12 is more reliable, for me at least, than using my XBoxOne controller on PC. It also helps to avoid picture cropping.
Hope this helps!

4 Likes

In addition to what @Polyphemus replied, once you find the camera by pressing x, before you use it you can press/hold the CTRL key and then click a number key of your choice to bind the camera to the number key. (I have mine bound to the zero key, and my torch/flashlight bound to the #5 key, for example.)

So, 1. Open Camera mode, either using the cumbersome X-key menu or by a bound number key.
2. Hit the mouse button or F12 (if you are using Steam)
3. If you want to share your photos, look for the photos you take in game in your steam NMS screenshots folder.

Let us know what PC platform you are using if it is not Steam. And also if you need advice on how to find your screenshot folder.

Welcome to the forums, @Amber!

4 Likes

Sometmes a Mission from an NPC specialist might ask you to take a photo of a typical planet that you must find. Like a desert planet for example. When that happens you DO need to press the left mouse button (or interact button you have set) to complete the request while using camera mode. So basically find the planet, go to camera mode and press the mouse, NOT the F12 screenshot in that instance.

My choice with a generic game controller used with a PC is to set one of the buttons to F12, just to take screenshots if the keyboard is not withn reach. Using a controller personally I find a little easier to control the camera mode, moving the camera about.

2 Likes

After enabling the Steam overlay, if on PC, you can set a “hotkey” for Photo editor. To set a hotkey photo mode (for PC):

  1. Enable Steam overlay
  2. Press X
  3. Press E
  4. Hold down on Ctrl and press a number (1 - 0)

Now pressing Ctrl + that number = enter photo mode

Once in photo mode, whatever settings you make are “remembered.”

3 Likes

Actually, (If I understand you) on PC (Win 7 and Win 10) you don’t need to press CTRL key again unless you are setting a new number key binding. All I do is press the number key to bring up the camera mode.

3 Likes

Interesting. I’ll test tonight after work. Thx 4 the tip.

2 Likes

Thanks that’s really helpful I will try it :blush:

2 Likes

I really want to use the photo option in No Mans Sky but the ‘Take Screenshot’ option is in red

image0.jpeg

3 Likes

I’d try “Reset to default” and see what that listing changes to. I don’t think it’s both mouse buttons.

2 Likes

Yes, reset to default pressing the ‘middle mouse button’. For some reason, even though the default is ‘left mouse button’, when assigning it manually, it turns red, regardless of what you assign it to, even if assigned to the same default.

2 Likes

Can confirm. When you’re in the analysis visor, 1,2,3 are set to change visor modes, but I have the 1 and 2 set as shortcuts to toggle 1st/3rd person and taking screenshots. When using the visor, I take random screenshots and change in and out of third person… :stuck_out_tongue_closed_eyes:
I sent a list of double booked shortcuts to HG’s Zendesk, let’s see.

3 Likes

Hi Clement

Thanks, I have done that already

And changed the button I use on the keyboard but the ‘take screenshot’ remains in Red for some reason

Thank you for your help

2 Likes

But As I am left-handed I’ve reassigned other buttons to and that one is the only one that remains red after I’ve reassigned it

Thanks

2 Likes

I would suggest to report the issue to Hello Games, as it can apparently not be re-assigned at all. Doing so will always make it show red.

That being said, I would still suggest to set it back to default, make all the other changes you need, but leaving the ‘Take Photo’ button at default, so it doesn’t show red. Any changes showing red, means it will conflict elsewhere.

You can still take images using the default F12 that Steam is configured to, which you can change to your liking in Steam’s client Settings > In-Game.

https://hellogames.zendesk.com/hc/en-us/requests/new

2 Likes

I just remembered what I actually wanted to say: F12 takes the full screenshot. When you use Photomode (for missions) it cuts off a few centimetres all around. And only one of the two includes the portal coordinates watermark (I think F12).

3 Likes

Yes, F12 (Steam default) will capture the actual screen, including whatever UI/glyph sequence is visible, while the ‘left mouse button’ (in-game default PC) will not show UI or glyph overlay. You can however use ‘Left Shift’ to hide UI and glyphs to then take a clean screencap with F12.

The cutting off, from what I understood, is caused by the FOV settings used and taking pictures using the in-game ‘left mouse button’, while F12 actually captures the screen without any cropping.
See more discussion about it here and some of the replies that follow:


And a topic about the issue here:

There have been some fixes regarding this issue, but cropping may still be present?

3 Likes

Yes. Cropping is still present when using the A button on my controller. F12 is the way to go for me.

2 Likes

I have set the visor-1,2,3 binds to Q. That toggles through them 1,2,3,none. 1,2,3,none., leaving my number keys free for other keybinds. My number 2 key is bound to refresh my mining tool.

oh, that is a good idea! :heart:

1 Like