Uncooperative Icons

Fixed in 3.98!!

Started with 3.94 - Endurance.
PC, Steam, Normal, save file originated in 2016.
No mods but I do edit the save file.
Written up to NMS Zendesk on 23 Jul 2022.

  1. One or more icons show up on the helmet scan with an arrow. Turning in that direction causes the icons to fade out and disappear. The location cannot be marked.

  2. Icons don’t show on the heads up display (HUD). For example the Starship icon doesn’t show up on planets. Most of the time when flying, the Space Station and my freighter have no icons - not next to them nor on the HUD.

Sometimes there are persistent icons: I used a Transmission Tower to mark a crash location. Walking or flying, I could not get the marking icon even near the center of screen. Pulsed off the planet, turned around, and followed the icon all the way to the wreck on the ground.

I started a new Normal save and the icons work correctly.

I don’t find any similar problems when I search the Internet and thought that I was alone until @unique mentioned that they’d had what sounded like the same difficulties with the weekend digging up bones mission.

Any help, directions, observations, etc. would be appreciated.


So. Turn to the right.

Turned just slightly and the icon is fading.

A little bit more and it’s gone.

Tried moving to where I thought I should wind up - but nothings there either.


From the new Normal save:

Arrow pointing to Anomaly icon.

Still there.

The dot at the point of the arrow is the cursor. Useful and shows the distance.

Same thing but with the old Normal save.

There’s the dot.


It looks like your HUD is on a small setting…?
I actually have mine set closer (120%)? but have had occasional glitches where it goes small & is barely big enough to see/read.
Not sure if it’s related to your fault but it might be.


Where would I find the setting?


It’s in the options…under video I think…?


Thanks! Found it. Tried it but it doesn’t change my problems.


Was on an ancient bones site last night and all the icons seemed to be working again for me.

Have you tried changing your multi-tool? If it’s the legacy save multitool, maybe it’s gone wrong or maybe somehow mixing old “add-ons” with new ones causes the problem.

Try buying a new multitool. I recently acquired a new multitool and that didn’t have the problem, although the problems weren’t as bad as yours.

Also, trying turning the HUD off in options, then after a little while, turning it back on again.


Happy cake @temp


Bought two new multitools. Outfitted one. Left the other alone. Neither seems to be a solution. Sometimes there are icons but they disappear when I try to center on them.

The multitool was a good thought! Thanks!


Went on The Burrowing Doom mission. Couldn’t see most icons and the ones off the sides vanished when I tried to center the screen on them. Finally landed several times within less than 200u from a nest, used the Target Sweep, and dropped a marker where I thought I should go. Flew there since I have no ship icon for the return trip and wouldn’t be able to call my ship if I ran into sentinels. Got lucky and finished the mission. Warped back and had icons - at least temporarily.


Still no joy with 3.97 - icons still not behaving.

Icon pointing left.

Moved slightly to the left. Icon fading.

Moved slightly to the left. Icon gone.

Used this MT.


3.98 has cured my problem with icons and HUD!!


Woo Hoo ! So glad to hear it. :smile:


Glad for you!


Ah, that is lovely to hear! :slightly_smiling_face: