Severe save game issues continually ignored by HG, are back


#1

There seem to be many problems regarding the save file system that have been in the game since launch, and seem to cause problems every time there is a major update, and a lot of the time in between, as well. Since 1.5 dropped, now I have been seeing lots of threads here and on gamefaqs.com where PS4 players with old saves are reporting crashing, low performance, whole inventory going blank, discoveries going missing shortly after scans, and even being forced to completely start fresh from the “Press square to initialize” screen.

So I am going to give everyone a history of all the save game problems I have experienced since I started playing on Day One. That way people will have a perspective on the scope and scale of this issue, and how long it has been since HG has been sweeping it under the rug and ignoring it.

It’s time that HG acknowledges that the PS4 save file system is completely screwed up and many of our saves are corrupted by various problems. It’s time that they get serious about fixing this for us. It’s time that they quit acting like it’s our fault for having played the game for a long time, and stop treating us like edge cases. They need to fix this!!! We are tired of the crashes and lost play time.

Note: I realize this post concerns issues that do not affect every player. However, I believe it affects enough players that it’s a very serious issue and I know from personal experience (as I will demonstrate below) that HG has been ignoring this issue.

PRE-ATLAS RISES SAVE FILE PROBLEMS

In 1.0x there was a bug where the game would seem to be saving, but would not be saving. When they patched it, the patch notes said something about too many discoveries causing this.

While HG did fix the bug where the game wouldn’t save, their fix made it where the game would now purge old discoveries as you make new ones. So lets say you visited 50 planets and scanned all the flora and fauna, and visited lots of waypoints. And you named everything. Well, by the time you finished doing the last planet, you’ll find that the first one is now gone from your discoveries screen. It can only hold a limited amount of data due to the PS4 save file being limited in size to a fixed amount—less than 40 MB for all your slots, which is very small for a modern game.

While it’s true that you can recover old discoveries that have been uploaded to the server by going back to the system/planet where you made them, this does not help you to find those systems, especially given how slow and unreliable the discovery scanner system in the galaxy map is. Often times, I’d return to an area and nothing would pull up. If it did show as being discovered, upon first inspection, the name would not be what I changed it to. Only after selecting a different star system and then selecting the original star system would the custom names pop in.

But also, the game will purge discoveries that you have not uploaded yet. So there is a potential for losing discovery data—in a game where the sole purpose is to explore things!! This is unacceptable.

After 1.2 did not fix this, I reported to HG the issue that my discoveries keep getting deleted. They asked me to send a copy of my save file, so I did. This was the last time I heard back from them; they said players with very long play times would experience this issue and they were looking into it.

ATLAS RISES SAVE FILE PROBLEMS

When Atlas Rises came out, introducing portals, many of us went through portals to make discoveries. If you did not enter and exit an exocraft, then you could scan creatures and plants but the discoveries would never get logged. You had to actually enter and exit an exocraft before the game would add the actual planet to your discoveries list. Then your flora and fauna scans (and discovered save waypoints) would get added to that.

However, sometime between 1.32 and 1.37 people started experiencing problems with the save file system again, where the game acts like it’s saving, but really it’s not. I recall that the patch notes and forum threads about the problem indicated that the cause had to do with people who made lots of discoveries on the other side of portals.

Whatever the cause, 1.38 purported to fix these problems, and also introduced a new save file format with 5 slots of any game mode type. On PC, the game would back up the original 1.37 save for safe keeping in case something went wrong, but on PS4, I’m not sure what they did.

All I know is that on 1.38, my game would freeze for a moment whenever I would save. Support let me know that this was affecting players with very long play times, but they did not seem concerned about fixing it anytime soon. I hoped for a 1.39 that would fix it, and I kept telling them that the discovery purging was still happening as well. I asked them to increase the max file size on PS4 and make sure the game saving was not happening on the main thread. I asked them why don’t they just do what Skyrim does and let you make as many saves as you want, whenever you want? No response.

Time went on and the crashes and bad performance got worse. Finally in January my 1.38 save died. I could not load the game at all. I sent my save to support and never heard back. The same thing happened to several of my fellow twitch streamer buddies, and it was pretty devastating to the NMS twitch community. Most of us stopped streaming because we were so fed up, due to the fixes never coming.

When I quit streaming NMS, I had regularly 20+ viewers each time I streamed. I regularly had people in my channel asking if they should buy the game. They got to see the crashes and performance issues for themselves.

MORE ABOUT THE PROBLEMS OF 1.38

There were many bugs in 1.38 that Hello Games chose to leave in there, and not patch, as they worked on Atlas Rises. I believe some of these bugs were slowly but surely corrupting people’s save files, and they knew it, but they still ignored the problem.

I know they knew about these problems because I sent them numerous bug reports on these issues.

For example there was a bug in 1.38 that caused planets to be the wrong biome if you loaded a save, then switched to a different save in a different galaxy. The game would think it was still in the galaxy of the first save, since NMS programmers evidently forgot to program the game to clear its local cache between loads.

I also remember people saying that if you took advantage of any of the following things, it could bork your save:

  • claim a base on the other side of a portal, then return back through the portal, then use terminus in a space station to go to the base
  • retrieve multiple glyphs from the same traveller grave by leaving and coming back to it
  • if you ever used the item duplication glitch involving your grave between 1.03 and 1.09

I also have suspicions that if you ever did any of the following things after 1.38, it could glitch your save by causing the file to write beyond its limits, corrupting the data somehow:

  • completing the sequence of traveler interactions after the point where the traveller is supposed to start just giving you nanites as a reward; if you interacted with another traveller and his grave after that, the quest would bug and start over at the beginning, and not give nanites anymore, possibly glitching your save
  • building an exocraft race track on your base after the base was already at 99% (it would count each race waypoint against your base complexity, allowing you to get up to 112% complexity)
  • forming a monument within the perimeter of your base by interacting with another player
  • using any glitch that let you build items outside the perimeter of your base or build more than the normal complexity limit
  • visiting the base of another player who used any kind of base-building glitch or who had an exocraft track such that their base was over 99% complexity
  • heavy use of the terrain manipulator
  • making a base on the same planet in the same spot, both in normal and creative

Whatever the cause, it leads to an inevitable scenario where your save game seems to be “full” and you can no longer make new discoveries without old ones disappearing, and further, even the recent scans you did 5 minutes ago will go missing before you even have a moment to upload them. Finally your game will crash and then you won’t be able to even get to the main menu of NMS without a blue-screen.

What caused my save to get like that? I did a lot of discoveries on the other side of portals, between 1.3 and 1.37. At some point my save stopped being able to save, just like it had done after 1.03. Then 1.38 fixed it but there was a delay every time I would save. This delay kept getting worse over time, and eventually my save would simply not work anymore. It could be the exocraft track I made, or the monument I built with another player inside my base perimeter.

Even going to Eissentam and making a whole new base still did not fix my issue. I still had long freezes every time I would save, and my discoveries would go missing very soon after being scanned.

THE 1.5 “NEXT” UPDATE DOES NOT SEEM TO HAVE FIXED THE PROBLEM REALLY

When 1.5 came out, I loaded up my save from January that would crash at launch. It seemed to be working at first.

However pretty soon I started noticing tons of problems.

I am not sure what caused my save to get screwy, but I don’t understand why they cannot simply program the game, upon updating from an old save, to simply copy all the items, credits, ships, quest progress, and feats into a fresh save. I don’t care about old discoveries since the universe was reset anyway.

But I have not been able to play my original save (1839 hours) since January, when it started crashing at launch. I never got a single response to any of my numerous support requests where I sent them copies of my save file and detailed descriptions of the issue. Could not bring myself to start over an 1800+ hour save, so I just waited for a fix and quit playing and quit streaming NMS.

No fix came for months and months.

Finally when I heard about NEXT, I hoped that would be the fix I had been waiting for.

I anxiously loaded my old save. At first it seemed to work, but pretty soon I started getting crashes at random times, especially when going back to the main menu. My ships would overlap on each other in my freighter, or would simply be missing from the freighter entirely. A ton of old discoveries are in my Discoveries tab, but none of them have the custom names anymore. And any new flora/fauna scans that I make disappear within minutes.

Also strange is that the game shows that there is no connection to the Discoveries server, even though if I load up a fresh save in a different slot, it connects just fine.

So, NMS NEXT:

  • did not fix the problem where discoveries get deleted

  • did not fix the issue where the PS4 save file has a maximum size of 39.03 MB and can therefore get full, causing data loss and crashes

  • did not fix the issue where the game crashes a lot and has bad FPS with these long-time saves

They had our bad saves for months and months, and still did not address the most glaring problems. What the heck HG?! This is how you treat your long-time devoted fans?

And to top it all off, when you update your save game, they delete all your old technology items and tech recipes. Therefore you will not be equipped to complete any of the high-level missions that you are being offered due to having maxed out your mission status. You will be like a complete noob where your hazard system lasts 30 seconds in Normal Mode during intense storms. Sentinels and pirates will now pose the same threat to you as they would to a complete noob.

That’s the reward you got for playing hundreds of hours: HG took a big crap on your save file, reset your progress, and you’re lucky if it even works at all because they did not even bother to fix all the save game problems, data loss issues, crashing, and performance problems that many of us have been sending them detailed bug reports about SINCE LAUNCH.

This really sucks because I love many of the new features in NEXT. They added many of the new features that I requested in the last year.

However, I am not going to start over with the recipe and tech upgrade grind. I am not going to keep playing if they still have not fixed the issue where my discoveries get removed after a certain point from the Discoveries tab. I am not going to keep playing if the game still has the same or even worse problems with performance, crashes, and audio glitches on my PS4 Pro as it had all along.

They really need to address this. Publicly. IN THIS THREAD.

I want to know WHY WAS IT NECESSARY TO DELETE ALL MY TECH UPGRADES AND RENAME EVERY ITEM IN THE GAME? While at the same time ignoring the issue where discoveries get deleted?

Please.


#2

I’ve had crash and lag issues and checked the PS4 error code and found that it is a memory corruption issue in my console.I’ve tried restarts and a reinstall of NMS but it didn’t really seem to fix anything.

After NEXT dropped I experienced massive issues.
I had a pre-update save off-console in multiple locations as advised to do when there is an update
I then proceeded to do a complete play station INITIALSATION. This process took several hours and completely mind-wipes the PS4 back to empty just out of the box settings and memory.
Everything is gone. After it restarts, it should be updated and current.
Following this, I reinstalled my user profiles and went through the process of getting them back on the network.
I then reinstalled NMS and allowed the update to load …all 9 gig again.
I then uploaded my off-console save.
I fired up with crystal clarity, zero lag and a complete confusion of wrong ships, altered tech and discoveries like everyone else. But my game works beautifully now and I can go through the process of playing again (typical new update bugs aside).

Perhaps your console needs an overhaul like mine did.


#3

Already tried that when I was having so many problems with 1.38 back in January. Did a complete init of my PS4—total wipe. Reinstalled NMS fresh from the blu-ray and re-downloaded the 1.38 update. This did nothing to fix my issues.

Also, I would expect other games to have problems on my PS4 if it was really the PS4 itself that was the problem.

I have been hearing of many PS4 users with these same issues. Do we ALL have to spend a whole day to wipe our system and re-install every game etc.?

If it was the console then why doesn’t the whole OS crash?

I think the only reason your game ran somewhat better now may be that you cleared the NMS cache files when you wiped everything. Because I think that is where the problem lies. I think they have cache files on disk and NMS does a poor job of cleaning up after itself, so if you ever reload a save or switch between save slots, then the on-disk cache will not get fully wiped properly, and cause many issues.

I also suspect they have problems with their net code—how the game talks to the discovery server.

Even if a wipe could clear up some performance issues by optimizing the HDD, still, I am quite certain the discovery deletion issue is caused by NMS itself, since their support team has acknowledged it to me.

Also, I started a fresh save in 1.38 on my GF’s account, and it never had any of the problems that my old save has. It runs at a higher FPS and does not get bogged down and crashy like my old one does.

So yeah, I’m pretty darn certain that NMS is to blame, not my console.