Scalding Storms on G Class planets

Well, I’ll post in here anyhow.

On trips to FIVE G Class stars, only 3 out of 27 planets were gardenish worlds, and ALL three had scalding storms. Fortunately, the last one has them much less frequently so it’s bearable. It’s also a trinary system, so I might just make it my new home.

In all five space stations, I encountered loud rumblings that persisted for a few minutes as if there was a cosmic storm of some kind. My character even began huffing as if he was enduring some stress, but there was no notice from the game.

Running legal Win10, 16GB ram, Intel M2 SSD, MSI GeForce 1080ti with 8GB ram. Mods disabled.


@stryker99: I moved your reply into it’s own separate topic.

I have yet to play the new update and I am not sure how things have changed in regards to weather on planets or effects within systems. One would assume that a planet’s description should at least match what is experienced. Not too sure about the star systems themselves.

Hope you’ll get lucky enough to find some place more ‘temperate’.


The weather is wild. Storms are fierce. Lightning, tornadoes, etc…it feels as if you are actually on a hostile alien world. However, there are plenty of the old world types. My old paradise planets are still nice and calm though they now look very different. Perhaps you just need to use a few blackholes and get to another section of space. As for the class of planets…I don’t really pay attention to that so I do not know exactly how that has been affected.
The loud rumbles could be a MP side-effect. That has been a problem before. Disable MP to see if it makes a difference. I jumped into some water in a cave last night and it was so loud it scared my cat right outta his skin. :smile:


I had some planetary cloud effects follow me inside my freighter hangar, similar to the glitch when Next came out although a bit more subtle. Could be the same type of thing with audio.


I hadn’t thought of that in the case of multiplayer. Coincidentally, I went through the options last night before I hit the sack and did things like set my game up for no auto flashlight, no multiplayer, so we’ll see if that makes a difference today.

What had occurred to me is the possibility that this was a factor of the Vy’keen gravitating to rugged, dangerous worlds, which could be, though I’ve also been creeping through the sector I’m in, and I’d expect a little more variety than what I’ve been encountering. Rad world, hot world, ice world, toxic world - one of them orange, a green world with superheated storms… it’s just a bit annoying.

But the garden world I’m on now has storms less frequently, and having a three sun sunset is pretty sweet, so I might have found a new home. Even if I need a spacesuit instead of a raincoat. :sweat_smile:


I’ve been playing on 3xperimental since the very early days after launch, with mods enabled, with my whole two working mods disabled, and last night I experienced another “storm” in a space station, though this time I didn’t respond to it.

Spoiler ahead for the new people, so I’ll conceal it.


I also went to an ATLAS anomaly and went through the ten or twelve ATLAS stone activation, needed a Heart of the Sun so I went back for it. I answered No the first time fearing a reset, but nothing happened so I went back, still had my Heart, so I dropped it in and replied Yes, and got the little show. I then tried to make a Star Seed, having all the required stuff, and it wasn’t even in my crafting list. I went out to collect the 16 “units” of required substances, and nothing changed. I reloaded the previous save to see if I mucked it up, but I caught the notice about Portal glitching, so I’ll try see if this might be a similar issue.


Well, something is really wrong now. I’ve tried my quest above a few times, reloaded my data twice, and now when I get the recipe for the Star Seed, it won’t even show up on my Log. Mods were disabled. Curiouser and curiouser…