Oxygen/Atmospheric Harvesters empty (1.60 update)


#1

Today I first visited both my Atmospheric and Oxygen Harvesters for the first time since the latest update. All of them were completely empty. I have 12 Oxygen Harvesters and 18 Atmospheric Harvesters (6*3 gasses). All completely empty, even though I always refuel after having emptied them out.

Had been seeing bug reports on Steam about this as well, even during ‘experimental’, but it seems this issue was never fixed before going live/public. I have yet to check the additional issues this may have. Word is that they will turn empty again if you leave them to come back later. So far they appear fine after refueling, showing to be collecting gas/oxygen.

Never have they been an issue so far, so HG likely broke something. Will keep you all updated on this, as I will check them again in a bit to see what is going on.


#2

As far as I can see, gas harvesters that I refuelled before the update are likely to be empty now, But those I refuelled after the update are OK.

All the gas harvesters I have refuelled after the update (including those that were empty due to the update) seem to be working properly now.

I don’t know whether this was a bug, or a reset. Whatever, for me, it’s working now.


#3

Update:

Went to one of my gas harvesting locations to see what happened.

Had one atmospheric harvester inventory open until it reached a full stack of Nitrogen in this case. All fine, nothing strange happened, could collect full stack and refuel.

The one next to it, same thing, but waited until it stopped animation before opening inventory. Opened inventory, to have it closed on me right-away, as usual (known bug). Animation however started again to stop a moment later? Odd, but opened inventory to collect full stack and refuelled, all fine.

The third one was fine, no animation weirdness, however, only 249 Nitrogen collected, even though it was finished. Refuelled, can miss a single gas, although should not happen.

Other planets I teleported to, to check the Radon and Sulphurine, appear to be working correctly. Full stacks, no issue refuelling to get them starting again.

Went to my home base to check Oxygen, which also appeared to work fine. Full stacks, no issue refuelling.

Decided to create a manual save and close the game to give a restart a try, just in case. It looks like all is fine and working as it should again. I can only assume something in the update caused a single reset. Just that one single gas giving me OCD issues, as I need multiples of 100 to work with (refining), oh well :stuck_out_tongue_winking_eye:

@Polyphemus: Sorry, was typing this up as I was doing my research. It does indeed look like just a single reset due to the update, as you experienced as well. No biggie … I am glad they all continue to work well again :slight_smile:


#4

That bug drove me nuts until I “retrained” myself enough. For anyone else constantly dealing with this, when you refill, don’t hit the button/key to manually close, wait for it to close on its own.


#5

Yeah, the auto-close ‘feature’ when no actions are available anymore. I still have the issue, even when waiting for that to happen and then try on another harvester. I even have it on a very first attempt at times. Nothing appears to actually help. I think it is this exact auto-close’ feature that just ‘sticks’ in memory at times, auto-closing on you on any attempt, to then finally be cleared to work on a retry.


#6

Update to yesterday’s chat.

Yesterday I carefully refuelled all my gas harvesters. I have lots - 12 bases have nothing else but a small building, a teleport, and three gas harvesters. Then I shut the game down for the night.

Today I started the game up again, and visited my gas harvesters. They were all empty. All of them - no gas, no fuel.

I have now refuelled all of them. We’ll have to wait and see what happens.


#7

I’m still wandering so haven’t set any harvesters up, but as I plan to at some point, I appreciate the heads up from you all


#8

I have not checked my harvesters on PS4 since the reset. If I can find them I’ll report back their behaviour.
Pre NEXT they would go empty if I left the area.
As a side note: my game had the portal interface bug which seems to go hand in hand with the harvester bug. Something about the interface menus… I still have the portal bug but it lessened so that I CAN reuse the portal but have to recharge it if I leave it


#9

Further research update.

All the gas harvesters I have refuelled today are performing, to some extent. I am able to harvest gas from all of them, although some are giving strange quantities.

A full charge of 50 condensed carbon should produce a yield of 250 gas. All my gas harvesters have been charged with 50 condensed carbon. Strangely, some of them are giving amounts like 180 nitrogen, or 170 sulphurine. They’re working, but not all of them are giving 100%.

As for finding them all empty - it looks like the state of gas harvesters may not survive a save. So, when you load a save, they’ve reverted to their default state.

I found this yesterday, too. The harvesters I had refuelled during that play session behaved themselves. The ones I refuelled in a previous play session were all empty.

I think it’s a problem with the way gas harvester information gets saved.


#10

Further research update.

I’m now finding that some of the gas harvesters I refuelled today are empty. It’s not a problem with saves.

You know, I think HG may have put a time limit on the things.

(My numbers here are arbitrary - I haven’t measured them. I’m just testing a concept).

So, for instance, you refuel a gas harvester. It then takes an hour for it to accumulate a full charge of gas.

The full charge of gas remains available to harvest for, say, another three hours. After that, it starts to leak away - so you get less.

After four hours, there’s nothing left. The gas harvester is empty, and not charged.

I’m by no means certain about this. It’s an idea I’m kicking around. Something to fit my observations.


#11

Further research update.

So far, tests seem to bear out my theory. Gas harvesters that have been charged recently give a harvest. Those that were charged a while ago are empty.

I think there’s a time limit.

I would appreciate other people’s input to this enquiry.


#12

Update

After my research from yesterday, I continued work on my freighter and had not checked again until I fired up the game again today, several hours ago.

I now notice similar issues as @Polyphemus describes. Some of my harvesters were full, others empty, while one fails to show the resource at all. No weird number counts though, but likely due to the amount of time that has passed since yesterday when last checking.

Doing further research into the save file itself currently and starting to notice something. I have not yet fully concluded what is going on, but will update you all once I have more data.

It is however clear that there is an issue, on PC at least. Would love to know from others in regards to this issue. Is console experiencing the same?


#13

Some initial research results now appears to explain why some harvesters are empty and others are full. Considering I only do full 1+ hour tests now, I have no clue yet as to why smaller stacks can appear (less than 250).

All gas harvesters use MAINT_FUEL1 and are ‘now’ supposed to also include GAS1 (Sulphurine). GAS2 (Radon), and GAS3 (Nitrogen) in each entry. This appears to have been added since the 1.60 update, as my older saves do not appear to include the gasses in their entries. I have checked about 10 saves prior to this update. This explains why I initially found all of my gas harvesters empty right after I had updated to 1.60. It also explains why my very first test appeared to make it all work again. I will explain this further down.

Since the very first tests, I stopped checking/doing all harvesters and had only emptied/refueled a couple. This resulted today in some being empty, while others had full stacks. With the research I am doing now, I do check all of my harvesters and note the save file data. An interesting pattern emerges.

I am doing the following now:

  • Auto save file at Space Station
  • Teleport to all gas harvesting locations (multiple systems)
  • Empty out whatever is in them and refuel
  • Last teleport back to Space Station
  • Save again (auto save)
  • Check save file and note down the MaintenanceInteraction data
  • Wait an hour
  • Load game and check all harvesters without creating a new save!

Checking the save file data after one round, shows how some have their GAS1, GAS2, or GAS3 entry included, while the others do not. I can now verify that those gas harvesters that have their gas included in the entry, will show a full stack upon return after an hour. Those gas harvesters which do not have their gas entry included, will be empty upon return after an hour.

Repeating the same round once more, shows how the inclusion of gas entries in the save file has switched! The gas harvesters that previously turned up empty, show full stacks, while the ones that gave full stacks the previous round, now turn up empty. How can this happen???

Well … just think about what actually shows when checking a gas harvester, emptying it out, to then refuel. A gas harvester which is empty, shows what gas it gives on that planet. A gas harvester which has a full stack, will show empty instead when you remove the full stack. THAT is what is being saved! The ones you just emptied did not show the gas it produces and will not include it in the save file. One that was empty, showed the gas it produces when being refueled and will include that in the save file. However, the next time this will switch around, because you take out a stack and that slot will show empty again, instead of the gas it is supposed to produce.

Basically the harvester saves the state of what is shown! This then messes up things, as the required data for saving properly, is not always shown. I tried taking out the stack without refueling, to then open the gas harvester once more in hopes of seeing what it produces. The slot however remains empty, even after portalling back and forth. So the only solution is to empty out the harvester, do not refuel, pick it up, place again, to then refuel. When doing that, it does show what it produces and appears to save correctly. Has to be done over and over, each time you empty one.

When it comes to odd stack sizes, I think something similar is happening on top of this issue. I would have to do further research to figure that one out, which I won’t …

All-in-all, they changed a mechanic with this update. Experimental already showed the issue being present. It got released to the public regardless, to remain broken for a while longer until they fix this … sigh :face_with_raised_eyebrow:


#14

Hrmm, that’s very interesting. While working on fixing the Atlas Rises lockup bug, I noticed harvesters did actually save some GAS* entries back then… but only temporarily. I didn’t test it thoroughly (and my memory is a little fuzzy) but I think if you recharged some harvesters then saved, those would record the GAS* value. However, if you reloaded, or warped out of the system (I had all my harvesters on the other side of portals), it would just “forget” that data and not include it in subsequent saves. I thought it odd, but figured it ultimately must not have been necessary. Presumably the game instead just recalculated what to show based on the other data (fuel amount, recharge timestamp, planet biome).

I wonder if they tried to fix this previous behavior, and ended up making it worse? As you said, they clearly changed something related in 1.60 and now it’s borked. :frowning:

Before 1.60 dropped, I was fairly close to finishing my $1-billion Stasis Device + Fusion Ignitor stacks. When I saw the bug reports from experimental last week, I started grinding my harvesters hard to get that done fast, just in case. Glad I did.


#15

I’ve had some automated mining units with the same behavior. I return to find the fuel and product both gone. The game does not discriminate between mining units producing the correct product and those that aberrantly give copper, activated copper, or some other random product. (I believe the product change is an older bug.) I always recharge at the same time I empty a unit, and I verify that it has produced at least 1 of the correct product before I leave. It’s not game breaking, but it does slow me down. On the bright side, several forum posts are direct results of having to wait for the mines to refill their hoppers.

Incidentally, network play is off. (I’m not being raided by human pirates.)


#16

Using atmosphere harvesters gets through huge quantities of condensed carbon. It’s an awful grind to make enough of the stuff, so I buy it.

At least, I did.

I now find it’s no longer available. It’s disappeared from my regular supplier, and I’ve tried 20 different systems looking for the stuff, with no joy.

Nerfed, bug, or just my bad luck?


#17

I never bought it so I can’t confirm if it’s another stealth nerf, though I wouldn’t be surprised. :confused: I’ve just been frequently expanding it with oxygen in the refiners. I have some oxygen harvesters set up nearby for a steady supply. I don’t mind the grind on these, though I always had several going at once.

I also recently started using the 3-slot recipes to refine 100 gas + 10 condensed carbon + 10 salt -> 1 gas product. Much lower material cost than directly crafting. Unfortunately those process much slower so the waiting around can be killer.


#18

Good tip about refining for gas products. I hadn’t realised the return was so much better. Thanks for that. :grinning:


#19

@Argh: I actually expected there to be Gas entries in my saves prior to this last update. I was amazed to not be able to find any. I do indeed recall it having been used prior to Next. I do indeed believe that recalculation used to be done correctly prior to this update, considering I had no issues with Harvesters until now.

On a side note, Oxygen collectors use MAINT_FUEL4 and have their product entries as OXYGEN. So even though these harvesters all use Carbon as charge (converted when using Condensed Carbon), they have different fuel entries in the save. Not sure what Autonomous Mining Units use for their entries, as I find them useless at a later stage in-game.

For completeness I will mention there is a 3rd entry for each, containing several timestamps (Unix):

  • LastUpdateTimestamp - time when last change was made
  • LastCompletedTimestamp - time when last refuelled
  • LastBrokenTimestamp - time when last finished/completed

I was doing checks for full cycles, resulting in Update and Completed always having the same timestamp. Broken was always exactly 3600 seconds after Update/Completed. These values only change when actually making a change, so just having a look doesn’t alter any of these values.

I am not sure if this bug is the result of an attempt to fix things, as they used to work just fine. I can only imagine they tried to fix similar behaviour on something that was indeed broken. Maybe the AMUs, as they appeared to show issues from what I heard, forgetting what they were actually collecting. I have no data on them though, so can’t really tell.


@Dex: Those have been some of the issues I had been reading about as well. Mining units turning up empty, not producing the correct product, or even changing product all of a sudden. This has been an issue since Atlas Rises indeed and has yet to be fixed. So it is easy to assume HG were making attempts to solve this, although for all I know, behaviour is still the same.

From what I found out however, if AMUs behave the same, it will not make a difference to wait until it shows a first product. From what I have seen with the Harvesters, it will only store the state when making an actual change. This state is already stored from when you refuelled, so seeing the first result popup, will not make a difference.


@Polyphemus: They did indeed nerf the availability of gasses to buy, some updates back. I actually thought this was a good change, as there was no need for having atmospheric harvesters at all. Ever since, I changed my ways, as I was figuring out how to best approach full Fusion Ignitor/Stasis Device cycles.


I have changed ways several times due to updates and changes made to grow times and availability of resources. Now I basically do everything on my freighter, besides the 3 gasses, crops and Oxygen.

On my freighter I still have crops for exactly 2 Living Glass, 2 Liquid Explosives, and 4 Circuit Boards, to produce 2 Fusion Ignitors and 2 Stasis Devices, just in case. In addition I have Coprite and Mordite for my planet side crops (see below). I have two rooms for refining, although only one is used at a time. Just wanted to keep symmetry in my freighter base. Each of these rooms have 4 Large Refiners and 4 Medium Refiners. I have 5 Fleet Command Rooms, for all my 23 frigates, being able to do all available fleet missions.

I picked 6 planets to cover all possible crops. Made a base at each near a crop spot inside a cave. Because the type of crop and gas is related, I have 2 planets for each gas. Each base has 3 gas harvesters, exact crops for 4 SDs and 4 FIs, and a portal. One of these planets is my home, where I have 12 Oxygen harvesters total.

I can now do my rounds, harvesting crops for 6 SDs and 6 FIs (once a day even though some have regrown sooner), harvesting 1500 of each gas. This totals 187.2mil units in itself. However, I still get the rewards from the fleet missions…

Now those fleet missions are great if you really want to make units and don’t mind some smart refining. The rewards often include Geodesite and Iridesite and if you try to keep up turning all those into SDs and FIs, you’ll be rich in no time. The other resources you get rewarded from fleet missions, are basically hinting at refining to do so. Often some Hot Ice, or Organic Catalyst, ready to be made into something more worthy. Often some of the compacted forms of Oxygen, Carbon, and Sodium. Regularly the heavy metals, usually the Activated version. Not to mention the Magnetised Ferrite, Chloride Lattice, TetraCobalt, and whatever else. With some smart refining, all you actually need is a regular supply of mostly Oxygen and occasional Gasses. Everything you receive as a reward, can be turned into what you need for the ‘top of the bill’ products.

But … that needs crops! Well … I don’t really need crops, because I can refine resources and turn them into crops (duplication). Fusion Ignitors are easiest in my experience, as they do not require an additional step in refining to make Uranium (Gamma Root). Silver is mostly used, to create Paraffinium (Star Bulb), with Pure Ferrite to Ammonia (Fungal Mould). Gold turns to Pyrite (Cactus). Condensed Carbon + Sodium Nitrate makes Dioxite (Frost Crystal), with Pure Ferrite to Phosphorus (Solanium), with Pure Ferrite to Uranium (Gamma Root). All that matters is keeping a reserve of everything, so it can be turned into more (duplication). Any resource required can be turned into more as needed. Even Silver and Gold can be created cheap. Aronium, Herox, Dirty Bronze can be made through refining to turn into Silver. Grantine, Magno-Gold, Lemmium can be made to turn into Gold.

So yeah, I found that basically the fleet missions can make you rich in no-time! Pretty boring though and in my opinion not rewarding at all in any way. I have been doing this for a while just to figure out max results. My ears are numb after a week or two and my balance is at around 4 billion units. I strongly suggest to play the game differently, I can confirm!


#20

I returned to the system where my harvesters once were but everything is gone. Beacons and harvesters have been swallowed by the NEXT update and are forever lost.
Nothing to see here :grin: