My S-Class vector freighter on Xbox keeps changing back to a C-Class vector anybody else having this problem?

I’ve tried uninstalling reinstalling I’ve tried old saves manual saves and I still get the same problem it shows I have an S-Class freighter but none of my colors are there none of my rooms I’ve built the base that I made on the freighter is gone and it’s showing it as a C-Class and not even an S-Class has anybody else on the Xbox having this problem?by the way I’m running on an Xbox one x pro so I shouldn’t be having stupid problems like this unless hello games is just made another mistake with their new stupid updates! Every time these dingbats release the next update they break something else it’s becoming obnoxious frustrating and it makes me not even want to play the game and I’ve been playing this game now for 4 years! I’m about the point of being sick of it they never answer any emails you send them about what’s going on they never talk to anybody because I guess Sean Murray is some introvert or some weird crap like that but look this guy needs to get his crap together and fix this game! Just want to know if I’m the only one having any problems as of today November the 12th 2020 thank you and I hope everybody has a good day and God bless all of you

2 Likes

Welcome to the forum and so sorry you are having this issue.
I assume you upgraded the Freighter and it was not S class originally. If so, then something is resetting the ship class back to its default class.
I would definitely report this to HG thru their zendesk. They are very good about addressing issues like this.


Please keep in mind that HG is a very small team. They do not have the personel to reply to each person. They are very good about fixing things though and it usually comes in a large batch.
In the meantime, does it really affect your gameplay that much? Annoying, yes. But you can surely still enjoy the game until a patch is released.