Mission objective won't complete

I’m doing the mission INDUSTRIAL SURVEYING.

It says to find a power hotspots.

I found and marked the hoospot, but the mission objective isn’t checked as COMPLETE.

Is this another of the 10,000,000 bugs in Beyond or am I missing something?

Thanks

2 Likes

I have not played the mission, so I am not sure what the requirements actually are. Maybe you have to build something at the found location or possibly return to whoever gave the mission.

On a side note: Are you sure the hotspot you found is a power hotspot (electricity/lightning bolt symbol) and not gas or mineral?

Also keep in mind that leaving the planet or a reload will remove the hotspots you found again. I do however believe the locations of hotspots to remain the same. You’d just have to scan for them again.

3 Likes

I’m sure you know this, but just checking to see if you had the quest highlighted in the Log, as well as what @DevilinPixy said.

(it’s kind of become like that old joke about “computer won’t start; check to see if its plugged in” ) :wink:

Also, I hear your frustration and I sympathize.

3 Likes

Sometimes the last step in a mission is to simply return to the individual who gave you the task.

3 Likes

I’ll have to double check but I think I’ve got the same mission. I haven’t progressed in it yet because first it wants me to go and build the tech I need to survey it and to extract the resources so you may have to actually build a structure on it to complete the mission.

Not certain though, I’m jumping on now so I’ll focus on that mission and report back if I progress past the point you’re at.

Edit: never mind it’s the mission to build an electromagnetic generator. It seems like it might be the same mission path though so if I do hit it I’ll chime in.

5 Likes

Finally came across this mission yesterday. Sorry if its a bit late and you figured it out but for anyone having an issue with this particular mission…

You need to stand in the hot-spot location until analysis completes, it takes a bit and isn’t noticeable this is happening immediately so one might be inclined to leave the area as soon as the icon pops up upon discovering its location.

It doesn’t need to be a power survey either. Mine was a gas one.

4 Likes

That is good to know. I haven’t got the visor installed yet, but soon™. Thank you. :heart:

2 Likes

Huh, I thought that was kind of obvious…

3 Likes

Thought worth mentioning in case it was the reason for the mission not completing. I found it kind of confusing. I’ve no idea why I can call down a giant pipe from the sky as a marker either or what it’s purpose is either, have yet to do anything with the new surveyor/mining units. But I almost didn’t notice the analysing message in VR cos I had my mining tool pointing to the ground :slight_smile:

3 Likes

You randomly get one of the three assigned for the mission, power, mineral, or gas, which is the one you need to find and analyse.

3 Likes