Locked Out Of Freighter


#1

In the early versions of No Man’s Sky, if there was combat in your system, the entrance to your freighter would turn red, and you couldn’t get in. Not only that, but players who were inside couldn’t get out. And it could go on and on for hours.

I think with 1.3 (?) this stopped being a problem. At least, I haven’t noticed it for a long time.

Now it seems to be back - with a vengeance. I leave my freighter to mine asteroids, and I get attacked by pirates. Generally not a problem - goodbye pirates, hello loot. But then I try to go back to my freighter - and it’s locked up. I can’t get in. And it stays that way, and stays that way, and…

So far, the only answer I’ve found is to warp to another system, and call my freighter. That solves it - but it’s damned inconvenient, particularly if I wanted to stay in the system I was in originally.

Any answers / ideas?


#2

Have you tried landing on a planet, and then summoning the freighter and seeing if that works? Maybe also try using the pulse engine to travel further away and summoning the freighter.


#3

Thank you for the suggestion. It’s always nice to know somebody cares.

But yes, I have. And no, it didn’t work.

I have also tried:

Landing on a planet, and coming back.
Warping my ship to another system, and coming back.
Teleporting to another system, and coming back.

It will eventually clear itself - but, as I said, it can take hours,

So far, the only thing I’ve found that works is to go to another system, and then call my freighter there.


#4

Doesn’t it go away if you just summon it to a different place inside the same system?


#5

Nope. That’s what @projectcartwheel suggested - I’ve tried. Doesn’t work.


#6

Save your game. Reload?


#7

Well, you know…

I can already clear it by moving to another system, and summoning my freighter there.

Then, if I want, I can move back. It’s a pain, but it can be done.

It just seems that:

  1. This was a problem early on, but it was solved,. Now it seems it’s come back. And;

  2. I’d rather not have all the messing about - I’d rather that the game worked properly.

So I wondered if other people knew whether I was doing something wrong, or that maybe there was an easy way to solve the problem.

But it seems not. Thank you all for trying.