Large Hydrophonic Trays bugged on Freighter

I have seen multiple report on this myself already, but lets put it out here.

PC (Steam) version 2.06c with existing NEXT save

Large Hydrophonic Trays on a freighter will show as not being charged (red). They appear to not regrow resources either. The smaller version does however appear to be working fine.

Another thing I noticed is the fact we can not take out the resource we planted, like we used to. Only option is to delete the tray, to place a new, requiring new resources which would have otherwise been returned. Replacing a malfunctioning tray does however still appear broken, showing red.

2 Likes

So, do you think we now have more bug reports than in NEXT? And it seems we are really just getting started.

1 Like

Not sure we actually have ‘more’ bugs to report, but there are plenty. Not to mention that some bugs already existed and are being reported once more. I can imagine that this will make it look even worse.

2 Likes

This is not really a Freighter issue but it is a Tray issue. It only happens with the Mordite.
It appears to be full grown but is not. I kept wondering why I could not harvest it.

3 Likes

PC exp New Save
Trays do not work on Freighter.
And not just the trays. I have found that lights work on pre-built parts of the Freighter
20190827120915_1
but not in rooms that I added
20190827120853_1

1 Like

Did you plug it in? :laughing:

Some lights work, some don’t. Depends on placement although green lights seem more broken. I posted a pic in another thread about storage room issues (long red corridor) and my new room lights were working.
Small hydroponic trays are working in our games in both new and existing areas.

2 Likes

I have no wiring on my Freighter. Am I supposed to? I am so confused. :woozy_face:

2 Likes

No, just a tech joke :clown_face: .

Edit: I have noticed the cable is available in the build menu but cannot find a way to use it

3 Likes

I don’t think this is specific to rooms that are ‘not’ default. There are just some parts of rooms that receive power and other parts that just don’t have the power for a light to work. Usually the floors and ceilings work fine, but the ends of corridors don’t. The X-corridor has none of the walls or ends working.

Interesting, I had not noticed there being differences depending on colour. Will give that a try when I can’t get it to work.

3 Likes

Ok so the lights work here (which adjoins the original part of the Freighter)


but not here in the + shaped corridore/room which I added

and the tray will work here,again in an original part of the freighter beside the hangar stairs

but it will not work here, in the cargo area that I modified

4 Likes

I just did a quick test on the 3rd floor of my freighter, just to make sure I could place everything without issues caused by whatever is placed a floor down. I noticed that I could not place small hydro trays on the floor directly above my already existing farm room. Something from below was interfering. I also noticed that some room parts could not be placed because of lights I had placed a floor below.

Anyways, I can confirm the coloured lights not being lit when placed on the edges of hallways, just like you show:

Interesting how the light that did not work, now remained when a room was attached. This light all of a sudden found power, although floating in the now doorway.

Placing small hydro trays appears to work for me. I tried all 3 varieties of rooms attached to the X-hallway.

Maybe something to do with the default floor when it comes to small hydro trays?
I can’t really test default floor on freighter, as my default floor is fully altered and filled in (Next save). I will see if I can find spots where the trays do not power.

Edit:
I just checked my farming room (default floor) to notice all small trays having power. Most of the large trays are receiving power as well, although some remain unpowered. There appears to be some pattern to it, but have not quite figured it out.

I tried placing small trays as 2x2 (equal to large tray), but noticed only 2 can be placed in said square. It does not appear to matter how you place them, but always only 2 allowed within the 2x2 area. Really odd.

I am unable so far to find a spot where a small tray will not power along a wall on its own, like you have @sheralmyst

Another fun fact, aiming at power input on trays in build mode, gives the wire menu. No attachment can be made however and a notification says ‘out of range from base’.

3 Likes

Good grief! :laughing:

I took the wire to the Captain. He didn’t know what to do with it either.

4 Likes

I tried every spot in the cargo area and found no place that powered my trays.
(and I do mean every spot) :grin:


I did find the wiring in the delete/change color menu (DUH)

2 Likes

Ok, I found the pattern for my unpowered large trays. All of them without power, are placed right where 4 rooms meet. So the large tray is basically with each corner in another room.

A small tray gets powered in the corner though.

5 Likes

Okay. That makes sense. Good job! :+1:
I mean, it still needs to be fixed, but at least we understand.

1 Like

I agree it needs fixing, but I am still clueless on your small tray issue. I have yet to find a way to reproduce it.

2 Likes

Well, no trays work for me at all in the cargo area.


But they work everywhere in the forward hallways

The only thing I think of is because my entire cargo area has been edited and the forward hallways have not…it should not make a difference but it seems to have something to do with the original wall placement.
I will investigate further.
No, I won’t, :grin: I moved everything, even the hallways into the cargo area. It was a lot of work.

3 Likes

I just bought myself a freighter in my creative mode save. I am still unable to reproduce your issue. Then again, I am not sure I can trust creative mode for this, as for some reason anything to do with electrics appears to work better in creative. For me the mystery remains …

2 Likes

After previous updates I’ve found Creative mode run better and without the issues of the other modes making it fun but not very useful for testing…

2 Likes

Well of course not, you’re doing it wrong. Everyone knows a Vy’keens power socket is located in the groin.

3 Likes