Is Anyone Else Having A Mouse Problem?


#1

I’m not sure whether this is a bug or not.

I play on PC. My mouse behaviour in NMS has always been a bit erratic. Sometimes I have to press the mouse button several times before the game responds. Sometimes I press the mouse button once, but the game sees a double click (so it will, for instance, move me two sections ahead in menus, instead of one). It was a little irritating, but nothing I couldn’t live with.

However, with the ability to travel by Portal, it’s become a real problem.

Entering a Portal address requires using the mouse to enter a sequence of 16 glyphs. There is no provision for backspace - if you make a mistake, you have to start again.

Because of the peculiar behaviour of my mouse, somewhere along the 16 glyph string, usually several times, my mouse click will produce a double glyph, instead of one. I can’t correct it. I have to go back, and start again.

And it happens again, and again, and again… It’s virtually impossible for me to enter a correct Portal addreess.

Things I’ve Tried:

It’s definitely not my mouse. I’ve tried 5 (five) different mice, three of them brand new, straight out of the box. They all work fine on other computers. They all work fine on this computer, except when playing NMS. They all display the same problems when playing NMS.

I’ve tried updating my Windows mouse drivers. I also tried rolling back to earlier versions. It didn’t make any difference.

I’ve tried altering the double-click speed within the Windows mouse driver. Interestingly, it made no difference at all within NMS. It looks like NMS isn’t actually using the Windows mouse driver, but one of its own.

I’ve tried updating my motherboard drivers (on the basis that it could be due to USB settings) - no improvement.


#2

Oddly enough, I’ve seen double selections happening, but I’ve always put it down to the mouse as well. And now that you mention it, I don’t think I’ve seen double-selection happening in any other program.


#3

I’d report it as a bug


#4

Yesterday I had trouble with getting my PS4 controler buttons to activate… wonder if this was a similar bug to PC users…today all seems to be working fine…
I was trying to take photos so pressed the Share button and then the green triangle often nothing worked…also I tried to delete a tec item after it had been olaced and again had no joy…


#5

I use xbox one controller on pc and have had odd issues as well. Pressing and holding the A button caused the red ring to come up and ask if I wanted to delete my game! I was scared to hit B for cancel but finally did and it worked. I have also had issues with my multi tool firing when I am using my jet pack and with removing things from storage.