Inventory management a mess ... (1.63-1.65)


#1

Note: I am playing on PC (Steam) and just decided to give the new update (1.63) a try.

First of all, no direct way to select base/freighter storage containers/rooms with the additional Pilgrim inventory being added. You can only access it through scrolling through the inventories (Q/E). They never realised they had to alter the UI menu popup to allow for an additional option (7 inventories max). This issue exists for both menus, sending items to storage, or receiving items from storage. Sending items to storage containers/rooms is impossible, even though you can technically reach the correct inventory by changing Quick Target (Q/E), but due to not being visible, the X key does not register. Both these menus are visually limited to show 7 inventories max. This issue was already known before the update went live, but never bothered to fix …

Storage Containers/Rooms unavailable in remote transfer with the Pilgrim added.

Another issue I noticed is that all ‘remote transfer’ inventories show the contents of my Colossus, besides the Colossus itself where the items are actually located. There is no way to retrieve those items remotely. I can not even get those items through ‘All Items’, even when the Colossus is right next to me. Range from the Colossus appears to work correctly when it comes to items being greyed out, but the result is the same. All inventories show these items, besides the Colossus itself. All other exocraft are actually empty besides some technology.

Images showing Colossus inventory in all remote inventories, besides Colossus itself

Exocraft inventories are being shown in all inventories for some reason, besides the exocraft the items are actually in. When having item stacks in several exocraft inventories, the inventories get all weirdly mixed up. Roamer shows all items from all other exocraft, but not the items it has itself. Nomad then shows what is in the Roamer or Colossus or whatever, it is all weirdly mixed and makes no sense at all anymore. When remotely transferring items, it often does not work. When it does work, it always appears to show the Roamer icon as if it comes from that exocraft, while certainly not always the case. It is a total mess.

While messing with this issue, at some point the game started to show empty UI menus when checking inventory inside any of the exocraft vehicles. Not long after, the game decided to just crash on me, trying to figure out what is actually going on here. I have tried to figure out the issue, reloading my backup several times, adding the new Pilgrim or not, but it is being all weird. I give up for now as I have been running into several crashes by now, not even all related to this particular issue.

Empty menus before crashing

'Useless' Minidump (crash)
Dump File: NMS_crash_1538915636.dmp : C:\Users\Daimy\AppData\Local\Temp\NMS_crash_1538915636.dmp
Last Write Time: 10/7/2018 14:33:57
Process Name: NMS.exe : C:\SteamLibrary Active\steamapps\common\No Man’s Sky\Binaries\NMS.exe
Process Architecture: x64
Exception Code: 0xC0000005
Exception Information: The thread tried to read from or write to a virtual address for which it does not have the appropriate access.
Heap Information: Not Present

Followed by a list of all modules running, but will spare you all those details. Basically a generic exception, useless for trouble-shooting, because all crash reports look like this.

Now here is what I would love to know. Am I the only one seeing inventory issues with the exocraft? For me, using my backed-up save from the previous update where this issue did not exist, I keep seeing these exocraft inventories getting totally messed up, not being properly identified. Also seeing exocraft contents in other inventories like storage, ship, and even freighter in remote inventory menus. I quit playing until this issue is fixed, as I am likely going to waste my time.


#2

Hmph. They said the next update is going to focus mostly on quality-of-live improvements… My guess (and desperate hope) would be that they are actually working on a new inventory management. That would at least explain why the current one was not extended. Might be too much effort if the new system is only a week off. I hope that’s the explanation for it…


#3

These must be PC only issue as I’m not seeing any of this on PS4. I hope they sort it out for you.

EDIT: U was wrong.
See post further down.


#4

I could somewhat understand if they are actually reworking the inventory management, which I would love to see. The ‘first’ issue I mentioned and reported several times on Steam and likely Zendesk, is not really all that game-breaking. However, the issue with exocraft inventories being all messed up IS game-breaking. Due to inventories not being properly identified, making changes to these inventories will eventually lead to game corruption (as shown with the inventory empty menus) and cause crashes.

Most have not yet noticed these issues, although I am starting to see others mention the same bugs as well now on the Steam Forums. I have no doubt it will not take long before players start to realise how severe this issue actually is. I am hoping HG will realise this too and hotfix this before saves are getting ruined, whether they plan on making changes or not.


#5

I hope this issue is limited to PC, which is certainly possible considering I have seen plenty of different issues specific to the available platforms.


#6

I never use inventory in my exocraft so I can’t really address the issue however, they once again removed the quick transfer via the Y button on my xbox controller. The Y shows, next to my starship only, in the quick transfer list but, it does not function.
I will pack my exo bike later today and see what happens.


#7

I normally do not use my exocraft inventory either. Was just a result of moving to Eissentam and deleting all my bases I had in Euclid manually. Was left with just the Colossus having some tech upgrade modules for later use. I would have not noticed this soon either otherwise. However, with the added slots, additional exocraft, and race initiator supposedly fixed, I can see myself using their inventory again.

When it comes to quick transfer buttons, I have no clue what is used on XBox controllers. On PC, the actual transfer key is X, while Q and E allow to move to the previous/next selections.


#8

Sorry to hear about your inventory troubles DevilinPixy, it sounds like an absolute mess. Do you know if these troubles started before you built the Pilgrim?

I haven’t encountered these problems yet, but I’m on the PS4 and still have not built the Pilgrim. Hopefully the inventory mess will get sorted in the next patch and you can continue your journey :smiley:


#9

I do occasionally test experimental builds, but always with a separate/copied save, not to make any progress or actually play. I always delete experimental saves after I am done checking them out, to revert to my actual saves. I do this to make sure experimental never affects my saves.

I had not actually tried the experimental builds since 1.60. Once 1.63 released to public, I updated, only to actually start playing today for the first time with my ‘clean’ save I started when Next released (±350 hrs). So naturally, I started without the Pilgrim. I noticed right away, prior to getting the required Savaged Technology to unlock the Pilgrim in the Blueprint Analyser. I then spend a couple of hours trying to figure out what could possibly cause this issue. I have tested with and without the Pilgrim, as well as checking some other ‘new’ features, because I was really looking forward to this update as you can imagine.

I actually first checked my Freighter, as usual. No real issues, but still disappointed seeing all the Hydrophonic Trays showing in red, requiring fuel. Some crops popping in to their full grown state, others not, which is still another minor bug. Will spare you the details as to why this happens, knowing they will pop to their full grown state once fueled anyway.

I then checked my bases, Ring structure base on one planet and 4 bases on another, where at one of them my Geobays are located. At the same time I had prepared to get an actual Blueprint Analyser built as well as the Salvaged Technology and additional resources required to build the new stuff. I had never re-built another Blueprint Analyser because I no longer needed it and had moved to Eissentam.

So I arrived at my vehicle base, to further inspect, before even building the Pilgrim or the new Geobays. A bit disappointed with the re-designed geobays, because I could no longer access the terminals attached. Nothing wrong with the new design though, it is great, but I have floors over them where the terminals used to stick through for access. Now they are relocated further towards the edge, ending up in a lower position, no longer within reach, below the floors I made. This means I have to re-design or just live with it, while at the same time trying to figure out where to put the new Pilgrim.

Anyways, I knew about the issue, but before diving in deeper, I decided to check the customisation. Removed a floor part, just to find out, I could no longer place it back. So yeah, re-design most likely required, unless I do customisation elsewhere. I then checked to see how customising the Roamer would look. Awkward camera position, outside the garage of course, having to continuously rotate to actually see the result. Camera not sticking but always turning back to the default orientation shortly after changing. Annoying, but ok, changed colours some more, only to see my Roamer vanish. It was nowhere to be found anymore … on top of that, it decided to crash when checking the Colossus.

Reloaded my backup save, tried to reproduce the vanishing, but couldn’t … oh well. Then checked the inventories and see if there was any logic in what inventory management showed. I then built the Pilgrim Geobay, to see if that made a difference, only to be made aware of the other issue (max limit of 7 inventories in transfer menu). Having the Pilgrim made no difference and actually made things worse to properly test. Either way, I tested multiple times, reloading the backup several times, to come to the conclusion it is a total mess. Not worth risking getting my inventory all messed up, resulting in game corruption and eventually crashes.

All may be fine if I just do not touch exocraft inventory, but with all the new stuff now available and a wish to mess with it, I am not taking a risk to continue. Restored to my backup, until issues are properly sorted. Some bugs I can live with, others I am aware of how they affect saves and can cause corruption … Not willing to end up as I did with Atlas Rises, no matter how eager I am to continue …


#10

Previously I stated all seemed good with the PS4 Inventories.
No…it is most certainly not.

If you have all your exocraft present, you cannot access your vault storage via the quick tranfer menu.
Also, the inventories are mixed up with the Roamer and Collosos swapped plus the Pilgrim is not even accessible (quick menu)
My temp solution is to have a base with only minimal vehicles present, with all my vaults built on site so I can access them directly.
Also I’ve found the only way to interact properly with inventory in vehicles is to be in that particular vehicle.
It’s an absolute freeking mess atm. I’m not even sure how to word it so have not yet submitted to Zendesk.


#11

The icon for storage containers isn’t present anymore but pressing right an extra time still brings up the storage container inventory in my game


#12

I am sorry to hear you have been hit with this issue as well. For some reason it always shows all exocraft inventory in all quick transfer locations (any vehicle), besides the actual vehicle.

It is almost as if a ‘boolean’ check result (true/false) for vehicle inventory is switched, interpreted the opposite way. So instead of NOT showing inventory, it now always shows when it shouldn’t and doesn’t show when it should, if that makes sense.

I doubt they literally reverted a boolean type check, but it is easy to mess up the ‘TRUE’ outcome elsewhere, considering that would usually be only one case (true) vs many cases (false). So where it used to result in TRUE, this condition is no longer being met, to then always result in FALSE, reversing what we see. If this is actually the case, the issue should be easily fixed.

Anyways, I have noticed how reports of the above issue in several public locations, Steam being dominant, have been very rare, sadly enough. In all honesty, you are the 2nd person actually matching the issue I have been describing. You are on PS4, while the other mention/report I have seen including mine, are on PC (Steam). I am hoping that Zendesk has actually received many, or at least noticed my report, because it truly is a mess that needs fixing.


#13

You are correct that receiving items from storage is still possible by using hot-keys/buttons to reach the appropriate category, even though unable to show in the ‘limited to 7’ menu (no confirmation required).

The opposite direction (sending) is however impossible, even though reaching the selection is possible with hot-keys/buttons, because confirmation does not register due to being ‘out of visible bounds’ in the selection menu.

Edit: It is a rookie mistake to forget about the menu limitation (7 inventory options) when adding a new inventory to the game (Pilgrim). Usually a quick test would point out the issue, but oh well … to err is human…


#14

I’m going to try and compose a Zendesk report to send in for PS4. It’s hard to describe though…
If I was less of a gentleman I’d simply state that:
"The exocraft quick transfer is all f♧◇♡♤ up".
I’ll think of something…


#15

Report sent. :wink:


#16

Yes. Hard to describe so I will let the pics do the talking.
Quick Transfer from current vehicle via this method, no problems.


However, vehicle to vehicle transfer…
Here is what is in my Colossus, nothing

What is in my Nomad

My Roamer

My Pilgrim

When I try to transfer from Pilgrim to Roamer

Pilgrim to Colossus

Pilgrim to Nomad (which is the vehicle actually containing the above items)


#17

Wait a moment, that’s transfer TO.
I’m currently taking a break from NMS and playing daggerfall again for a bit, so I haven’t actually messed with this, but the pictures and descriptions you’re posting make perfect sense to me.

Essentially, you’re getting a window to transfer resources from any exocraft, not just the one you have as your main right now, to the one you select in the transfer window. So what you get in the transfer window are all the resources stored on any of the exocraft, except the one you’re targeting, since it wouldn’t make sense to transfer items from that craft to itself.
Seems a reasonable system to me, although I see how it could be confusing at first…

Oh wait, I see the problem. You don’t see the items in your current main exocraft in the transfer menu. Yeah, that’s definitely a bug.


#18

Yeah and don’t forget the send to other players menu when all exocrafts are listed is gone too.

Here is a good video about those never ending inventory bugs;


#19

Issue is still present with the latest update (1.64). I am going to take the risk playing again, as I have not yet crashed this time, where I did several times in 1.63.


#20

Issue still present in 1.65 …