I cannot load the ETARC forum on my PS4 anymore


#1

@oldgods When I try to open the ETARC website on my Playstation 4, the screen just goes blank, nothing loads at all. No links to any section of the discussion forum work, they are all blank. I am posting this from the computer at my work because I don’t have a PC. As it stands, I cannot access ETARC from my home because I don’t have a PC or smart phone, only a PS4.

Is anyone else that has a Playstation 4 having trouble opening the ETARC site on its internet browser?


#2

Verified. I can’t check via ps4 either. It looks like the page loads about 10%, then just goes white.


#3

First of all, I do not have a PS4 and am unable to test, but would suggest to check/try the following:

  • Make sure Javascript is enabled
  • Delete Browsing History
  • Delete Cookies
  • Check Free Space
  • Rebuild the Database
  • Optimize the Internet Connection by getting the DNS servers closest and fastest to you.
    Namebench or similar DNS benchmark software can be used, but requires PC.
  • Make sure to have the latest Firmware Update. (currently 4.73, although there is a beta 5.0)

Hope you can get it to work. If not, I would suggest to try Playstation Support.


#4

Yep, it’s the exact same thing for me.


#5

Can’t do any of those things on PS4 except rebuilding database. PS4 doesn’t let you download anything that Sony hasn’t approved, and I don’t think it allows cookies. I will try rebuilding the database, thank you.


#6

You should be able to do all I mentioned, besides benchmarking DNS, according to info I found online. I can however not verify as I do not own a PS4 myself.

Check this article for example that explains some of the suggestions I made:

For the other suggestions, check this page:

On a side note, I just had to delete all cookies using Chrome on PC, due to an error with ‘too many re-directs’ (net::ERR_TOO_MANY_REDIRECTS), which resulted in forums.etarc.org becoming completely unavailable. I know PS4 does not use Chrome, but is based on Safari instead, but something similar could have possibly happened, resulting in your blank screen when trying to visit.


#7

Rebuilding database did not help :frowning:

I thought the server migration might help, but it actually made it worse. Now, when I try to go to this forum on my PS4, it says “Not compatible with PS4 due to NAT type”. So it seems to me the server migration and image changes are what made it stop working on my PS4.


#9

Can you try https://forums.atlas-65.com/ directly and not go trough Etarc DNS?


#10

I don’t use my ps4 much but I also checked and tried the https://forums.atlas-65.com address and also just got a white screen. You can see the loading bar moving over but all you see is a blank white screen. Other addresses work fine.

It also says the PS4 doesn’t have the CA root certificate provided by the server.


#11

Yes, that URL shows up when I go there, but it is still a blank white screen. Thank you for the reply.


#12

Are you guys still getting error on PlayStation? If so, is it the same error as before?


#13

I will check again and get back with you when I work again on Monday. I can only post on here at work or if I go to the library.


#14

No, it’s still giving me the same error.


#15

Am I correct in saying these forums use Let’s Encrypt (Authority X3) certificates?

After trying to find more info on this, I found the following and hope this is useful for either those having issues, or those trying to fix the problem:
https://letsencrypt.org/docs/certificate-compatibility/
Which mentions PS3/PS4 to possibly have incompatibility with these specific certificates from Let’s Encrypt. SSL Lab’s Server Test does however show to complete the chain and grades atlas-65.com as A and forums.atlas-65.com as grade A+. See:
https://www.ssllabs.com/ssltest/
Also see the PS4 Web Content Guidelines:

I do believe that as of PS4 firmware 5.00 beta, Let’s Encrypt certificates are considered to be trusted and no longer throw issues.


#16

Yes! Same error no changes.

No matter what I try I can’t access the forum. Every other site seems fine. I can go on Steam. I can go on Reddit.
It seems to be that certificate error issue still.


#17

Same as before.


#18

You were right! PS4 5.00 fixed it so I can visit this forum again! Hooray!


#19

@DevilinPixy :handshake: @Anashel. Stoked ur back @MacForADay.

Is it fixed for @Xion4012 and @Wyo? …here’s hoping. :pray:


#20

It works. A big thanks to @Anashel and the rest of the team :blush:


#21

I’ll have to try it tonight!