Freighter upper floors all gone

I am playing on PC (Steam) version 2.06c, current default, with an existing NEXT save.

Just tested to have a look at how my save survived the update(s). Nothing special done at all yet. Just loaded in and went to see. Funny to load in outside my space ship in space by the way, which I could only just enter in time to avoid death. I was not aware we could create an auto-save by exiting ship in space.

Bases appear ok, besides the announced missing landing pads.
My Freighter however, is missing all floors above the main floor, which itself appears ok. I used to have multiple rooms and floors above the main floor however, which included all my frigate mission command rooms. Not to mention loads of building items and creative areas/rooms I had created over time.

For as far as I am aware, multiple floors on a freighter are still a thing.

I have attempted a previous auto-save with the same result.

I am pretty sad about this to be honest. I knew I shouldn’t have tried, as I am now likely going to spend some time attempting to fix it.

Anyone else experienced the same?


Stairs are still in the build items. I have an issue with my storage rooms being disconnected from the hallways that lead to them . At first they were inaccessible. That was fixed but not the gap. Maybe your second floor is detached…


I tried placing rooms to see if my stairs would attach to something, but there is nothing above first floor at all, everything is gone :frowning:


On a new game. I just rescued a Freighter. Trying to build the Command room and there seems to be issues with placement. I normally place the Command room on the left most area pictured below. The placement would turn green but did not actually connect to the hallway when I tried placing it. I had to place the room to the far right to make it work.
The Command room is the same size as before.

When I tried to place it where I wanted it, the place I am pointing to below (my pre-BEYOND location) it refused to do so and placed it to the far left down the left hallway.
Hope that makes sense.

EDIT: To add to the fun, after having my Command room misplaced, I ran to check out the large area at the back of the Freighter and guess what…

There is already a Command room aboard…

To check out the multi floor capabilities, I was able to place out 3 ramps before running out of silver.


When placing rooms on the Command Ship (Freighter), you need to stand directly in line with the room you are placing as it won’t click otherwise. I had to build straight ahead, then turn at a right angle to extend my chosen area.
Might need to build a dummy room to give access and then remove it once your done if it disrupts your plans


Ok. I thought I tried standing everywhere. Also tried with and without the new build camera