Anyone having trouble finding missions?


#1

Im on ps4 and now im at a part of the main story where I have to complete 3 missions for the mercenaries guild. Thing is, I spent all day yesterday jumping to all kinds of systems, in the missions listing I can find race related mission, trade/explorer guild mission, but the only MG missions I see are level 3-8 and since I never did any mission for them, I need at maximum a rank 2, can’t find any. Anyone encountered that ?


#2

I’ve gotten plenty of them. What you could try though, is completing several of the others (the ones you don’t need), they’ll be replaced by random other ones, so eventually you’re bound to get some. I believe most “exterminate fauna” and “kill sentinel” missions belong to the mercenaries.


#3

Yeah, I see those but they’re always to high level. It may be because I already maxed out my relationship with the races, but I still get appropriately leveled missions from the other factions. I’ve taken on other missions but if I can’t progress in an hour or two, im considering starting over in creative.


#4

go to log page, this is the grind part, see how many missions you need to move to next level, take the missions to move up in rank, REMEMBER there are now 4 parts to relationships with alien races.


#5

I can’t take the mercenaries faction missions to move up in rank, that’s my problem. Are you saying there’s another type of mission that would raise my relationship with the mercenaries faction?


#6

no … wife had the problem on PS4, she was able to do other missions to raise level to advance , she was not too happy about the grind :slight_smile:


#7

Not sure what you mean. Thing is, I need to do 3 mercenaries missions to advance, not raise my level. I need to raise my level to at least 3 in the mercenaries guild to be able to do those 3 missions, as no missions below level 3 appears. Now I’ve done about 60 missions of all kind ( race related, guild related ) and still no change. Just got my 31 slot superfreighter. Would suck to have to restart because I can’t continue with the main story.


#8

I also have the problem that i completed quite a lot of mission but didn’t get progress anywhere. I only have 1 progressed mission at vy’keen, nothing more :confused:


#9

I decided to back up my save and start over to see if it’s gonna fix something. If anybody figure something out, let me know.


#10

Is everything the same in Creative mode? I mean is there the Atlas Path? The Arthemis Path etc?


#11

I don’t know, im gonna find out right now and let you know as I progress. Might be interesting to see if ther’s any differences.


#12

So far, I don’t have to repair my ship.


#13

I just got the message from Arthemis, but I dont even remember how I embarked on the Atlas path a year ago.