Decals Not Showing

Decals not showing when trying to place them on my Freighter. If you place them, they may or may not show. I have placed a couple and I do not know where they are…(looking for a mirror to check my back)


Try removing the rectangular decorative panel before applying decals in a freighter.
Panning about in ‘delete’ will reveal a hidden object because nothing seems to highlight.
Press delete and you’ll hear the audio of something getting deleted. Works on PS4 anyway.


I was placing these on curved walls…but I will keep that in mind. I placed a few on some flat walls only to find it on top of my old decal. I was able to delete both and then place a new one. The old one did not show until the new one was over it. None of them show as I am placing them.


On a sort of unrelated note, do the decals still have massive invisible geometry? I remember in next during the community events, the new decals, if placed on the wall of a narrow tunnel you’ve dug etc, it would block your path and nothing could be built around them.

I’ll be trying out some decals tonight on a freighter (one jump away from my free one :D) will report how I get on when I get on


I really could not answer that question since I cannot see the decals when placing them. I have only placed a few so I have not had any that were partial or incomplete.

The decals do actually appear to still be there. I have seen most my decals being fine on my planetary bases. On my freighter however, where they are placed on top a panel, they seem to not be visible anymore (@Mad-Hatter). I have not tried replacing them in the same way to see if that works. Maybe placement has changed somewhat, with offsets not being correct anymore?


Confirmed. I thought my decals were gone. When I put new decaals down in the same spot, it caused the old ones to show under the new one. This is only on my Freighter


I just tried a new approach with the decals I knew were supposed to be there.

Go into your build menu and aim at the location where a decal is supposed to show. Nothing should light up or show selected, to make sure you are not aiming at a selected room or other object. This indicates the decal is actually still there, just not visible.

Now instead of risking to delete it, to replace again after, just go into the ‘Colour’ option (CTRL PC/Keyboard) and change it. It will then go to ‘Material’, which selects the result. For me the decal appeared again when testing it on number decals I knew were supposed to be there.

Decal on a ‘Panel’ (black) on the back wall of a Storage Room on my freighter.

Edit: Pretty annoying you can’t even see a preview when trying to normally place a decal, as if they default to ‘transparent’?