Some VR Bugs

Hello, please move if there is a similar topic, I could not find one. Wanted to make a space dedicated to VR bugs and help. Ill start off. Has anyone else experienced the planet info when leaving ship being to far out of frame to read? I will post a screenshot next time I jump in via VR.


I added the Bugs and Issues tag. Carry on. Hoping to get VR as well. Waiting for things to calm down.


Not sure if this is a bug isolated to VR or if it’s present across both playstyles.

I came across my first tradestation last night in my new playthrough and was overjoyed by the new ladders.

However I soon learned once you use a ladder, you can never use it again. The VR prompt to “pull it” has gone, it’s like it thinks you just plucked a plant or searched a crate so no need to prompt again kinda thing.

Also cannot sit in chairs in VR. Only chairs with a prompt are spinny ones, the prompt is “collect item” and it just spins the chair. I’m totally okay with this cos I can just sit down virtually haha.

Haven’t checked latest two patch notes so it’s possible this issues are no longer present.


Even in non-VR, you can not sit in all chairs. Only certain ones. Not sure why. Mostly couches are available for sitting in. Perhaps only couches? Not sure.


Don’t let the VR player punch in places they aren’t allow to use weapons.

Boo! That shouldnt be a bug :facepunch:

Can confirm, that happens for me as well. PC Oculus Rift CV1.


For those in VR getting black squares when mining resources, check the video posted below:

1 Like

Not a bug, I was just wondering. When you bust up asteroids now, it seems larger pieces fly off in every direction including right back at you. Just wondering if anyone in VR has experienced that yet and if so, what was it like…thinking of getting VR once the bugs are smoothed out.


Not that I have noticed. Do they come into the cockpit?

I did accidentally jump over a smoke stack and I’m sure I could smell…some mineral smoke…and then coughed. I didn’t realise it was there so took me by surprise.

One bug in VR is that there is no way to zoom in on the analyser view - normally you’d click it a few times to zoom in further and further. The keymap is missing and I haven’t bothered to look up how to change it yet. Someone mentioned steam mapping, but I’ve seen no actual guides on how to do it.

I think I’ll probably have to do it manually using the controls config.


I have not seen any asteroid bits fly into the cockpit. But some have been close.

So I spent 15 mins collecting asteroid rocks and some fragments came very close to hitting the ship - I might have ducked - but couldn’t get any to hit dead centre between my eyes. Vr NMS is amazing, especially with all the new stuff they’ve added.

If you are going to get VR, google earth is also amazing. But it takes some while to get used to it without feeling a bit ill and disorientated. Probably best not to use smooth movements in NMS while in the learning zone.

When I first got mine, I’d sit on a chair with nothing around me and put a cushion under my feet, something to ground me in reality.


Anyone have the big hands glitch yet?

It happened to me after I redeemed the pre order ship (which I’d totally forgotten about until now) and climbed inside. Hands were really big but also everything was much further away and hard to reach :joy:

I can’t grab time code from the YouTube app or from my mobiles browser, I tried adding the timestamp to the url but in preview before post it doesn’t look like it wants to behave.

Big hands happen at 2h 26m just before end of video.


Are your hands normal again in any other ship? They do seem to fit the ship controls at least. There is/was an issue with some character models (character customisation) where placement was off in some cases. Give it some further testing and report the issue.

You did the YouTube url with time stamp correctly, the preview will not match, but as soon as you play the embed here, it will link to the correct time.


It’s a new save so I just have the one ship which turned into my pre order ship even though I hit add to collection instead of exchange. Was hoping I could keep my starter ship too.

As soon as I got out my hands returned to normal size but they felt tiny after having big hands for so long :slight_smile:

Will do some more testing when I get home and report my findings


Updating to the latest Steam VR Beta may help stuttering


I used the Space Station Appearance Machine and my hands only worked 1/4 of the time. One time i was missing the left hand completely. It still worked, just no model was shown. Seems to be ok with the standard sized models and the first set of hands.

Hands seem OK now, or at least aren’t invisible.