Major Freighter Issue

I flew into a system and found this nice looking fleet.

Decided to take a look at the Freighter. The Captain seemed nice enough. I should have known something was not right though.
He only asked 4mil for it. So I took it because it was so much prettier than mine.
Then I tried to place a Command Room. It will not place.

I ran toward the back of the Freighter hoping to find a place to build it but I was stopped by an invisible barrier at the end of the first hallway.

This is a disaster.


Something similar happened to me yesterday. Not exactly the same, but…

Try leaving the freighter, moving to another system, calling your freighter, and boarding it again.

It seems the game is getting mixed up between settings for your old freighter and your new one.


Reported and sent pics.
Funny thing. It shows a Base icon right in the doorway of the first door from the hangar.


In 3xperimental HG is trying to fix the Command Room placement, though not quite successful yet. It also appears that these invisible walls inside are new to the experimental update, or I had just not seen reports of it prior. Strange things are happening.

I have personally left my Freighter in the exact location it has been prior to Beyond, for good reason. For placing my Command Rooms I had to resort to manually adding the data in the save editor, due to a similar issue with not wanting to be placed. This was quite a while ago though.

I am assuming the new issues that came with experimental are being sorted before going live, which explains the current delay.


Funny indeed, even though it is technically a base and stored in the same location, just treated somewhat different. No reason for the icon though, which makes one wonder … :wink:


I had no problem placing my previous command room. Now it really is unplaceable…


I do not know if it was today’s update or a restart but, I can now place my Command Room and access the back of my Freighter.

However, I then died…ha ha…just my own mistake. Not a glitch.


I’ve gotten into the habit of moving my freighter just slightly before boarding it. I have fewer problems with it if I do that first.

Glad you got it to work again. :+1:


My freighter allowed me to put a command room down like this (by accident --not glitch building):

And of course, when deleted, it took the working one with it. :sigh: